slackbuilds_ponce/network/nss-mdns/look-in-run-for-avahi-socket.patch
Robby Workman 29a2bca7b8
network/nss-mdns: Look in /run for avahi daemon socket
This fixes nss-mdns functionality since avahi was upgraded and
changed to use /run for its socket.

This build could be fixed by using --localstatedir=/ instead,
but it looks wrong (even if it's correct in this case), so I
decided to go with the patch instead.

Thanks to Lioh Moeller for the bug report.

Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
2019-08-31 17:13:20 +07:00

24 lines
1.1 KiB
Diff

diff -Nur nss-mdns-0.10.orig/src/Makefile.am nss-mdns-0.10/src/Makefile.am
--- nss-mdns-0.10.orig/src/Makefile.am 2007-02-08 10:42:23.000000000 -0600
+++ nss-mdns-0.10/src/Makefile.am 2019-08-28 23:24:49.690739951 -0500
@@ -22,7 +22,7 @@
AM_CFLAGS = \
-DMDNS_ALLOW_FILE=\"$(sysconfdir)/mdns.allow\" \
-DRESOLV_CONF_FILE=\"$(sysconfdir)/resolv.conf\" \
- -DAVAHI_SOCKET=\"$(localstatedir)/run/avahi-daemon/socket\"
+ -DAVAHI_SOCKET=\"/run/avahi-daemon/socket\"
#AM_CFLAGS += -DNDEBUG=1 -Os
diff -Nur nss-mdns-0.10.orig/src/Makefile.in nss-mdns-0.10/src/Makefile.in
--- nss-mdns-0.10.orig/src/Makefile.in 2007-05-12 09:55:34.000000000 -0500
+++ nss-mdns-0.10/src/Makefile.in 2019-08-28 23:24:39.273681707 -0500
@@ -409,7 +409,7 @@
# This cool debug trap works on i386/gcc only
AM_CFLAGS = -DMDNS_ALLOW_FILE=\"$(sysconfdir)/mdns.allow\" \
-DRESOLV_CONF_FILE=\"$(sysconfdir)/resolv.conf\" \
- -DAVAHI_SOCKET=\"$(localstatedir)/run/avahi-daemon/socket\" \
+ -DAVAHI_SOCKET=\"/run/avahi-daemon/socket\" \
'-DDEBUG_TRAP=__asm__("int $$3")'
AM_LDFLAGS = -avoid-version -module -export-dynamic
lib_LTLIBRARIES = $(am__append_1) $(am__append_2)