slackbuilds_ponce/audio/TiMidity++/patches/autoconf.diff
Kyle Guinn 59c25301a2 audio/TiMidity++: Updated for version 2.14.0.
Autodetect instrument patch files

Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
2012-12-20 14:56:16 +01:00

206 lines
7.2 KiB
Diff

diff -Nur a/autoconf/libOggFLAC.m4 b/autoconf/libOggFLAC.m4
--- a/autoconf/libOggFLAC.m4 2012-06-01 06:45:45.000000000 +0300
+++ b/autoconf/libOggFLAC.m4 1970-01-01 02:00:00.000000000 +0200
@@ -1,116 +0,0 @@
-# Configure paths for libOggFLAC
-# "Inspired" by ogg.m4
-
-dnl AM_PATH_LIBOGGFLAC([ACTION-IF-FOUND [, ACTION-IF-NOT-FOUND]])
-dnl Test for libOggFLAC, and define LIBOGGFLAC_CFLAGS and LIBOGGFLAC_LIBS
-dnl
-AC_DEFUN([AM_PATH_LIBOGGFLAC],
-[dnl
-dnl Get the cflags and libraries
-dnl
-AC_ARG_WITH(libOggFLAC,
- AS_HELP_STRING([--with-libOggFLAC=PFX],
- [Prefix where libOggFLAC is installed (optional)]),
- [libOggFLAC_prefix="$withval"], [libOggFLAC_prefix=""])
-AC_ARG_WITH(libOggFLAC-libraries,
- AS_HELP_STRING([--with-libOggFLAC-libraries=DIR],
- [Directory where libOggFLAC library is installed (optional)]),
- [libOggFLAC_libraries="$withval"], [libOggFLAC_libraries=""])
-AC_ARG_WITH(libOggFLAC-includes,
- AS_HELP_STRING([--with-libOggFLAC-includes=DIR],
- [Directory where libOggFLAC header files are installed (optional)]),
- [libOggFLAC_includes="$withval"], [libOggFLAC_includes=""])
-AC_ARG_ENABLE(libOggFLACtest,
- AS_HELP_STRING([--disable-libOggFLACtest],
- [Do not try to compile and run a test libOggFLAC program]),,
- [enable_libOggFLACtest=yes])
-
- if test "x$libOggFLAC_libraries" != "x" ; then
- LIBOGGFLAC_LIBS="-L$libOggFLAC_libraries"
- elif test "x$libOggFLAC_prefix" != "x" ; then
- LIBOGGFLAC_LIBS="-L$libOggFLAC_prefix/lib"
- elif test "x$prefix" != "xNONE" ; then
- LIBOGGFLAC_LIBS="-L$prefix/lib"
- fi
-
- LIBOGGFLAC_LIBS="$LIBOGGFLAC_LIBS -lOggFLAC -lFLAC -lm"
-
- if test "x$libOggFLAC_includes" != "x" ; then
- LIBOGGFLAC_CFLAGS="-I$libOggFLAC_includes"
- elif test "x$libOggFLAC_prefix" != "x" ; then
- LIBOGGFLAC_CFLAGS="-I$libOggFLAC_prefix/include"
- elif test "$prefix" != "xNONE"; then
- LIBOGGFLAC_CFLAGS="-I$prefix/include"
- fi
-
- AC_MSG_CHECKING(for libOggFLAC)
- no_libOggFLAC=""
-
-
- if test "x$enable_libOggFLACtest" = "xyes" ; then
- ac_save_CFLAGS="$CFLAGS"
- ac_save_CXXFLAGS="$CXXFLAGS"
- ac_save_LIBS="$LIBS"
- CFLAGS="$CFLAGS $LIBOGGFLAC_CFLAGS"
- CXXFLAGS="$CXXFLAGS $LIBOGGFLAC_CFLAGS"
- LIBS="$LIBS $LIBOGGFLAC_LIBS"
-dnl
-dnl Now check if the installed libOggFLAC is sufficiently new.
-dnl
- rm -f conf.libOggFLACtest
- AC_TRY_RUN([
-#include <stdio.h>
-#include <stdlib.h>
-#include <string.h>
-#include <OggFLAC/stream_decoder.h>
-
-int main ()
-{
- system("touch conf.libOggFLACtest");
- return 0;
-}
-
-],, no_libOggFLAC=yes,[echo $ac_n "cross compiling; assumed OK... $ac_c"])
- CFLAGS="$ac_save_CFLAGS"
- LIBS="$ac_save_LIBS"
- fi
-
- if test "x$no_libOggFLAC" = "x" ; then
- AC_MSG_RESULT(yes)
- ifelse([$1], , :, [$1])
- else
- AC_MSG_RESULT(no)
- if test -f conf.libOggFLACtest ; then
- :
- else
- echo "*** Could not run libOggFLAC test program, checking why..."
- CFLAGS="$CFLAGS $LIBOGGFLAC_CFLAGS"
- LIBS="$LIBS $LIBOGGFLAC_LIBS"
- AC_TRY_LINK([
-#include <stdio.h>
-#include <OggFLAC/stream_decoder.h>
-], [ return 0; ],
- [ echo "*** The test program compiled, but did not run. This usually means"
- echo "*** that the run-time linker is not finding libOggFLAC or finding the wrong"
- echo "*** version of libOggFLAC. If it is not finding libOggFLAC, you'll need to set your"
- echo "*** LD_LIBRARY_PATH environment variable, or edit /etc/ld.so.conf to point"
- echo "*** to the installed location Also, make sure you have run ldconfig if that"
- echo "*** is required on your system"
- echo "***"
- echo "*** If you have an old version installed, it is best to remove it, although"
- echo "*** you may also be able to get things to work by modifying LD_LIBRARY_PATH"],
- [ echo "*** The test program failed to compile or link. See the file config.log for the"
- echo "*** exact error that occured. This usually means libOggFLAC was incorrectly installed"
- echo "*** or that you have moved libOggFLAC since it was installed. In the latter case, you"
- echo "*** may want to edit the libOggFLAC-config script: $LIBOGGFLAC_CONFIG" ])
- CFLAGS="$ac_save_CFLAGS"
- LIBS="$ac_save_LIBS"
- fi
- LIBOGGFLAC_CFLAGS=""
- LIBOGGFLAC_LIBS=""
- ifelse([$2], , :, [$2])
- fi
- AC_SUBST(LIBOGGFLAC_CFLAGS)
- AC_SUBST(LIBOGGFLAC_LIBS)
- rm -f conf.libOggFLACtest
-])
diff -Nur a/autoconf/Makefile.am b/autoconf/Makefile.am
--- a/autoconf/Makefile.am 2004-05-30 11:02:23.000000000 +0300
+++ b/autoconf/Makefile.am 2012-10-13 18:19:32.837584323 +0200
@@ -25,7 +25,6 @@
gtk.m4 \
gtk-2.0.m4 \
libFLAC.m4 \
- libOggFLAC.m4 \
ogg.m4 \
utils.m4 \
vorbis.m4
\ No newline at end of file
diff -Nur a/configure.in b/configure.in
--- a/configure.in 2012-06-28 17:14:25.000000000 +0300
+++ b/configure.in 2012-10-13 18:19:14.806923746 +0200
@@ -889,7 +889,7 @@
jack: JACK
ao: Libao
vorbis: Ogg Vorbis
- flac: FLAC / OggFLAC
+ flac: FLAC
speex: Ogg Speex
gogo: MP3 GOGO (Only Windows is supported)
],
@@ -1393,23 +1393,10 @@
AC_MSG_CHECKING(enable_audio=flac)
if test "x$au_enable_flac" = xyes; then
AC_MSG_RESULT([yes, configuring flac])
- SYSEXTRAS="$SYSEXTRAS flac_a.c w32_libFLAC_dll.c w32_libOggFLAC_dll.c"
+ SYSEXTRAS="$SYSEXTRAS flac_a.c w32_libFLAC_dll.c"
AC_CHECK_HEADER(FLAC/all.h, [
EXTRADEFS="$EXTRADEFS -DAU_FLAC -DAU_FLAC_DLL"
])
- AC_CHECK_HEADER(OggFLAC/all.h, [
- EXTRADEFS="$EXTRADEFS -DAU_OGGFLAC -DAU_OGGFLAC_DLL"
- ])
-dnl AM_PATH_LIBFLAC([
-dnl EXTRADEFS="$EXTRADEFS -DAU_FLAC -DAU_FLAC_DLL"
-dnl EXTRACT_CPPFLAGS(CPPFLAGS,CFLAGS,$LIBFLAC_CFLAGS)
-dnl LIBS="$LIBS $LIBFLAC_LIBS"
-dnl ])
-dnl AM_PATH_LIBOGGFLAC([
-dnl EXTRADEFS="$EXTRADEFS -DAU_OGGFLAC -DAU_OGGFLAC_DLL"
-dnl EXTRACT_CPPFLAGS(CPPFLAGS,CFLAGS,$LIBOGGFLAC_CFLAGS)
-dnl LIBS="$LIBS $LIBOGGFLAC_LIBS"
-dnl ])
else
AC_MSG_RESULT(no)
fi
@@ -1423,11 +1410,6 @@
EXTRACT_CPPFLAGS(CPPFLAGS,CFLAGS,$LIBFLAC_CFLAGS)
LIBS="$LIBS $LIBFLAC_LIBS"
])
- AM_PATH_LIBOGGFLAC([
- EXTRADEFS="$EXTRADEFS -DAU_OGGFLAC"
- EXTRACT_CPPFLAGS(CPPFLAGS,CFLAGS,$LIBOGGFLAC_CFLAGS)
- LIBS="$LIBS $LIBOGGFLAC_LIBS"
- ])
else
AC_MSG_RESULT(no)
fi
diff -Nur a/timidity/Makefile.am b/timidity/Makefile.am
--- a/timidity/Makefile.am 2008-03-30 05:31:07.000000000 +0300
+++ b/timidity/Makefile.am 2012-10-13 18:19:32.837584323 +0200
@@ -157,11 +157,7 @@
w32_libFLAC_dll.c \
w32_libFLAC_dll.h \
w32_libFLAC_dll_g.h \
- w32_libFLAC_dll_i.h \
- w32_libOggFLAC_dll.c \
- w32_libOggFLAC_dll.h \
- w32_libOggFLAC_dll_g.h \
- w32_libOggFLAC_dll_i.h
+ w32_libFLAC_dll_i.h
calcnewt_SOURCES = calcnewt.c
@@ -442,7 +438,7 @@
version.$(OBJEXT): version.c ../configure
$(CC) $(DEFS) $(DEFAULT_INCLUDES) $(CFLAGS) -c $(srcdir)/version.c
-resample.c: newton_table.c
+$(srcdir)/resample.c: newton_table.c
if VCPP
newton_table.c: calcnewt$(EXEEXT)