slackbuilds_ponce/libraries/FreeImage/Makefile.fip.DESTDIR.diff
2010-05-13 00:28:31 +02:00

41 lines
1.6 KiB
Diff

--- FreeImage/Makefile.fip.orig 2009-09-07 01:09:47.000000000 -0500
+++ FreeImage/Makefile.fip 2009-09-07 01:27:12.000000000 -0500
@@ -15,16 +15,11 @@
MODULES = $(SRCS:.c=.o)
MODULES := $(MODULES:.cpp=.o)
-CFLAGS ?= -O3 -fexceptions -fvisibility=hidden
+CFLAGS ?= -fexceptions -fvisibility=hidden
CFLAGS += $(INCLUDE)
-CXXFLAGS ?= -O3 -fexceptions -fvisibility=hidden -Wno-ctor-dtor-privacy
+CXXFLAGS ?= -fexceptions -fvisibility=hidden -Wno-ctor-dtor-privacy
CXXFLAGS += $(INCLUDE)
-ifeq ($(shell sh -c 'uname -m 2>/dev/null || echo not'),x86_64)
- CFLAGS += -fPIC
- CXXFLAGS += -fPIC
-endif
-
TARGET = freeimageplus
STATICLIB = lib$(TARGET).a
SHAREDLIB = lib$(TARGET)-$(VER_MAJOR).$(VER_MINOR).so
@@ -62,11 +57,14 @@
$(CC) -shared -Wl,-soname,$(VERLIBNAME) $(LDFLAGS) -o $@ $(MODULES) $(LIBRARIES)
install:
- install -d $(INCDIR) $(INSTALLDIR)
- install -m 644 -o root -g root $(HEADER) $(INCDIR)
- install -m 644 -o root -g root $(HEADERFIP) $(INCDIR)
- install -m 644 -o root -g root $(STATICLIB) $(INSTALLDIR)
- install -m 755 -o root -g root $(SHAREDLIB) $(INSTALLDIR)
+ install -d 755 $(DESTDIR)/$(INCDIR)
+ install -m 644 $(HEADER) $(DESTDIR)/$(INCDIR)
+ install -m 644 $(HEADERFIP) $(DESTDIR)/$(INCDIR)
+ install -d 755 $(DESTDIR)/$(INSTALLDIR)
+ install -m 644 $(STATICLIB) $(DESTDIR)/$(INSTALLDIR)
+ install -m 755 $(SHAREDLIB) $(DESTDIR)/$(INSTALLDIR)
+ cd $(DESTDIR)/$(INSTALLDIR) ; ln -sf $(SHAREDLIB) $(VERLIBNAME)
+ cd $(DESTDIR)/$(INSTALLDIR) ; ln -sf $(VERLIBNAME) $(LIBNAME)
clean:
rm -f core Dist/*.* u2dtmp* $(MODULES) $(STATICLIB) $(SHAREDLIB) $(LIBNAME)