mirror of
https://github.com/Ponce/slackbuilds
synced 2024-12-01 01:00:03 +01:00
5c19a16771
If libmediainfo is compiled with optional tinyxml dep, mediainfo compilation will fail without this patch. Fix will be included in next release. https://github.com/MediaArea/MediaInfoLib/pull/1434 Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
33 lines
1.4 KiB
Diff
33 lines
1.4 KiB
Diff
From 038dff8433053aada3e8bf34655e2cec67305c5c Mon Sep 17 00:00:00 2001
|
|
From: Jan Palus <jpalus@fastmail.com>
|
|
Date: Wed, 22 Sep 2021 12:10:41 +0200
|
|
Subject: [PATCH] ADM: compile-in tfsxml unconditionally (unrelated to
|
|
tinyxml2)
|
|
|
|
Fixes unresolved symbols when compiling with system tinyxml2.
|
|
---
|
|
Project/GNU/Library/Makefile.am | 4 ++--
|
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/Project/GNU/Library/Makefile.am b/Project/GNU/Library/Makefile.am
|
|
index ffa05219e..7cf200670 100644
|
|
--- a/Project/GNU/Library/Makefile.am
|
|
+++ b/Project/GNU/Library/Makefile.am
|
|
@@ -230,7 +230,8 @@ lib@MediaInfoLib_LibName@_la_SOURCES = \
|
|
../../../Source/MediaInfo/Video/File_Vp8.cpp \
|
|
../../../Source/MediaInfo/Video/File_Y4m.cpp \
|
|
../../../Source/MediaInfo/XmlUtils.cpp \
|
|
- ../../../Source/MediaInfo/OutputHelpers.cpp
|
|
+ ../../../Source/MediaInfo/OutputHelpers.cpp \
|
|
+ ../../../Source/ThirdParty/tfsxml/tfsxml.c
|
|
|
|
@MediaInfoLib_LibName@includedir = $(includedir)/MediaInfo
|
|
@MediaInfoLib_LibName@include_HEADERS = \
|
|
@@ -280,7 +281,6 @@ endif
|
|
|
|
if COMPILE_TINYXML2
|
|
lib@MediaInfoLib_LibName@_la_SOURCES += \
|
|
- ../../../Source/ThirdParty/tfsxml/tfsxml.c \
|
|
../../../Source/ThirdParty/tinyxml2/tinyxml2.cpp
|
|
endif
|
|
|