slackbuilds_ponce/network/dsniff/patches/35_Add_CPPFLAGS.patch
Matteo Bernardini f706b0bc33 network/dsniff: Update to the latest debian patches.
Thanks to USUARIONUEVO for the report

Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
2021-04-17 23:19:28 -05:00

50 lines
1.3 KiB
Diff

Description: import CPPFLAGS in order to build an ELF binary that uses fortified libc functions. Now it is built with all default Debian compiler flags.
Author: Marcos Fouces <marcos.fouces@gmail.com>
---
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
--- a/Makefile.in
+++ b/Makefile.in
@@ -11,12 +11,13 @@
install_prefix =
prefix = @prefix@
exec_prefix = @exec_prefix@
-libdir = $(prefix)/share/dsniff
+libdir = @libdir@
sbindir = @sbindir@
mandir = @mandir@
CC = @CC@
CFLAGS = @CFLAGS@ -DDSNIFF_LIBDIR=\"$(libdir)/\"
+CPPFLAGS = @CPPFLAGS@
LDFLAGS = @LDFLAGS@
PCAPINC = @PCAPINC@
@@ -37,7 +38,8 @@
X11INC = @X_CFLAGS@
X11LIB = @X_LIBS@ @X_PRE_LIBS@ -lXmu -lX11 @X_EXTRA_LIBS@
-INCS = -I. $(X11INC) -I$(srcdir)/missing
+INCS = -I. $(NIDSINC) $(PCAPINC) $(LNETINC) $(DBINC) $(SSLINC) $(X11INC) \
+ -I$(srcdir)/missing
LIBS = @LIBS@ -L$(srcdir) -lmissing
INSTALL = @INSTALL@
@@ -73,7 +75,7 @@
CONFIGS = dsniff.magic dsniff.services dnsspoof.hosts
.c.o:
- $(CC) $(CFLAGS) $(INCS) -c $(srcdir)/$*.c
+ $(CC) $(CFLAGS) $(CPPFLAGS) $(INCS) -c $(srcdir)/$*.c
all: $(PROGS)
@@ -98,7 +100,7 @@
filesnarf.o: nfs_prot.h
$(LIBOBJS):
- $(CC) $(CFLAGS) $(INCS) -c $(srcdir)/missing/$*.c
+ $(CC) $(CFLAGS) $(CPPFLAGS) $(INCS) -c $(srcdir)/missing/$*.c
libmissing.a: $(LIBOBJS)
ar -cr $@ $(LIBOBJS)