slackbuilds_ponce/system/ansible/Makefile.patch
Alex Diaconu a9a2f3683a system/ansible: Added (a ssh based config management framework)
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
2013-07-07 09:11:41 -03:00

55 lines
1.8 KiB
Diff

--- a/Makefile 2013-07-05 14:59:24.000000000 +0200
+++ b/Makefile 2013-07-05 15:01:21.000000000 +0200
@@ -21,34 +21,13 @@
# This doesn't evaluate until it's called. The -D argument is the
# directory of the target file ($@), kinda like `dirname`.
MANPAGES := docs/man/man1/ansible.1 docs/man/man1/ansible-playbook.1 docs/man/man1/ansible-pull.1 docs/man/man1/ansible-doc.1
-ifneq ($(shell which a2x 2>/dev/null),)
-ASCII2MAN = a2x -D $(dir $@) -d manpage -f manpage $<
-ASCII2HTMLMAN = a2x -D docs/html/man/ -d manpage -f xhtml
-else
-ASCII2MAN = @echo "ERROR: AsciiDoc 'a2x' command is not installed but is required to build $(MANPAGES)" && exit 1
-endif
-PYTHON=python
+PYTHON=python2
SITELIB = $(shell $(PYTHON) -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")
# VERSION file provides one place to update the software version
VERSION := $(shell cat VERSION)
-# Get the branch information from git
-ifneq ($(shell which git),)
-GIT_DATE := $(shell git log -n 1 --format="%ai")
-endif
-
-ifeq ($(OS), FreeBSD)
-DATE := $(shell date -j -f "%Y-%m-%d %H:%M:%s" "$(GIT_DATE)" +%Y%m%d%H%M)
-else
-ifeq ($(OS), Darwin)
-DATE := $(shell date -j -f "%Y-%m-%d %H:%M:%S" "$(GIT_DATE)" +%Y%m%d%H%M)
-else
-DATE := $(shell date --utc --date="$(GIT_DATE)" +%Y%m%d%H%M)
-endif
-endif
-
# RPM build parameters
RPMSPECDIR= packaging/rpm
RPMSPEC = $(RPMSPECDIR)/ansible.spec
@@ -74,16 +53,6 @@
authors:
sh hacking/authors.sh
-# Regenerate %.1.asciidoc if %.1.asciidoc.in has been modified more
-# recently than %.1.asciidoc.
-%.1.asciidoc: %.1.asciidoc.in
- sed "s/%VERSION%/$(VERSION)/" $< > $@
-
-# Regenerate %.1 if %.1.asciidoc or VERSION has been modified more
-# recently than %.1. (Implicitly runs the %.1.asciidoc recipe)
-%.1: %.1.asciidoc VERSION
- $(ASCII2MAN)
-
loc:
sloccount lib library bin