mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-22 19:44:21 +01:00
c1a8fd4994
Also added the new dependency six Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
20 lines
552 B
Diff
20 lines
552 B
Diff
=== modified file 'setup.py'
|
|
--- setup.py 2012-04-29 13:32:22 +0000
|
|
+++ setup.py 2012-04-29 13:34:16 +0000
|
|
@@ -1,5 +1,6 @@
|
|
#!/usr/bin/python
|
|
from os.path import isfile, join
|
|
+import codecs
|
|
import glob
|
|
import os
|
|
import re
|
|
@@ -13,7 +14,7 @@
|
|
|
|
TOPDIR = os.path.dirname(__file__) or "."
|
|
VERSION = re.search('__version__ = "([^"]+)"',
|
|
- open(TOPDIR + "/dateutil/__init__.py").read()).group(1)
|
|
+ codecs.open(TOPDIR + "/dateutil/__init__.py", encoding='utf-8').read()).group(1)
|
|
|
|
|
|
setup(name="python-dateutil",
|
|
|