slackbuilds_ponce/network/shorewall6/patch-6-4.4.8.1

177 lines
6.6 KiB
Groff

diff -Naur -X /home/teastep/bin/exclude.txt shorewall6-4.4.8/changelog.txt shorewall6-4.4.8.1/changelog.txt
--- shorewall6-4.4.8/changelog.txt 2010-03-24 11:12:49.000000000 -0700
+++ shorewall6-4.4.8.1/changelog.txt 2010-04-07 14:49:43.000000000 -0700
@@ -1,3 +1,12 @@
+Changes in Shorewall 4.4.8.1
+
+1) Correct handling of a logical interface name in the EXTERNAL column
+ of proxyarp.
+
+2) Fix find_first_interface_address() error reporting.
+
+3) Fix propagation of zero-valued config variables.
+
Changes in Shorewall 4.4.8
1) Correct handling of RATE LIMIT on NAT rules.
diff -Naur -X /home/teastep/bin/exclude.txt shorewall6-4.4.8/fallback.sh shorewall6-4.4.8.1/fallback.sh
--- shorewall6-4.4.8/fallback.sh 2010-03-23 08:47:56.000000000 -0700
+++ shorewall6-4.4.8.1/fallback.sh 2010-04-07 14:49:33.000000000 -0700
@@ -28,7 +28,7 @@
# shown below. Simply run this script to revert to your prior version of
# Shoreline Firewall.
-VERSION=4.4.8
+VERSION=4.4.8.1
usage() # $1 = exit status
{
diff -Naur -X /home/teastep/bin/exclude.txt shorewall6-4.4.8/install.sh shorewall6-4.4.8.1/install.sh
--- shorewall6-4.4.8/install.sh 2010-03-23 08:47:56.000000000 -0700
+++ shorewall6-4.4.8.1/install.sh 2010-04-07 14:49:33.000000000 -0700
@@ -22,7 +22,7 @@
# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
#
-VERSION=4.4.8
+VERSION=4.4.8.1
usage() # $1 = exit status
{
diff -Naur -X /home/teastep/bin/exclude.txt shorewall6-4.4.8/releasenotes.txt shorewall6-4.4.8.1/releasenotes.txt
--- shorewall6-4.4.8/releasenotes.txt 2010-03-24 11:12:49.000000000 -0700
+++ shorewall6-4.4.8.1/releasenotes.txt 2010-04-07 14:49:43.000000000 -0700
@@ -1,5 +1,5 @@
----------------------------------------------------------------------------
- S H O R E W A L L 4 . 4 . 8
+ S H O R E W A L L 4 . 4 . 8 . 1
----------------------------------------------------------------------------
I. RELEASE 4.4 HIGHLIGHTS
@@ -218,6 +218,27 @@
I I I. P R O B L E M S C O R R E C T E D I N T H I S R E L E A S E
----------------------------------------------------------------------------
+4.4.8.1
+
+1) Logical interface names in the EXTERNAL column of
+ /etc/shorewall/proxyarp were previously not mapped to their
+ corresponding physical interface names. This could cause 'start' or
+ 'restart' to fail.
+
+2) If find_first_interface_address() cannot determine the address of
+ the passed interface, the following message is issued and the
+ process continues:
+
+ /usr/share/shorewall/lib.common: line 438:
+ startup_error: command not found
+
+3) If LOG_VERBOSITY=0 in shorewall.conf, then when the compiled script
+ was executed, messages such as the following would be issued:
+
+ /var/lib/shorewall6/.restart: line 65: [: -gt: unary operator
+ expected
+4.4.8
+
1) A CONTINUE rule specifying a log level would cause the compiler to
generate an incorrect rule sequence. The packet would be logged
but the CONTINUE action would not occur.
@@ -286,6 +307,11 @@
'shorewall refresh' executed, those new changes would not be included
in the active ruleset.
+12) In 4.4.7, it was documented that setting the 'bridge' option in an
+ interfaces file entry also set 'routeback'. That feature was
+ incomplete with the result that 'routeback' still needed to be
+ specified.
+
----------------------------------------------------------------------------
I V. K N O W N P R O B L E M S R E M A I N I N G
----------------------------------------------------------------------------
diff -Naur -X /home/teastep/bin/exclude.txt shorewall6-4.4.8/shorewall6 shorewall6-4.4.8.1/shorewall6
--- shorewall6-4.4.8/shorewall6 2010-03-23 08:47:56.000000000 -0700
+++ shorewall6-4.4.8.1/shorewall6 2010-04-07 14:49:33.000000000 -0700
@@ -227,16 +227,20 @@
}
#
+# Issue an error message and die
+#
+startup_error() {
+ echo " ERROR: $@" >&2
+ kill $$
+ exit 1
+}
+
+#
# Run the appropriate compiler
#
compiler() {
pc=${PERLSHAREDIR}/compiler.pl
- startup_error() {
- echo " ERROR: $@" >&2
- exit 1
- }
-
local command
command=$1
diff -Naur -X /home/teastep/bin/exclude.txt shorewall6-4.4.8/shorewall6.conf shorewall6-4.4.8.1/shorewall6.conf
--- shorewall6-4.4.8/shorewall6.conf 2010-03-23 08:47:56.000000000 -0700
+++ shorewall6-4.4.8.1/shorewall6.conf 2010-04-07 14:49:33.000000000 -0700
@@ -1,19 +1,11 @@
###############################################################################
-# /etc/shorewalls/shorewall6.conf Version 4 - Change the following variables to
-# match your setup
#
-# This program is under GPL
-# [http://www.gnu.org/licenses/old-licenses/gpl-2.0.txt]
-#
-# This file should be placed in /etc/shorewall
-#
-# (c) 1999,2000,2001,2002,2003,2004,2005,
-# 2006,2007,2008 - Tom Eastep (teastep@shorewall.net)
+# Shorewall Version 4 -- /etc/shorewall6/shorewall6.conf
#
# For information about the settings in this file, type "man shorewall6.conf"
#
-# Additional information is available at
-# http://www.shorewall.net/Documentation.htm#Conf
+# Manpage also online at
+# http://www.shorewall.net/manpages6/shorewall6.conf.html
###############################################################################
# S T A R T U P E N A B L E D
###############################################################################
diff -Naur -X /home/teastep/bin/exclude.txt shorewall6-4.4.8/shorewall6.spec shorewall6-4.4.8.1/shorewall6.spec
--- shorewall6-4.4.8/shorewall6.spec 2010-03-23 08:47:56.000000000 -0700
+++ shorewall6-4.4.8.1/shorewall6.spec 2010-04-07 14:49:33.000000000 -0700
@@ -1,6 +1,6 @@
%define name shorewall6
%define version 4.4.8
-%define release 0base
+%define release 1
Summary: Shoreline Firewall 6 is an ip6tables-based firewall for Linux systems.
Name: %{name}
@@ -97,6 +97,8 @@
%doc COPYING INSTALL changelog.txt releasenotes.txt tunnel ipsecvpn ipv6 Samples6
%changelog
+* Thu Mar 25 2010 Tom Eastep tom@shorewall.net
+- Updated to 4.4.8-1
* Fri Mar 19 2010 Tom Eastep tom@shorewall.net
- Updated to 4.4.8-0base
* Tue Mar 16 2010 Tom Eastep tom@shorewall.net
diff -Naur -X /home/teastep/bin/exclude.txt shorewall6-4.4.8/uninstall.sh shorewall6-4.4.8.1/uninstall.sh
--- shorewall6-4.4.8/uninstall.sh 2010-03-23 08:47:56.000000000 -0700
+++ shorewall6-4.4.8.1/uninstall.sh 2010-04-07 14:49:33.000000000 -0700
@@ -26,7 +26,7 @@
# You may only use this script to uninstall the version
# shown below. Simply run this script to remove Shorewall Firewall
-VERSION=4.4.8
+VERSION=4.4.8.1
usage() # $1 = exit status
{