slackbuilds_ponce/games/neverball/Makefile.diff
Brad Hermanson f89d4c8180 games/neverball: Updated for version 1.5.4.
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
2012-06-25 21:15:41 -04:00

29 lines
853 B
Diff

diff -Nur neverball-1.5.4.orig//Makefile neverball-1.5.4/Makefile
--- neverball-1.5.4.orig//Makefile 2012-06-02 00:19:40.340921775 -0400
+++ neverball-1.5.4/Makefile 2012-06-02 21:54:52.078406763 -0400
@@ -27,7 +27,7 @@
# Paths (packagers might want to set DATADIR and LOCALEDIR)
USERDIR := .neverball
-DATADIR := ./data
+DATADIR := /usr/share/neverball/data
LOCALEDIR := ./locale
ifdef MINGW
@@ -131,14 +131,14 @@
OGL_LIBS := -framework OpenGL
endif
-BASE_LIBS := -ljpeg $(PNG_LIBS) $(FS_LIBS)
+BASE_LIBS := -ljpeg $(PNG_LIBS) $(FS_LIBS) -lm
ifdef DARWIN
BASE_LIBS += -L/opt/local/lib
endif
ALL_LIBS := $(SDL_LIBS) $(BASE_LIBS) $(TILT_LIBS) $(INTL_LIBS) -lSDL_ttf \
- -lvorbisfile $(OGL_LIBS)
+ -lvorbisfile $(OGL_LIBS) -lX11
#------------------------------------------------------------------------------