mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-14 21:56:41 +01:00
59db74dcd4
Added the new deps pip, requests-oauthlib and six Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
21 lines
600 B
Diff
21 lines
600 B
Diff
diff --git a/setup.py b/setup.py
|
|
index 2de2d05..3b3b807 100644
|
|
--- a/setup.py
|
|
+++ b/setup.py
|
|
@@ -1,6 +1,6 @@
|
|
#!/usr/bin/env python
|
|
#from distutils.core import setup
|
|
-import re
|
|
+import re, uuid
|
|
from setuptools import setup, find_packages
|
|
from pip.req import parse_requirements
|
|
|
|
@@ -14,7 +14,7 @@ if mo:
|
|
else:
|
|
raise RuntimeError("Unable to find version string in %s." % (VERSIONFILE,))
|
|
|
|
-install_reqs = parse_requirements('requirements.txt')
|
|
+install_reqs = parse_requirements('requirements.txt', session=uuid.uuid1())
|
|
reqs = [str(req.req) for req in install_reqs]
|
|
|
|
setup(name="tweepy",
|