slackbuilds_ponce/system/memtest86+/patches/memtest86+-5.01-no-clean.patch
Kyle Guinn 898d490968
system/memtest86+: Updated for version 5.01.
Signed-off-by: Kyle Guinn <elyk03@gmail.com>
2019-04-06 07:03:01 +07:00

19 lines
603 B
Diff

http://forum.canardpc.com/threads/110954-PATCH-fix-parallel-build-issues
don't run the clean target when building all as we run into parallel races:
- memtest kicks off building of a bunch of .o files
- clean runs in parallel which runs `rm` and deletes some of the new .o
- memtest goes to link and fails because objects are missing
--- a/Makefile
+++ b/Makefile
@@ -19,7 +19,7 @@
smp.o vmem.o random.o
-all: clean memtest.bin memtest
+all: memtest.bin memtest
# Link it statically once so I know I don't have undefined
# symbols and then link it dynamically so I have full