slackbuilds_ponce/system/ttyrec/ttyrec-1.0.8-flags.patch
Matteo Bernardini b42166cb70 system/ttyrec: Patch for the newer glibc and fix the CFLAGS.
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
2021-04-18 00:02:36 -05:00

19 lines
591 B
Diff

--- a/Makefile 2017-08-26 11:47:02.981266309 +0200
+++ b/Makefile 2017-08-26 14:33:47.161600445 +0200
@@ -10,13 +10,13 @@
all: $(TARGET)
ttyrec: ttyrec.o io.o
- $(CC) $(CFLAGS) -o ttyrec ttyrec.o io.o
+ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -o ttyrec ttyrec.o io.o
ttyplay: ttyplay.o io.o
- $(CC) $(CFLAGS) -o ttyplay ttyplay.o io.o
+ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -o ttyplay ttyplay.o io.o
ttytime: ttytime.o io.o
- $(CC) $(CFLAGS) -o ttytime ttytime.o io.o
+ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -o ttytime ttytime.o io.o
clean:
rm -f *.o $(TARGET) ttyrecord *~