mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-22 19:44:21 +01:00
f706b0bc33
Thanks to USUARIONUEVO for the report Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
62 lines
1.6 KiB
Diff
62 lines
1.6 KiB
Diff
Author: Steve Kemp <skx@debian.org>
|
|
Description: Adapt to Debian directory structure.
|
|
---
|
|
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
|
|
|
|
--- a/Makefile.in
|
|
+++ b/Makefile.in
|
|
@@ -11,7 +11,7 @@
|
|
install_prefix =
|
|
prefix = @prefix@
|
|
exec_prefix = @exec_prefix@
|
|
-libdir = @libdir@
|
|
+libdir = $(prefix)/share/dsniff
|
|
sbindir = @sbindir@
|
|
mandir = @mandir@
|
|
|
|
@@ -37,8 +37,7 @@
|
|
X11INC = @X_CFLAGS@
|
|
X11LIB = @X_LIBS@ @X_PRE_LIBS@ -lXmu -lX11 @X_EXTRA_LIBS@
|
|
|
|
-INCS = -I. $(NIDSINC) $(PCAPINC) $(LNETINC) $(DBINC) $(SSLINC) $(X11INC) \
|
|
- -I$(srcdir)/missing
|
|
+INCS = -I. $(X11INC) -I$(srcdir)/missing
|
|
LIBS = @LIBS@ -L$(srcdir) -lmissing
|
|
|
|
INSTALL = @INSTALL@
|
|
--- a/dnsspoof.8
|
|
+++ b/dnsspoof.8
|
|
@@ -31,7 +31,7 @@
|
|
address queries on the LAN with an answer of the local machine's IP
|
|
address.
|
|
.SH FILES
|
|
-.IP \fI/usr/local/lib/dnsspoof.hosts\fR
|
|
+.IP \fI/usr/share/dsniff/dnsspoof.hosts\fR
|
|
Sample hosts file.
|
|
.SH "SEE ALSO"
|
|
dsniff(8), hosts(5)
|
|
--- a/dsniff.8
|
|
+++ b/dsniff.8
|
|
@@ -68,9 +68,9 @@
|
|
On a hangup signal \fBdsniff\fR will dump its current trigger table to
|
|
\fIdsniff.services\fR.
|
|
.SH FILES
|
|
-.IP \fI/usr/local/lib/dsniff.services\fR
|
|
+.IP \fI/usr/share/dsniff/dsniff.services\fR
|
|
Default trigger table
|
|
-.IP \fI/usr/local/lib/dsniff.magic\fR
|
|
+.IP \fI/usr/share/dsniff/dsniff.magic\fR
|
|
Network protocol magic
|
|
.SH "SEE ALSO"
|
|
arpspoof(8), libnids(3), services(5), magic(5)
|
|
--- a/pathnames.h
|
|
+++ b/pathnames.h
|
|
@@ -12,7 +12,7 @@
|
|
#define PATHNAMES_H
|
|
|
|
#ifndef DSNIFF_LIBDIR
|
|
-#define DSNIFF_LIBDIR "/usr/local/lib/"
|
|
+#define DSNIFF_LIBDIR "/usr/share/dsniff/"
|
|
#endif
|
|
|
|
#define DSNIFF_SERVICES "dsniff.services"
|