mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-18 22:06:04 +01:00
e8e323bd5a
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
23 lines
1 KiB
Diff
23 lines
1 KiB
Diff
From fb71fc45992a9adf73b3c8194bdd691391ca34d7 Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?J=C3=A9r=C3=A9my=20Bobbio?= <lunar@debian.org>
|
|
Date: Wed, 27 Jan 2016 17:44:06 +0100
|
|
Subject: [PATCH] install the library in expected directories
|
|
|
|
We add CMake install directives in order to see the library files installed in
|
|
the expected multiarch compatible locations.
|
|
---
|
|
src/CMakeLists.txt | 4 ++++
|
|
1 file changed, 4 insertions(+)
|
|
|
|
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
|
|
index b1c92fb..c8d3fd9 100644
|
|
--- a/src/CMakeLists.txt
|
|
+++ b/src/CMakeLists.txt
|
|
@@ -21,3 +21,7 @@ set_target_properties(tlsh_shared PROPERTIES LIBRARY_OUTPUT_DIRECTORY ${CMAKE_SO
|
|
set_target_properties(tlsh_shared PROPERTIES OUTPUT_NAME tlsh${BUILD_POSTFIX})
|
|
set_target_properties(tlsh_shared PROPERTIES VERSION "${VERSION_MAJOR}.${VERSION_MINOR}.${VERSION_PATCH}"
|
|
SOVERSION "0")
|
|
+
|
|
+include(GNUInstallDirs)
|
|
+install(TARGETS tlsh_shared DESTINATION ${CMAKE_INSTALL_LIBDIR})
|
|
+install(FILES ../include/tlsh.h DESTINATION ${CMAKE_INSTALL_INCLUDEDIR})
|