mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-18 22:06:04 +01:00
c14df07dd2
Signed-off-by: Erik Hanson <erik@slackbuilds.org>
32 lines
1 KiB
Diff
32 lines
1 KiB
Diff
diff -Nur 4th-3.62.0-unix/sources/Makefile 4th-3.62.0-unix.new/sources/Makefile
|
|
--- 4th-3.62.0-unix/sources/Makefile 2012-12-22 12:26:35.000000000 +0000
|
|
+++ 4th-3.62.0-unix.new/sources/Makefile 2013-02-11 15:30:00.531948113 +0000
|
|
@@ -16,13 +16,13 @@
|
|
|
|
# The following variables may need to be changed
|
|
|
|
-LIBRARIES=/usr/lib
|
|
-INCLUDES=/usr/include
|
|
-BINARIES=/usr/local/bin
|
|
-MANDIR=/usr/share/man
|
|
-DOCDIR=/usr/share/doc
|
|
+LIBRARIES=$(DESTDIR)/usr/lib$(LIBSUFFIX)
|
|
+INCLUDES=$(DESTDIR)/usr/include
|
|
+BINARIES=$(DESTDIR)/usr/bin
|
|
+MANDIR=$(DESTDIR)/usr/man
|
|
+DOCDIR=$(DESTDIR)/usr/doc
|
|
SOURCES=../4th
|
|
-CFLAGS= -DUNIX -fsigned-char -Wall -O3 -s
|
|
+CFLAGS=$(CXXFLAGS) -DUNIX -fsigned-char -Wall -s
|
|
|
|
# Cross compilation variables
|
|
LD=$(CROSS)ld
|
|
@@ -128,7 +128,7 @@
|
|
|
|
install: mostlyinstall
|
|
install -Dm644 ../documentation/4th.1 $(MANDIR)/man1/4th.1
|
|
- install -Dm644 ../documentation/4tHmanual.txt $(DOCDIR)/4th/
|
|
+ install -Dm644 ../documentation/4tHmanual.txt $(DOCDIR)/4th-3.62.0/
|
|
|
|
uninstall:
|
|
-rm -f $(LIBRARIES)/lib4th.{a,so*}
|