slackbuilds_ponce/office/omegat/omegat.SlackBuild
Lockywolf 253263183c office/omegat: Added (translation memory application).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
2023-12-06 11:01:07 +07:00

127 lines
3.9 KiB
Bash

#!/bin/bash
# Slackware build script for omegat
# Copyright 2023, Lockywolf
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=omegat
TARNAM=OmegaT
VERSION=${VERSION:-6.0.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
fi
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
fi
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i586" ]; then
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
printf "Unsupported architecture: %s.\n" "$ARCH" 1>&2
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
LIBDIRSUFFIX=""
printf "Unsupported architecture: %s.\n" "$ARCH" 1>&2
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
elif [ "$ARCH" = "aarch64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
printf "Unsupported architecture: %s.\n" "$ARCH" 1>&2
exit 1
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
printf "Unsupported architecture: unknown.\n" 1>&2
exit 2
fi
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
mkdir $PRGNAM-$VERSION
cd $PRGNAM-$VERSION
tar xvf $CWD/${TARNAM}_${VERSION}_Linux_64.tar.bz2
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
install -d -m755 $PKG/opt
mv ${TARNAM}_${VERSION}_Linux_64 $PKG/opt
install -d -m755 "$PKG"/usr/bin
(
cd $PKG/usr/bin
ln -sr ../../opt/${TARNAM}_${VERSION}_Linux_64/OmegaT ./
)
install -Dm644 $PKG/opt/${TARNAM}_${VERSION}_Linux_64/$PRGNAM.desktop $PKG/usr/share/applications/$PRGNAM.desktop
install -Dm644 $PKG/opt/${TARNAM}_${VERSION}_Linux_64/images/$TARNAM.svg $PKG/usr/share/icons/hicolor/scalable/$PRGNAM.svg
install -Dm644 $PKG/opt/${TARNAM}_${VERSION}_Linux_64/images/$TARNAM.svg $PKG/usr/share/pixmaps/$PRGNAM.svg
# uncomment if your know how to install raster icons
icon_sizes=( 32 128 256 512 )
for size in "${icon_sizes[@]}"
do
mkdir -p $PKG/usr/share/icons/hicolor/$size\x$size/apps/
cp $PKG/opt/${TARNAM}_${VERSION}_Linux_64/images/OmegaT.iconset/icon_$size\x$size.png $PKG/usr/share/icons/hicolor/$size\x$size/apps/$PRGNAM.png
done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
$PKG/opt/${TARNAM}_${VERSION}_Linux_64/{OmegaT-license.txt,authors.txt,changes.txt,doc-license.txt,readme.txt} \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE