slackbuilds_ponce/misc/dbview/dbview.SlackBuild
B. Watson 9c81726d50
misc/dbview: New maintainer.
Signed-off-by: B. Watson <urchlay@slackware.uk>

Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
2024-09-07 09:08:50 +07:00

90 lines
2.4 KiB
Bash

#!/bin/bash
# Slackware build script for dbview
# Written by Oleg O. Chukaev
# Modified and now maintained by B. Watson <urchlay@slackware.uk>
# Original version of this script had no license; modified version
# licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
# 20240905 bkw: BUILD=2
# - new maintainer.
# - actually test against some .dbf files, found here:
# https://github.com/infused/dbf/tree/master/spec/fixtures
# not all of them are in supported versions of the .dbf format,
# but at least some of them work fine.
# - add a patch from Debian.
# - add a patch to fix grammar/spelling/usage in the man page.
# - get rid of unneeded makefile.diff.
# Note: this is more for digital archaeology than anything else.
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=dbview
VERSION=${VERSION:-1.0.4}
BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
fi
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
fi
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i586" ]; then
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
else
SLKCFLAGS="-O2"
fi
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} + -o \
\! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} +
# 20240905 bkw: patch borrowed from Debian: the exit status is
# backwards (should be 0 for success, not 1).
patch -p1 < $CWD/negate_exit_code.diff
# 20240905 bkw: my own patch for the man page. some of the changes
# are nitpicky (DOS => MS-DOS), but matter to me.
patch -p1 < $CWD/manpage.diff
make CFLAGS="$SLKCFLAGS -Wl,-s"
make install prefix=$PKG/usr mandir=$PKG/usr/man MAN=root
gzip -9 $PKG/usr/man/man*/*
PKGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
mkdir -p $PKGDOC
cp -a CHANGES README dBASE $PKGDOC
cat $CWD/$PRGNAM.SlackBuild > $PKGDOC/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE