mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-20 19:41:34 +01:00
63daf9f79a
Signed-off-by: Heinz Wiesinger <pprkut@slackbuilds.org>
67 lines
1.7 KiB
Bash
67 lines
1.7 KiB
Bash
#!/bin/bash
|
|
|
|
# Slackware Package Build Script for phpDocumentor
|
|
# Home Page http://www.phpdoc.org/
|
|
|
|
cd $(dirname $0) ; CWD=$(pwd)
|
|
|
|
PRGNAM=phpDocumentor
|
|
VERSION=${VERSION:-1.4.3}
|
|
BUILD=${BUILD:-1}
|
|
TAG=${TAG:-_SBo}
|
|
PKGTYPE=${PKGTYPE:-tgz}
|
|
|
|
ARCH=noarch # hardcode ARCH
|
|
|
|
DOCROOT=${DOCROOT:-/var/www/htdocs}
|
|
|
|
PHPUSER=${PHPUSER:-root}
|
|
PHPGROUP=${PHPGROUP:-apache}
|
|
|
|
SRCNAM=PhpDocumentor-${VERSION}
|
|
|
|
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
|
|
# the name of the created package would be, and then exit. This information
|
|
# could be useful to other scripts.
|
|
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
|
|
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
|
|
exit 0
|
|
fi
|
|
|
|
TMP=${TMP:-/tmp/SBo}
|
|
PKG=$TMP/package-$PRGNAM
|
|
OUTPUT=${OUTPUT:-/tmp}
|
|
|
|
set -eu
|
|
|
|
rm -rf $PKG
|
|
mkdir -p $TMP $PKG $OUTPUT
|
|
cd $TMP
|
|
rm -rf $PRGNAM-$VERSION
|
|
tar xvf $CWD/$SRCNAM.tgz
|
|
mv $SRCNAM $TMP/$PRGNAM-$VERSION
|
|
cd $PRGNAM-$VERSION
|
|
chown -R root:root .
|
|
find -L . \
|
|
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 -o -perm 755 \) \
|
|
-exec chmod 750 {} \; -o \
|
|
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 -o -perm 644 \) \
|
|
-exec chmod 640 {} \;
|
|
|
|
mkdir -p $PKG/$DOCROOT
|
|
cp -a $TMP/$PRGNAM-$VERSION $PKG/$DOCROOT/$PRGNAM
|
|
|
|
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
|
cp -a \
|
|
Documentation* INSTALL LICENSE README* ChangeLog \
|
|
$PKG/usr/doc/$PRGNAM-$VERSION
|
|
|
|
# Change ownership and perms and create a link.
|
|
chown -R $PHPUSER:$PHPGROUP $PKG/$DOCROOT/$PRGNAM
|
|
chmod 0750 $PKG/$DOCROOT/$PRGNAM
|
|
|
|
mkdir -p $PKG/install
|
|
cat $CWD/slack-desc > $PKG/install/slack-desc
|
|
|
|
cd $PKG
|
|
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
|