slackbuilds_ponce/development/guile1.8/guile1.8.SlackBuild
Lockywolf 04147d5ba9
development/guile1.8: New maintainer.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
2023-07-17 09:51:28 +07:00

174 lines
5.7 KiB
Bash

#!/bin/bash
# Copyright 2013-2016 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
# Updated 2023, Lockywolf
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
# 20230629 bkw: Modified by SlackBuilds.org, BUILD=5:
# - fix the info files so the info command can actually display them.
# - add doinst.sh to handle /usr/info/dir
# - rm generic INSTALL from doc dir.
# 20230716 Lockywolf: BUILD=6
# - Add NO_DOCS option.
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=guile1.8
SRCNAM=guile
VERSION=${VERSION:-1.8.8}
BUILD=${BUILD:-6}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
fi
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
fi
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i586" ]; then
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
fi
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $SRCNAM-$VERSION
tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
cd $SRCNAM-$VERSION
# fix segfault - thanks gentoo maintainers.
patch -p1 -i $CWD/guile-1.8.8-gcc46.patch
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} + -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} +
if [[ "$NO_DOCS" == true ]] ; then
sed -i 's/scripts srfi doc examples test-suite benchmark-suite lang am/scripts srfi examples test-suite benchmark-suite lang am/g' Makefile.am ;
autoreconf -i
fi
CFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \
--infodir=/usr/info \
--mandir=/usr/man \
--with-threads \
--program-suffix=1.8 \
--disable-error-on-warning \
--disable-static \
--build=$ARCH-slackware-linux
make -j1 LDFLAGS+="-lpthread"
make install DESTDIR=$PKG
rm -rf $PKG/usr/lib${LIBDIRSUFFIX}/*.la
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
# 20230629 bkw:
#
# Fix the info files. This is required for them to work with the info
# command; simply renaming them doesn't work. If you try it, you won't
# see the guile 1.8 stuff in the info directory... and if you try
# "info guile1.8" or even "info /usr/info/guile1.8.info.gz" with the
# previous BUILD (4), it will show you the guile 3.0 documentation
# instead (seriously). Surgery is required.
#
# goops.info.gz and guile-tut.info.gz can stay as-is, they are not
# included in Slackware's guile. r5rs.info is almost identical to
# the one in Slackware, so leave it out of this package.
#
# This is a lot of work to do, but it results in proper info files:
# they show up in the index (if you just type "info"), without
# conflicting with Slackware's guile info files. And you can also run
# "info guile1.8" to display them.
#
# The alternative to this messy solution would be to rm -rf $PKG/usr/info
# and just not ship the .info files. But I kinda hate to do that.
#
rm -f $PKG/usr/info/{guile.*,r5rs*,dir}
if [[ "$NO_DOCS" != true ]] ; then
find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
gzip -9 $PKG/usr/info/*.info
GV="$( echo $VERSION | cut -d. -f1,2 )"
( cd doc/ref
sed -i '/^guile\.info-/s,guile,guile'$GV, guile.info
sed -i \
-e '/\* Guile Ref/s,.*,* Guile '$GV' Reference: (guile'$GV'). The Guile '$GV' reference manual.,' \
-e '/^File: guile\.info/s,guile,guile'$GV, \
guile.info*
rename guile. guile$GV. guile.info*
for i in guile$GV.info*; do
gzip -9c < $i > $PKG/usr/info/$( basename $i ).gz
done
)
fi
# Avoid duplicate with Slackware's guile.m4
# It can detect newer (2.0) and older (1.8) version of guile installed on system
mv $PKG/usr/share/aclocal/guile.m4 $PKG/usr/share/aclocal/guile18.m4
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a AUTHORS COPYING* GUILE-VERSION HACKING LICENSE NEWS README* THANKS \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
# Fix guile-config1.8 info
sed -i '1s/guile/guile1.8/' -i $PKG/usr/bin/guile-config1.8
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cat $CWD/doinst.sh > $PKG/install/douninst.sh
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE