games/chocolate-doom: Updated for version 2.3.0.

This commit is contained in:
B. Watson 2017-01-11 03:40:17 -05:00 committed by Willy Sudiarto Raharjo
parent 4f6684b5a8
commit ffec091952
No known key found for this signature in database
GPG key ID: 887B8374D7333381
5 changed files with 46 additions and 43 deletions

View file

@ -1,27 +1,32 @@
Chocolate Doom is a Doom source port that accurately reproduces the
experience of Doom as it was played in the 1990s.
experience of Doom and Doom II as they were played in the 1990s.
Starting with version 2.0.0, Chocolate Doom also supports Heretic, Hexen,
and Strife.
Starting with version 2.3.0, Chocolate Doom also supports Heretic, Hexen,
Strife, and Chex Quest.
To play chocolate-doom, you need at least one of:
doom2.wad from Doom II
doom.wad from Registered Doom or Ultimate Doom
tnt.wad or plutonia.wad from Final Doom
doom1.wad from Shareware Doom (doom_shareware_data on SBo)
doom1.wad from Shareware Doom (games/doom_shareware_data on SBo)
freedoom.wad from FreeDoom (games/freedoom on SBo)
For chocolate-heretic:
heretic.wad from Registered Heretic
heretic1.wad from Shareware Heretic (heretic_shareware_data on SBo)
heretic1.wad from Shareware Heretic (games/heretic_shareware_data on SBo)
For chocolate-hexen:
hexen.wad from Registered Hexen
hexdemo.wad from the Hexen demo (hexen_demo_data on SBo)
hexdemo.wad from the Hexen demo (games/hexen_demo_data on SBo)
For chocolate-strife:
strife1.wad from Registered Strife
Place the WAD file(s) in /usr/share/games/doom.
freedoom doesn't work with Chocolate Doom. Neither does strife0.wad from
the Strife demo. Chex Quest might work (not tested by SlackBuild author).
For Chex Quest, get chex.wad from the game, and chex.deh from
https://www.doomworld.com/idgames/utils/exe_edit/patches/chexdeh, place
them both in /usr/share/games/doom, and run: chocolate-doom -iwad chex.wad
The Strife demo (strife0.wad) doesn't work with Chocolate Doom.
Chex Quest 2 and 3 are not supported.

View file

@ -6,8 +6,17 @@
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
# 20170111 bkw:
# - update for v2.3.0
# - use upstream's .desktop files for heretic/hexen/strife, now that
# they're provided
# - use symlinks for the *-setup binaries, since they're identical
# - include a few missing docs (AUTHORS, COPYING, etc)
# - get rid of no-longer-needed disable_windres.diff
# - update README and slack-desc
PRGNAM=chocolate-doom
VERSION=${VERSION:-2.2.1}
VERSION=${VERSION:-2.3.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@ -53,16 +62,12 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
# Grr. Newer binutils includes a windres command, which doesn't seem to work
# like the actual windows one (configure lacks switches to disable windres)
patch -p1 < $CWD/disable_windres.diff
autoreconf -if
# NB: Upstream uses --docdir in a weird way: docs for chocolate-doom
# go in $docdir, the others go in e.g. "$docdir/../chocolate-hexen/".
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
--bindir=/usr/games \
--prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \
--sysconfdir=/etc \
@ -77,26 +82,31 @@ make install DESTDIR=$PKG
# install-strip fails to strip the *-setup binaries.
strip $PKG/usr/games/*
# No symlinks in /usr/man (we'll create some later though)
gzip -9 $PKG/usr/man/man?/*
# Move icons to standard Slackware pixmap icon dir:
mv $PKG/usr/share/icons $PKG/usr/share/pixmaps
# Upstream doesn't include .desktop files or icons for the other games,
# we'll generate them.
cd $PKG/usr/share/applications
for GAME in Heretic Hexen Strife; do
game="$( echo $GAME | tr A-Z a-z )"
sed -e "s,Doom,$GAME,g" -e "s,doom,$game,g" \
$PRGNAM.desktop \
> chocolate-$game.desktop
ln -s $PRGNAM.png $PKG/usr/share/pixmaps/chocolate-$game.png
done
cd -
# 2.3.0 has a single chocolate-setup binary, which it installs 4 copies
# of with different names, and it uses the names to decide which game
# to configure. Better done with symlinks. Plus make links for the man
# pages. Note that running chocolate-setup lets you pick which game
# you want to configure, so strictly speaking these extra symlinks are
# unneeded. Also, upstream only ships one .desktop file for the setup,
# I'm leaving that as-is.
cp $PKG/usr/games/$PRGNAM-setup $PKG/usr/games/chocolate-setup
for exe in $PKG/usr/games/chocolate-*-setup; do
man=$PKG/usr/man/man6/$( basename $exe ).6.gz
rm -f $exe $man
ln -s chocolate-setup $exe
ln -s chocolate-setup.6.gz $man
done
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cp -a HACKING.md TODO.md AUTHORS COPYING $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh

View file

@ -1,8 +1,8 @@
PRGNAM="chocolate-doom"
VERSION="2.2.1"
VERSION="2.3.0"
HOMEPAGE="http://www.chocolate-doom.org/"
DOWNLOAD="http://www.chocolate-doom.org/downloads/2.2.1/chocolate-doom-2.2.1.tar.gz"
MD5SUM="20ef24c517f701023aa187c07b587ce6"
DOWNLOAD="https://www.chocolate-doom.org/downloads/2.3.0/chocolate-doom-2.3.0.tar.gz"
MD5SUM="5759b36c9a342e8d62ecdcc5fc9f428c"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""

View file

@ -1,12 +0,0 @@
diff -Naur chocolate-doom-2.0.0/configure.ac chocolate-doom-2.0.0.patched/configure.ac
--- chocolate-doom-2.0.0/configure.ac 2013-12-09 00:40:53.000000000 -0500
+++ chocolate-doom-2.0.0.patched/configure.ac 2014-03-20 14:54:11.000000000 -0400
@@ -90,7 +90,7 @@
AC_CHECK_TOOL(WINDRES, windres, )
AC_CHECK_TOOL(STRIP, strip, )
-AM_CONDITIONAL(HAVE_WINDRES, test "$WINDRES" != "")
+AM_CONDITIONAL(HAVE_WINDRES, false)
AM_CONDITIONAL(HAVE_PYTHON, $HAVE_PYTHON)
dnl Automake v1.8.0 is required, please upgrade!

View file

@ -9,10 +9,10 @@
chocolate-doom: chocolate-doom (Doom source port)
chocolate-doom:
chocolate-doom: Chocolate Doom is a Doom source port that accurately reproduces the
chocolate-doom: experience of Doom as it was played in the 1990s.
chocolate-doom: experience of Doom and Doom II as they were played in the 1990s.
chocolate-doom:
chocolate-doom: Starting with version 2.0.0, Chocolate Doom also supports Heretic,
chocolate-doom: Hexen, and Strife.
chocolate-doom: Starting with version 2.3.0, Chocolate Doom also supports Heretic,
chocolate-doom: Hexen, Strife, and Chex Quest.
chocolate-doom:
chocolate-doom:
chocolate-doom: