mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-21 19:42:24 +01:00
system/apachetop: Change maintainer & patch possible buffer overflow
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
This commit is contained in:
parent
0edc246dd9
commit
fde51ee5cf
3 changed files with 46 additions and 3 deletions
39
system/apachetop/apachetop-0.12.6-maxpathlen.patch
Normal file
39
system/apachetop/apachetop-0.12.6-maxpathlen.patch
Normal file
|
@ -0,0 +1,39 @@
|
|||
Patch by Robert Scheck <robert@fedoraproject.org> for apachetop <= 0.12.6, which
|
||||
adds some includes in order to have a real change to get MAXPATHLEN defined with
|
||||
a valid value. Once MAXPATHLEN really gets filled with 128, it will just cause a
|
||||
buffer overflow.
|
||||
|
||||
See Red Hat Bugzilla #446199 (https://bugzilla.redhat.com/show_bug.cgi?id=446199)
|
||||
for more information. This patch should solve the mentioned bug report and should
|
||||
be sane enough to get included by upstream of apachetop for the next release. It
|
||||
is important to run autoheader before ./configure to get these changes activated.
|
||||
|
||||
--- apachetop-0.12.6/configure.ac.orig 2005-10-27 18:39:25.000000000 +0200
|
||||
+++ apachetop-0.12.6/configure.ac 2008-06-21 16:00:38.000000000 +0200
|
||||
@@ -34,7 +34,8 @@
|
||||
# Checks for header files.
|
||||
AC_HEADER_STDC
|
||||
AC_CHECK_HEADERS([arpa/inet.h netdb.h netinet/in.h \
|
||||
- string.h strings.h sys/socket.h time.h sys/time.h])
|
||||
+ string.h strings.h sys/socket.h time.h sys/time.h \
|
||||
+ limits.h sys/param.h])
|
||||
|
||||
# Checks for typedefs, structures, and compiler characteristics.
|
||||
#AC_HEADER_STDBOOL # not in 2.53?
|
||||
--- apachetop-0.12.6/src/apachetop.h.orig 2005-10-15 18:10:01.000000000 +0200
|
||||
+++ apachetop-0.12.6/src/apachetop.h 2008-06-21 16:02:00.000000000 +0200
|
||||
@@ -89,8 +89,12 @@
|
||||
#define getMIN(a,b) (a < b ? a : b)
|
||||
#define getMAX(a,b) (a > b ? a : b)
|
||||
|
||||
-#ifndef MAXPATHLEN
|
||||
-# define MAXPATHLEN 128
|
||||
+#ifdef HAVE_SYS_PARAM_H
|
||||
+# include <sys/param.h>
|
||||
+#endif
|
||||
+
|
||||
+#if HAVE_LIMITS_H
|
||||
+# include <limits.h>
|
||||
#endif
|
||||
|
||||
/* upon startup, each input file is put into an element of this array,
|
|
@ -3,6 +3,7 @@
|
|||
# Slackware build script for ApacheTop
|
||||
|
||||
# Written by Menno Duursma <druiloor@zonnet.nl>
|
||||
# Updated by Willy Sudiarto Raharjo <willysr@slackware-id.org>
|
||||
|
||||
# This program is free software. It comes without any warranty.
|
||||
# Granted WTFPLv2, as published by Sam Hocevar dec 2004.
|
||||
|
@ -10,7 +11,7 @@
|
|||
|
||||
PRGNAM=apachetop
|
||||
VERSION=${VERSION:-0.12.6}
|
||||
BUILD=${BUILD:-1}
|
||||
BUILD=${BUILD:-2}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
# Automatically determine the architecture we're building on:
|
||||
|
@ -60,6 +61,9 @@ patch -p0 < $CWD/apachetop.outputfile.patch
|
|||
# Add mension of the feature added above to the manpage.
|
||||
patch -p0 < $CWD/apachetop.manpage.diff
|
||||
|
||||
# Add patch from Fedora Project to fix buffer overflow possibility
|
||||
patch -p1 < $CWD/apachetop-0.12.6-maxpathlen.patch
|
||||
|
||||
# Add --with-adns=<path> if you have adns installed and want ApacheTop support
|
||||
# Note: The log to parce can be overwritten at runtime, using the '-f' flag.
|
||||
CXXFLAGS="$SLKCFLAGS" \
|
||||
|
|
|
@ -6,5 +6,5 @@ MD5SUM="604283ac4bbbddd98fc9b1f11381657e"
|
|||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES=""
|
||||
MAINTAINER="Diogo Leal"
|
||||
EMAIL="diogo@diogoleal.com"
|
||||
MAINTAINER="Willy Sudiarto Raharjo"
|
||||
EMAIL="willysr@slackware-id.org"
|
||||
|
|
Loading…
Reference in a new issue