mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-16 19:50:19 +01:00
desktop/dolphin-megasync: Added (MEGAsync plugin for dolphin).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
e33b337f8b
commit
fd15dd31e7
6 changed files with 169 additions and 0 deletions
4
desktop/dolphin-megasync/README
Normal file
4
desktop/dolphin-megasync/README
Normal file
|
@ -0,0 +1,4 @@
|
||||||
|
MEGAsync plugin for dolphin file manager.
|
||||||
|
|
||||||
|
Dolphin-megasync uploads your files to your Mega account from Dolphin.
|
||||||
|
You need to install MEGAsync for this plugin to work.
|
11
desktop/dolphin-megasync/doinst.sh
Normal file
11
desktop/dolphin-megasync/doinst.sh
Normal file
|
@ -0,0 +1,11 @@
|
||||||
|
|
||||||
|
if [ -x /usr/bin/update-desktop-database ]; then
|
||||||
|
/usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
|
||||||
|
fi
|
||||||
|
|
||||||
|
if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
|
||||||
|
if [ -x /usr/bin/gtk-update-icon-cache ]; then
|
||||||
|
/usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
|
||||||
|
fi
|
||||||
|
fi
|
||||||
|
|
113
desktop/dolphin-megasync/dolphin-megasync.SlackBuild
Normal file
113
desktop/dolphin-megasync/dolphin-megasync.SlackBuild
Normal file
|
@ -0,0 +1,113 @@
|
||||||
|
#!/bin/bash
|
||||||
|
|
||||||
|
# Slackware build script for MEGAsync
|
||||||
|
|
||||||
|
# Copyright 2022 JW(Shinichi Abe) <shin1.abe@nifty.com>
|
||||||
|
# All rights reserved.
|
||||||
|
#
|
||||||
|
# Redistribution and use of this script, with or without modification, is
|
||||||
|
# permitted provided that the following conditions are met:
|
||||||
|
#
|
||||||
|
# 1. Redistributions of this script must retain the above copyright
|
||||||
|
# notice, this list of conditions and the following disclaimer.
|
||||||
|
#
|
||||||
|
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
|
||||||
|
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
||||||
|
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
||||||
|
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
||||||
|
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
||||||
|
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
||||||
|
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
||||||
|
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
||||||
|
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
||||||
|
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||||
|
|
||||||
|
cd $(dirname $0) ; CWD=$(pwd)
|
||||||
|
|
||||||
|
PRGNAM=dolphin-megasync
|
||||||
|
SRCNAM=MEGAsync
|
||||||
|
VERSION=${VERSION:-4.7.2.0}
|
||||||
|
BUILD=${BUILD:-1}
|
||||||
|
TAG=${TAG:-_SBo}
|
||||||
|
PKGTYPE=${PKGTYPE:-tgz}
|
||||||
|
|
||||||
|
if [ -z "$ARCH" ]; then
|
||||||
|
case "$( uname -m )" in
|
||||||
|
i?86) ARCH=i586 ;;
|
||||||
|
arm*) ARCH=arm ;;
|
||||||
|
*) ARCH=$( uname -m ) ;;
|
||||||
|
esac
|
||||||
|
fi
|
||||||
|
|
||||||
|
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
|
||||||
|
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
|
||||||
|
exit 0
|
||||||
|
fi
|
||||||
|
|
||||||
|
TMP=${TMP:-/tmp/SBo}
|
||||||
|
PKG=$TMP/package-$PRGNAM
|
||||||
|
OUTPUT=${OUTPUT:-/tmp}
|
||||||
|
|
||||||
|
if [ "$ARCH" = "i586" ]; then
|
||||||
|
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
|
||||||
|
LIBDIRSUFFIX=""
|
||||||
|
elif [ "$ARCH" = "i686" ]; then
|
||||||
|
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
|
||||||
|
LIBDIRSUFFIX=""
|
||||||
|
elif [ "$ARCH" = "x86_64" ]; then
|
||||||
|
SLKCFLAGS="-O2 -fPIC"
|
||||||
|
LIBDIRSUFFIX="64"
|
||||||
|
else
|
||||||
|
SLKCFLAGS="-O2"
|
||||||
|
LIBDIRSUFFIX=""
|
||||||
|
fi
|
||||||
|
|
||||||
|
set -e
|
||||||
|
|
||||||
|
rm -rf $PKG
|
||||||
|
mkdir -p $TMP $PKG $OUTPUT
|
||||||
|
cd $TMP
|
||||||
|
rm -rf $SRCNAM-$VERSION
|
||||||
|
tar xvf $CWD/$SRCNAM-${VERSION}_Linux.tar.gz
|
||||||
|
cd $SRCNAM-${VERSION}_Linux
|
||||||
|
|
||||||
|
# prepare source
|
||||||
|
mkdir -p build
|
||||||
|
# Apply Arch patch (Thanks to Arch)
|
||||||
|
patch -p2 -i $CWD/kf5.patch --verbose || extit 1
|
||||||
|
mv src/MEGAShellExtDolphin/CMakeLists.txt src/MEGAShellExtDolphin/CMakeLists.txt.old
|
||||||
|
mv src/MEGAShellExtDolphin/CMakeLists_kde5.txt src/MEGAShellExtDolphin/CMakeLists.txt
|
||||||
|
|
||||||
|
chown -R root:root .
|
||||||
|
find -L . \
|
||||||
|
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
|
||||||
|
-o -perm 511 \) -exec chmod 755 {} \; -o \
|
||||||
|
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||||
|
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||||
|
|
||||||
|
cd build
|
||||||
|
cmake ../src/MEGAShellExtDolphin \
|
||||||
|
-DCMAKE_BUILD_TYPE=None \
|
||||||
|
-DCMAKE_INSTALL_PREFIX=/usr \
|
||||||
|
-DCMAKE_INSTALL_LIBDIR=lib${LIBDIRSUFFIX}
|
||||||
|
make
|
||||||
|
|
||||||
|
make install DESTDIR=$PKG
|
||||||
|
cd ..
|
||||||
|
install -Dm644 LICENCE.md $PKG/usr/share/licenses/$PRGNAM/LICENCE.md
|
||||||
|
|
||||||
|
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
|
||||||
|
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
||||||
|
|
||||||
|
cd $TMP/$SRCNAM-${VERSION}_Linux
|
||||||
|
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||||
|
cp -a \
|
||||||
|
CREDITS.md LICENCE.md README.md $PKG/usr/doc/$PRGNAM-$VERSION
|
||||||
|
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||||
|
|
||||||
|
mkdir -p $PKG/install
|
||||||
|
cat $CWD/slack-desc > $PKG/install/slack-desc
|
||||||
|
cat $CWD/doinst.sh > $PKG/install/doinst.sh
|
||||||
|
|
||||||
|
cd $PKG
|
||||||
|
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
|
10
desktop/dolphin-megasync/dolphin-megasync.info
Normal file
10
desktop/dolphin-megasync/dolphin-megasync.info
Normal file
|
@ -0,0 +1,10 @@
|
||||||
|
PRGNAM="dolphin-megasync"
|
||||||
|
VERSION="4.7.2.0"
|
||||||
|
HOMEPAGE="https://github.com/meganz/MEGAsync/"
|
||||||
|
DOWNLOAD="https://github.com/meganz/MEGAsync/archive/v4.7.2.0_Linux/MEGAsync-4.7.2.0_Linux.tar.gz"
|
||||||
|
MD5SUM="b1734bf785e279dd0d01d8ff254c7587"
|
||||||
|
DOWNLOAD_x86_64=""
|
||||||
|
MD5SUM_x86_64=""
|
||||||
|
REQUIRES=""
|
||||||
|
MAINTAINER="JW(Shinichi Abe)"
|
||||||
|
EMAIL="shin1.abe@nifty.com"
|
12
desktop/dolphin-megasync/kf5.patch
Normal file
12
desktop/dolphin-megasync/kf5.patch
Normal file
|
@ -0,0 +1,12 @@
|
||||||
|
diff --git a/MEGAsync/src/MEGAShellExtDolphin/CMakeLists_kde5.txt b/MEGAsync/src/MEGAShellExtDolphin/CMakeLists_kde5.txt
|
||||||
|
@@ -64,4 +64,4 @@ target_link_libraries(${MEGASYNCPLUGIN} KF5::CoreAddons KF5::KIOCore KF5::KIOWid
|
||||||
|
|
||||||
|
#install(FILES ${CMAKE_CURRENT_BINARY_DIR}/megasync-plugin.desktop DESTINATION ${KDE_INSTALL_KSERVICES5DIR})
|
||||||
|
install(FILES megasync-plugin.desktop DESTINATION ${KDE_INSTALL_KSERVICES5DIR})
|
||||||
|
-install(TARGETS ${MEGASYNCPLUGIN} DESTINATION ${CMAKE_INSTALL_LIBDIR}/qt5/plugins)
|
||||||
|
+install(TARGETS ${MEGASYNCPLUGIN} DESTINATION ${PLUGIN_INSTALL_DIR})
|
||||||
|
|
||||||
|
diff --git a/MEGAsync/src/MEGAShellExtDolphin/megasync-plugin.moc b/src/MEGAShellExtDolphin/megasync-plugin.moc
|
||||||
|
deleted file mode 100644
|
||||||
|
index e69de29b..00000000
|
||||||
|
|
19
desktop/dolphin-megasync/slack-desc
Normal file
19
desktop/dolphin-megasync/slack-desc
Normal file
|
@ -0,0 +1,19 @@
|
||||||
|
# HOW TO EDIT THIS FILE:
|
||||||
|
# The "handy ruler" below makes it easier to edit a package description.
|
||||||
|
# Line up the first '|' above the ':' following the base package name, and
|
||||||
|
# the '|' on the right side marks the last column you can put a character in.
|
||||||
|
# You must make exactly 11 lines for the formatting to be correct. It's also
|
||||||
|
# customary to leave one space after the ':' except on otherwise blank lines.
|
||||||
|
|
||||||
|
|-----handy-ruler------------------------------------------------------|
|
||||||
|
dolphin-megasync: dolphin-megasync (MEGAsync plugin for dolphin file manager)
|
||||||
|
dolphin-megasync:
|
||||||
|
dolphin-megasync: MEGAsync plugin for dolphin file manager.
|
||||||
|
dolphin-megasync: Upload your files to your Mega account via Dolphin.
|
||||||
|
dolphin-megasync:
|
||||||
|
dolphin-megasync: HomePage: https://github.com/meganz/MEGAsync
|
||||||
|
dolphin-megasync:
|
||||||
|
dolphin-megasync:
|
||||||
|
dolphin-megasync:
|
||||||
|
dolphin-megasync:
|
||||||
|
dolphin-megasync:
|
Loading…
Reference in a new issue