mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-21 19:42:24 +01:00
libraries/libixp: Updated for version 0.4
This commit is contained in:
parent
2ec9354ad2
commit
fd023843e5
5 changed files with 52 additions and 30 deletions
|
@ -1,6 +1,3 @@
|
||||||
libixp - A standalone client/server 9P library
|
|
||||||
|
|
||||||
libixp is a stand-alone client/server 9P library including ixpc
|
libixp is a stand-alone client/server 9P library including ixpc
|
||||||
client which behaves like wmiir in the past. It consists of less
|
client which behaves like wmiir in the past. It consists of less
|
||||||
than 2000 lines of code (including ixpc).
|
than 2000 lines of code (including ixpc).
|
||||||
|
|
||||||
|
|
18
libraries/libixp/libixp-0.4-libdir.diff
Normal file
18
libraries/libixp/libixp-0.4-libdir.diff
Normal file
|
@ -0,0 +1,18 @@
|
||||||
|
diff -Nur libixp-0.4.orig/mk/lib.mk libixp-0.4/mk/lib.mk
|
||||||
|
--- libixp-0.4.orig/mk/lib.mk 2007-11-05 08:36:22.000000000 -0600
|
||||||
|
+++ libixp-0.4/mk/lib.mk 2009-08-03 00:20:42.479105075 -0500
|
||||||
|
@@ -1,4 +1,4 @@
|
||||||
|
-PTARG = ${ROOT}/lib/${TARG}
|
||||||
|
+PTARG = ${ROOT}/@baselibdir@/${TARG}
|
||||||
|
LIB = ${PTARG}.a
|
||||||
|
OFILES = ${OBJ:=.o}
|
||||||
|
|
||||||
|
@@ -20,7 +20,7 @@
|
||||||
|
|
||||||
|
${LIB}: ${OFILES}
|
||||||
|
echo AR $$($(ROOT)/util/cleanname $(BASE)/$@)
|
||||||
|
- mkdir ${ROOT}/lib 2>/dev/null || true
|
||||||
|
+ mkdir ${ROOT}/@baselibdir@ 2>/dev/null || true
|
||||||
|
${AR} $@ ${OFILES}
|
||||||
|
|
||||||
|
include ${ROOT}/mk/common.mk
|
|
@ -34,10 +34,13 @@ OUTPUT=${OUTPUT:-/tmp}
|
||||||
|
|
||||||
if [ "$ARCH" = "i486" ]; then
|
if [ "$ARCH" = "i486" ]; then
|
||||||
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
|
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
|
||||||
|
LIBDIRSUFFIX=""
|
||||||
elif [ "$ARCH" = "i686" ]; then
|
elif [ "$ARCH" = "i686" ]; then
|
||||||
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
|
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
|
||||||
|
LIBDIRSUFFIX=""
|
||||||
elif [ "$ARCH" = "x86_64" ]; then
|
elif [ "$ARCH" = "x86_64" ]; then
|
||||||
SLKCFLAGS="-O2 -fPIC"
|
SLKCFLAGS="-O2 -fPIC"
|
||||||
|
LIBDIRSUFFIX="64"
|
||||||
fi
|
fi
|
||||||
|
|
||||||
set -e
|
set -e
|
||||||
|
@ -46,7 +49,7 @@ rm -rf $PKG
|
||||||
mkdir -p $TMP $PKG $OUTPUT
|
mkdir -p $TMP $PKG $OUTPUT
|
||||||
cd $TMP
|
cd $TMP
|
||||||
rm -rf $PRGNAM-$VERSION
|
rm -rf $PRGNAM-$VERSION
|
||||||
tar -xzvf $CWD/$PRGNAM-$VERSION.tar.gz
|
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
|
||||||
cd $PRGNAM-$VERSION
|
cd $PRGNAM-$VERSION
|
||||||
chown -R root:root .
|
chown -R root:root .
|
||||||
find . \
|
find . \
|
||||||
|
@ -55,29 +58,32 @@ find . \
|
||||||
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
||||||
-exec chmod 644 {} \;
|
-exec chmod 644 {} \;
|
||||||
|
|
||||||
# Fix prefixes and cflags values
|
# Fix cflags value
|
||||||
sed -i \
|
sed -i 's:^CFLAGS =:CFLAGS += :' config.mk
|
||||||
-e 's:^PREFIX = /usr/local:PREFIX = /usr:' \
|
|
||||||
-e 's:^MAN = ${PREFIX}/share/man:MAN = /usr/man:' \
|
|
||||||
-e 's:^ETC = ${PREFIX}/etc:ETC = /etc:' \
|
|
||||||
-e 's:^CFLAGS =:CFLAGS += :' \
|
|
||||||
config.mk
|
|
||||||
CFLAGS="$SLKCFLAGS" make
|
|
||||||
|
|
||||||
# This is *needed* to install correctly under $PKG
|
CFLAGS="$SLKCFLAGS" make \
|
||||||
sed -i \
|
PREFIX=/usr \
|
||||||
-e 's:^PREFIX = /usr:PREFIX = '${PKG}'/usr:' \
|
LIBDIR=/usr/lib${LIBDIRSUFFIX} \
|
||||||
-e 's:^MAN = /usr/man:MAN = '${PKG}'/usr/man:' \
|
MAN=/usr/man \
|
||||||
-e 's:^ETC = /etc:ETC = '${PKG}'/etc:' \
|
ETC=/etc
|
||||||
config.mk
|
|
||||||
make install
|
# Fix hardcoded /usr/lib
|
||||||
|
sed "s%@baselibdir@%lib$LIBDIRSUFFIX%g" $CWD/libixp-0.4-libdir.diff | patch -p1
|
||||||
|
|
||||||
|
make install \
|
||||||
|
PREFIX=$PKG/usr \
|
||||||
|
LIBDIR=$PKG/usr/lib${LIBDIRSUFFIX} \
|
||||||
|
MAN=$PKG/usr/man \
|
||||||
|
ETC=$PKG/etc
|
||||||
|
|
||||||
# Erase "/etc", it's empty
|
# Erase "/etc", it's empty
|
||||||
rmdir $PKG/etc
|
rmdir $PKG/etc
|
||||||
|
|
||||||
(
|
( cd $PKG
|
||||||
find $PKG | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
|
||||||
find $PKG | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
|
xargs strip --strip-unneeded 2> /dev/null || true
|
||||||
|
find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
|
||||||
|
xargs strip --strip-unneeded 2> /dev/null
|
||||||
)
|
)
|
||||||
|
|
||||||
( cd $PKG/usr/man
|
( cd $PKG/usr/man
|
||||||
|
@ -86,12 +92,11 @@ rmdir $PKG/etc
|
||||||
)
|
)
|
||||||
|
|
||||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||||
cd libixp
|
cp -a libixp/LICENSE* libixp/README $PKG/usr/doc/$PRGNAM-$VERSION
|
||||||
cp -a LICENSE LICENSE.p9p README $PKG/usr/doc/$PRGNAM-$VERSION
|
|
||||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||||
|
|
||||||
mkdir -p $PKG/install
|
mkdir -p $PKG/install
|
||||||
cat $CWD/slack-desc > $PKG/install/slack-desc
|
cat $CWD/slack-desc > $PKG/install/slack-desc
|
||||||
|
|
||||||
cd $PKG
|
cd $PKG
|
||||||
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
|
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
|
||||||
|
|
|
@ -3,6 +3,8 @@ VERSION="0.4"
|
||||||
HOMEPAGE="http://libs.suckless.org/libixp"
|
HOMEPAGE="http://libs.suckless.org/libixp"
|
||||||
DOWNLOAD="http://code.suckless.org/dl/libs/libixp-0.4.tar.gz"
|
DOWNLOAD="http://code.suckless.org/dl/libs/libixp-0.4.tar.gz"
|
||||||
MD5SUM="59d9e918adffaf4413b32ac4f66724fd"
|
MD5SUM="59d9e918adffaf4413b32ac4f66724fd"
|
||||||
|
DOWNLOAD_x86_64=""
|
||||||
|
MD5SUM_x86_64=""
|
||||||
MAINTAINER="Antonio Hernández Blas"
|
MAINTAINER="Antonio Hernández Blas"
|
||||||
EMAIL="hba.nihilismus@gmail.com"
|
EMAIL="hba.nihilismus@gmail.com"
|
||||||
APPROVED="David Somero"
|
APPROVED="dsomero"
|
||||||
|
|
|
@ -13,7 +13,7 @@ libixp: client which behaves like wmiir in the past. It consists of less
|
||||||
libixp: than 2000 lines of code (including ixpc).
|
libixp: than 2000 lines of code (including ixpc).
|
||||||
libixp:
|
libixp:
|
||||||
libixp: Homepage: http://www.suckless.org/wiki/libs/libixp
|
libixp: Homepage: http://www.suckless.org/wiki/libs/libixp
|
||||||
libixp:
|
libixp:
|
||||||
libixp:
|
libixp:
|
||||||
libixp:
|
libixp:
|
||||||
libixp:
|
libixp:
|
||||||
|
|
Loading…
Reference in a new issue