graphics/brlcad: Updated for version 7.24.0.

Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
This commit is contained in:
John Vogel 2013-11-21 23:30:35 -06:00 committed by Robby Workman
parent ad0113f353
commit fc90148bde
3 changed files with 72 additions and 28 deletions

View file

@ -0,0 +1,36 @@
diff -Naur a/src/bwish/CMakeLists.txt b/src/bwish/CMakeLists.txt
--- a/src/bwish/CMakeLists.txt 2013-06-14 01:55:27.000000000 -0400
+++ b/src/bwish/CMakeLists.txt 2013-11-21 20:57:03.386263490 -0500
@@ -14,6 +14,8 @@
include_directories(
${CMAKE_SOURCE_DIR}/src/other/tcl/generic
${CMAKE_SOURCE_DIR}/src/other/tcl/unix
+ ${CMAKE_SOURCE_DIR}/src/other/tk/generic
+ ${CMAKE_SOURCE_DIR}/src/other/tk/unix
${CMAKE_SOURCE_DIR}/src/other/incrTcl/itcl/generic
${CMAKE_SOURCE_DIR}/src/other/incrTcl/itk/generic
)
diff -Naur a/src/libtclcad/CMakeLists.txt b/src/libtclcad/CMakeLists.txt
--- a/src/libtclcad/CMakeLists.txt 2013-06-14 01:55:25.000000000 -0400
+++ b/src/libtclcad/CMakeLists.txt 2013-11-21 20:43:02.865252378 -0500
@@ -10,6 +10,8 @@
set(TCLCAD_LOCAL_INCLUDE_DIRS
${CMAKE_SOURCE_DIR}/src/other/tcl/generic
${CMAKE_SOURCE_DIR}/src/other/tcl/unix
+ ${CMAKE_SOURCE_DIR}/src/other/tk/generic
+ ${CMAKE_SOURCE_DIR}/src/other/tk/unix
${CMAKE_SOURCE_DIR}/src/other/incrTcl/itcl/generic
${CMAKE_SOURCE_DIR}/src/other/incrTcl/itk/generic
${PNG_INCLUDE_DIR}
diff -Naur a/src/mged/CMakeLists.txt b/src/mged/CMakeLists.txt
--- a/src/mged/CMakeLists.txt 2013-06-14 01:55:49.000000000 -0400
+++ b/src/mged/CMakeLists.txt 2013-11-21 21:07:51.444272058 -0500
@@ -15,6 +15,8 @@
include_directories(
${CMAKE_SOURCE_DIR}/src/other/tcl/generic
${CMAKE_SOURCE_DIR}/src/other/tcl/unix
+ ${CMAKE_SOURCE_DIR}/src/other/tk/generic
+ ${CMAKE_SOURCE_DIR}/src/other/tk/unix
${CMAKE_SOURCE_DIR}/src/other/incrTcl/itcl/generic
${CMAKE_SOURCE_DIR}/src/other/incrTcl/itk/generic
)

View file

@ -8,8 +8,10 @@
# Maintained as of version 7.16.6 by Niels Horn <niels.horn@gmail.com>
# Revision date: 2012/09/13
# Modified 2013/11/22 for build with cmake by John Vogel <jvogel4@stny.rr.com>
PRGNAM=brlcad
VERSION=${VERSION:-7.22.0}
VERSION=${VERSION:-7.24.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@ -49,37 +51,43 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Create configure script
sh autogen.sh
patch -p1 -i ${CWD}/brlcad-tcltk_match_includes.patch
mkdir -p build
cd build
# There is a "known issue" according to the guys on #brlcad and we need
# the configure flag "-disable-strict-build" for now
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/opt/$PRGNAM \
--sysconfdir=/etc \
--localstatedir=/var \
--mandir=/opt/$PRGNAM/man \
--with-ogl \
--with-tcl=/usr/lib${LIBDIRSUFFIX} \
--with-tk=/usr/lib${LIBDIRSUFFIX} \
--disable-tcl-build \
--disable-tk-build \
--disable-jove-build \
--disable-strict-build \
--build=$ARCH-slackware-linux
# the cmake define "-DBRLCAD_ENABLE_STRICT=OFF" for now
cmake \
-DBRLCAD_FLAGS_OPTIMIZATION=ON \
-DBRLCAD_ENABLE_STRICT=OFF \
-DBRLCAD_FLAGS_DEBUG=OFF \
-DBRLCAD_BUNDLED_LIBS=OFF \
-DBRLCAD_ITCL=ON \
-DBRLCAD_ITK=ON \
-DBRLCAD_IWIDGETS=ON \
-DBRLCAD_TKHTML=ON \
-DBRLCAD_TKPNG=ON \
-DBRLCAD_TKTABLE=ON \
-DBRLCAD_PNG=ON \
-DCMAKE_INSTALL_PREFIX=/opt/$PRGNAM \
-DMAN_DIR=man \
-DDATA_DIR=share \
-DTCL_INCLUDE_PATH=/usr/include \
-DTCL_INCLUDE_PATH=/usr/include \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" ..
make
make install DESTDIR=$PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
find $PKG/opt/$PRGNAM/man -type f -exec gzip -9 {} \;

View file

@ -1,8 +1,8 @@
PRGNAM="brlcad"
VERSION="7.22.0"
VERSION="7.24.0"
HOMEPAGE="http://brlcad.org"
DOWNLOAD="http://downloads.sourceforge.net/brlcad/brlcad-7.22.0.tar.bz2"
MD5SUM="c284e1a29157e709ecd21ea8dafda519"
DOWNLOAD="http://downloads.sourceforge.net/brlcad/brlcad-7.24.0.tar.bz2"
MD5SUM="ecd94dfaf0b980776c589bb9337a6786"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""