graphics/brlcad: Fix 32bit build.

Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com>

Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
Andrew Clemons 2022-03-21 19:23:34 +13:00 committed by Willy Sudiarto Raharjo
parent bc4830823f
commit fc79a77809
No known key found for this signature in database
GPG key ID: 3F617144D7238786
2 changed files with 19 additions and 1 deletions

View file

@ -0,0 +1,12 @@
--- a/db/nist/CMakeLists.txt
+++ b/db/nist/CMakeLists.txt
@@ -10,7 +10,8 @@ set(NIST_SAMPLE_MODELS
)
foreach(im ${NIST_SAMPLE_MODELS})
- ADD_G_TARGET(${im} "BRL-CAD Geometry Models/Sample")
+# disabled because this often segfaults
+# ADD_G_TARGET(${im} "BRL-CAD Geometry Models/Sample")
endforeach(im ${NIST_SAMPLE_MODELS})
CMAKEFILES(

View file

@ -19,11 +19,13 @@
# Previous version wouldn't build, updated for v7.32.4, and still
# had to patch that.
# 20220321 acl: Modified by SlackBuilds.org: fix build on 15.0 32bit.
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=brlcad
VERSION=${VERSION:-7.32.4}
BUILD=${BUILD:-1}
BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@ -79,6 +81,10 @@ find -L . \
# https://github.com/BRL-CAD/brlcad/commit/b0dd45620f1ffdd8814069df091b20e8780e1b3e
patch -p1 < $CWD/fix-step-g-segfault.diff
# thanks arch maintainers.
# fixes build on i586.
patch -p1 < $CWD/brlcad-7.32.4-skip-gstep.patch
mkdir -p build
cd build
# There is a "known issue" according to the guys on #brlcad and we need