mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-18 22:06:04 +01:00
system/virt-manager: Updated for version 0.10.0.
This almost surely still has bugs, but it's more functional that the version we had. Feedback is welcome and encouraged. Patches are even more so. Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
This commit is contained in:
parent
b5f8ce7e5a
commit
fb12e1f0dd
5 changed files with 52 additions and 41 deletions
|
@ -1,19 +1,20 @@
|
||||||
schema_install() {
|
|
||||||
SCHEMA="$1"
|
|
||||||
GCONF_CONFIG_SOURCE="xml::etc/gconf/gconf.xml.defaults" \
|
|
||||||
chroot . gconftool-2 --makefile-install-rule \
|
|
||||||
/etc/gconf/schemas/$SCHEMA \
|
|
||||||
1>/dev/null
|
|
||||||
}
|
|
||||||
|
|
||||||
schema_install virt-manager.schemas
|
|
||||||
|
|
||||||
if [ -x /usr/bin/update-desktop-database ]; then
|
if [ -x /usr/bin/update-desktop-database ]; then
|
||||||
/usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
|
/usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
|
||||||
fi
|
fi
|
||||||
|
|
||||||
|
if [ -x /usr/bin/update-mime-database ]; then
|
||||||
|
/usr/bin/update-mime-database usr/share/mime >/dev/null 2>&1
|
||||||
|
fi
|
||||||
|
|
||||||
if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
|
if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
|
||||||
if [ -x /usr/bin/gtk-update-icon-cache ]; then
|
if [ -x /usr/bin/gtk-update-icon-cache ]; then
|
||||||
/usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
|
/usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
|
||||||
fi
|
fi
|
||||||
fi
|
fi
|
||||||
|
|
||||||
|
if [ -e usr/share/glib-2.0/schemas ]; then
|
||||||
|
if [ -x /usr/bin/glib-compile-schemas ]; then
|
||||||
|
/usr/bin/glib-compile-schemas usr/share/glib-2.0/schemas >/dev/null 2>&1
|
||||||
|
fi
|
||||||
|
fi
|
||||||
|
|
||||||
|
|
|
@ -1,15 +1,15 @@
|
||||||
# HOW TO EDIT THIS FILE:
|
# HOW TO EDIT THIS FILE:
|
||||||
# The "handy ruler" below makes it easier to edit a package description. Line
|
# The "handy ruler" below makes it easier to edit a package description.
|
||||||
# up the first '|' above the ':' following the base package name, and the '|'
|
# Line up the first '|' above the ':' following the base package name, and
|
||||||
# on the right side marks the last column you can put a character in. You must
|
# the '|' on the right side marks the last column you can put a character in.
|
||||||
# make exactly 11 lines for the formatting to be correct. It's also
|
# You must make exactly 11 lines for the formatting to be correct. It's also
|
||||||
# customary to leave one space after the ':'.
|
# customary to leave one space after the ':' except on otherwise blank lines.
|
||||||
|
|
||||||
|-----handy-ruler------------------------------------------------------|
|
|-----handy-ruler------------------------------------------------------|
|
||||||
virt-manager: virt-manager (a gtk interface for libvirt)
|
virt-manager: virt-manager (a gtk interface for libvirt)
|
||||||
virt-manager:
|
virt-manager:
|
||||||
virt-manager: virt-manager is a gtk interface for libvirt.
|
virt-manager: virt-manager is a gtk interface for libvirt.
|
||||||
virt-manager: It supports both Xen and qemu/kvm.
|
virt-manager: It supports Xen, qemu/kvm, virtualbox, and perhaps others.
|
||||||
virt-manager:
|
virt-manager:
|
||||||
virt-manager:
|
virt-manager:
|
||||||
virt-manager:
|
virt-manager:
|
||||||
|
|
|
@ -2,15 +2,12 @@
|
||||||
|
|
||||||
# Slackware build script for virt-manager
|
# Slackware build script for virt-manager
|
||||||
|
|
||||||
# For version 0.8.3
|
# Written by Ash Wiren ash@spooksoftware.com # Released to public domain.
|
||||||
# Written by Ash Wiren ash@spooksoftware.com
|
|
||||||
# Released to public domain.
|
|
||||||
# Lots of fixes by Robby Workman
|
|
||||||
# For version 0.9.0
|
|
||||||
# Modified by Zoran Stojakovic
|
# Modified by Zoran Stojakovic
|
||||||
|
# Lots of mods by rworkman for 0.10.x
|
||||||
|
|
||||||
PRGNAM=virt-manager
|
PRGNAM=virt-manager
|
||||||
VERSION=${VERSION:-0.9.4}
|
VERSION=${VERSION:-0.10.0}
|
||||||
BUILD=${BUILD:-1}
|
BUILD=${BUILD:-1}
|
||||||
TAG=${TAG:-_SBo}
|
TAG=${TAG:-_SBo}
|
||||||
|
|
||||||
|
@ -56,29 +53,22 @@ find . \
|
||||||
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
||||||
-exec chmod 644 {} \;
|
-exec chmod 644 {} \;
|
||||||
|
|
||||||
CFLAGS="$SLKCFLAGS" \
|
# Add Slackware support
|
||||||
CXXFLAGS="$SLKCFLAGS" \
|
patch -p1 < $CWD/virtinst-osdict.py-Add-Slackware-to-OS-choices.patch
|
||||||
./configure \
|
|
||||||
-prefix=/usr \
|
|
||||||
--libdir=/usr/lib${LIBDIRSUFFIX} \
|
|
||||||
--sysconfdir=/etc \
|
|
||||||
--localstatedir=/var \
|
|
||||||
--mandir=/usr/man \
|
|
||||||
--docdir=/usr/doc/$PRGNAM-$VERSION \
|
|
||||||
--build=$ARCH-slackware-linux
|
|
||||||
|
|
||||||
make
|
python setup.py configure
|
||||||
make install DESTDIR=$PKG
|
python setup.py install --root=$PKG
|
||||||
|
|
||||||
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
|
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
|
||||||
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
||||||
|
|
||||||
|
mv $PKG/usr/share/man $PKG/usr
|
||||||
find $PKG/usr/man -type f -exec gzip -9 {} \;
|
find $PKG/usr/man -type f -exec gzip -9 {} \;
|
||||||
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
|
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
|
||||||
|
|
||||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||||
cp -a \
|
cp -a \
|
||||||
ABOUT-NLS ChangeLog AUTHORS COPYING COPYING-DOCS HACKING INSTALL NEWS README \
|
COPYING HACKING INSTALL NEWS README \
|
||||||
$PKG/usr/doc/$PRGNAM-$VERSION
|
$PKG/usr/doc/$PRGNAM-$VERSION
|
||||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||||
|
|
||||||
|
|
|
@ -1,10 +1,10 @@
|
||||||
PRGNAM="virt-manager"
|
PRGNAM="virt-manager"
|
||||||
VERSION="0.9.4"
|
VERSION="0.10.0"
|
||||||
HOMEPAGE="http://virt-manager.et.redhat.com"
|
HOMEPAGE="http://virt-manager.et.redhat.com"
|
||||||
DOWNLOAD="http://virt-manager.et.redhat.com/download/sources/virt-manager/virt-manager-0.9.4.tar.gz"
|
DOWNLOAD="http://virt-manager.org/download/sources/virt-manager/virt-manager-0.10.0.tar.gz"
|
||||||
MD5SUM="7f724839749f6d8d2e57ce8bb8a6a76f"
|
MD5SUM="e23b8d2a7623b4e8e256c25735f332c8"
|
||||||
DOWNLOAD_x86_64=""
|
DOWNLOAD_x86_64=""
|
||||||
MD5SUM_x86_64=""
|
MD5SUM_x86_64=""
|
||||||
REQUIRES="gnome-python gtk-vnc qemu rarian tunctl urlgrabber virtinst"
|
REQUIRES="libvirt-glib gnome-python2-gconf tunctl ipaddr-py urlgrabber pygobject3 gtk-vnc spice-gtk vte3"
|
||||||
MAINTAINER="Zoran Stojakovic"
|
MAINTAINER="Robby Workman"
|
||||||
EMAIL="stojakovic.zoran@gmail.com"
|
EMAIL="rworkman@slackbuilds.org"
|
||||||
|
|
|
@ -0,0 +1,20 @@
|
||||||
|
diff -Nur virt-manager-0.10.0.orig/virtinst/osdict.py virt-manager-0.10.0/virtinst/osdict.py
|
||||||
|
--- virt-manager-0.10.0.orig/virtinst/osdict.py 2013-06-13 14:10:00.000000000 -0500
|
||||||
|
+++ virt-manager-0.10.0/virtinst/osdict.py 2013-11-11 17:47:51.907305561 -0600
|
||||||
|
@@ -619,7 +619,15 @@
|
||||||
|
VIDEO : VMVGA_VIDEO,
|
||||||
|
},
|
||||||
|
},
|
||||||
|
-
|
||||||
|
+ "slackware": {
|
||||||
|
+ "label": "Slackware",
|
||||||
|
+ "distro": "slackware",
|
||||||
|
+ "supported": False,
|
||||||
|
+ "devices" : {
|
||||||
|
+ DISK : VIRTIO_DISK,
|
||||||
|
+ NET : VIRTIO_NET,
|
||||||
|
+ },
|
||||||
|
+ },
|
||||||
|
"generic24": {
|
||||||
|
"label": "Generic 2.4.x kernel"
|
||||||
|
},
|
Loading…
Reference in a new issue