mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-20 19:41:34 +01:00
libraries/libsigrokdecode: Patched to build with python-3.5.
Signed-off-by: David Spencer <baildon.research@googlemail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
c04609e670
commit
f8c699978f
2 changed files with 28 additions and 0 deletions
|
@ -0,0 +1,24 @@
|
|||
diff -u -r libsigrokdecode-0.3.1-orig/configure.ac libsigrokdecode-0.3.1/configure.ac
|
||||
--- libsigrokdecode-0.3.1-orig/configure.ac 2015-07-12 21:35:14.000000000 +0100
|
||||
+++ libsigrokdecode-0.3.1/configure.ac 2015-12-21 19:23:07.809995006 +0000
|
||||
@@ -99,6 +99,11 @@
|
||||
CPPFLAGS_PYTHON="$CPPFLAGS_PYTHON $python3_CFLAGS";
|
||||
LDFLAGS_PYTHON="$LDFLAGS_PYTHON $python3_LIBS";
|
||||
MODNAME_PYTHON="python3"],
|
||||
+[PKG_CHECK_MODULES([python35], [python-3.5 >= 3.5],
|
||||
+ [pyver=`$PKG_CONFIG --modversion python-3.5`;
|
||||
+ CPPFLAGS_PYTHON="$CPPFLAGS_PYTHON $python35_CFLAGS";
|
||||
+ LDFLAGS_PYTHON="$LDFLAGS_PYTHON $python35_LIBS";
|
||||
+ MODNAME_PYTHON="python-3.5"],
|
||||
[PKG_CHECK_MODULES([python34], [python-3.4 >= 3.4],
|
||||
[pyver=`$PKG_CONFIG --modversion python-3.4`;
|
||||
CPPFLAGS_PYTHON="$CPPFLAGS_PYTHON $python34_CFLAGS";
|
||||
@@ -114,7 +119,7 @@
|
||||
CPPFLAGS_PYTHON="$CPPFLAGS_PYTHON $python32_CFLAGS";
|
||||
LDFLAGS_PYTHON="$LDFLAGS_PYTHON $python32_LIBS";
|
||||
MODNAME_PYTHON="python-3.2"],
|
||||
-)])])])
|
||||
+)])])])])
|
||||
AC_SUBST(CPPFLAGS_PYTHON)
|
||||
AC_SUBST(LDFLAGS_PYTHON)
|
||||
AC_SUBST(MODNAME_PYTHON)
|
|
@ -69,6 +69,10 @@ find -L . \
|
|||
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||
|
||||
# Patch to add Python 3.5 support
|
||||
patch -p1 < $CWD/libsigrokdecode-0.3.1_python3-3.5.diff
|
||||
autoreconf
|
||||
|
||||
CFLAGS="$SLKCFLAGS" \
|
||||
CXXFLAGS="$SLKCFLAGS" \
|
||||
./configure \
|
||||
|
|
Loading…
Reference in a new issue