mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-25 10:03:03 +01:00
games/bsnes: Updated for version 091.
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
This commit is contained in:
parent
4458b0416b
commit
f789d4c1ab
3 changed files with 30 additions and 62 deletions
|
@ -1,40 +0,0 @@
|
|||
diff --git a/bsnes/Makefile b/bsnes/Makefile
|
||||
index 4af8708..2e95a38 100755
|
||||
--- a/bsnes/Makefile
|
||||
+++ b/bsnes/Makefile
|
||||
@@ -10,7 +10,7 @@ options :=
|
||||
# compiler
|
||||
c := $(compiler) -std=gnu99
|
||||
cpp := $(subst cc,++,$(compiler)) -std=gnu++0x
|
||||
-flags := -O3 -fomit-frame-pointer -I.
|
||||
+flags := $(CXXFLAGS) -fomit-frame-pointer -I.
|
||||
link :=
|
||||
objects := libco
|
||||
|
||||
@@ -25,7 +25,7 @@ flags := $(flags) $(foreach o,$(call strupper,$(options)),-D$o)
|
||||
|
||||
# platform
|
||||
ifeq ($(platform),x)
|
||||
- link += -s -ldl -lX11 -lXext
|
||||
+ link += -ldl -lX11 -lXext
|
||||
else ifeq ($(platform),osx)
|
||||
else ifeq ($(platform),win)
|
||||
link += -mwindows
|
||||
diff --git a/bsnes/ui/Makefile b/bsnes/ui/Makefile
|
||||
index 7cf3420..dd3f89b 100755
|
||||
--- a/bsnes/ui/Makefile
|
||||
+++ b/bsnes/ui/Makefile
|
||||
@@ -94,11 +94,8 @@ install:
|
||||
ifeq ($(platform),x)
|
||||
install -D -m 755 out/bsnes $(DESTDIR)$(prefix)/bin/bsnes
|
||||
endif
|
||||
- install -D -m 644 data/bsnes.png $(DESTDIR)$(prefix)/share/pixmaps/bsnes.png
|
||||
- install -D -m 644 data/bsnes.desktop $(DESTDIR)$(prefix)/share/applications/bsnes.desktop
|
||||
- mkdir -p ~/.config/bsnes
|
||||
- cp data/cheats.xml ~/.config/bsnes/cheats.xml
|
||||
- chmod 777 ~/.config/bsnes ~/.config/bsnes/cheats.xml
|
||||
+ install -D -m 644 data/bsnes.png $(DESTDIR)/usr/share/pixmaps/bsnes.png
|
||||
+ install -D -m 644 data/bsnes.desktop $(DESTDIR)/usr/share/applications/bsnes.desktop
|
||||
|
||||
uninstall:
|
||||
ifeq ($(platform),x)
|
|
@ -5,8 +5,7 @@
|
|||
# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
|
||||
|
||||
PRGNAM=bsnes
|
||||
VERSION=${VERSION:-0.082}
|
||||
SRCVER=${VERSION:2}
|
||||
VERSION=${VERSION:-091}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
|
@ -42,9 +41,9 @@ set -e
|
|||
rm -rf $PKG
|
||||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
rm -rf ${PRGNAM}_v${SRCVER}-source
|
||||
tar xvf $CWD/${PRGNAM}_v${SRCVER}-source.tar.bz2
|
||||
cd ${PRGNAM}_v${SRCVER}-source
|
||||
rm -rf ${PRGNAM}_v${VERSION}-source
|
||||
tar xvf $CWD/${PRGNAM}_v${VERSION}-source.tar.xz
|
||||
cd ${PRGNAM}_v${VERSION}-source
|
||||
find . -type d -exec chmod -R 0755 {} \;
|
||||
chown -R root:root .
|
||||
find . \
|
||||
|
@ -53,18 +52,15 @@ find . \
|
|||
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
||||
-exec chmod 644 {} \;
|
||||
|
||||
# Patch makefile so SLKCFLAGS are recognized.
|
||||
patch -p1 < $CWD/bsnes-0.077-makefile.patch
|
||||
|
||||
cd $PRGNAM
|
||||
|
||||
# Remove pulseaudio as there is no package for it at SBo.
|
||||
# Comment out or delete the following 4 lines to enable pulseaudio.
|
||||
sed -i \
|
||||
-e 's|audio.pulseaudio ||' \
|
||||
-e 's|audio.pulseaudiosimple ||' \
|
||||
-e '/pulse/d' ui{,-gameboy}/Makefile
|
||||
sed -e 's|audio.pulseaudio ||' \
|
||||
-e 's|audio.pulseaudiosimple ||' \
|
||||
-i 'target-ethos/Makefile'
|
||||
|
||||
moc -i -Iphoenix/qt/ -o phoenix/qt/platform.moc phoenix/qt/platform.moc.hpp
|
||||
sed -e 's/sudo install/install/' \
|
||||
-i 'target-ethos/Makefile'
|
||||
# Choose whether qt or gtk interface is used. Qt4 is default.
|
||||
if [ "${INTERFACE:-QT4}" != 'QT4' ]; then
|
||||
PHOENIX='gtk'
|
||||
|
@ -84,20 +80,32 @@ make \
|
|||
phoenix="$PHOENIX" \
|
||||
profile="$PROFILE"
|
||||
|
||||
make install DESTDIR=$PKG prefix=/usr
|
||||
make install profile=$PROFILE DESTDIR=$PKG prefix=/usr
|
||||
cd ..
|
||||
|
||||
# Compile snespurify. It helps clean up ROMS for use with bsnes.
|
||||
cd snespurify
|
||||
cd purify
|
||||
# Fix building with QT >= 4.8.0.
|
||||
moc -i -Iphoenix/qt/ -o phoenix/qt/platform.moc phoenix/qt/platform.moc.hpp
|
||||
|
||||
# Fix snespurify scripts.
|
||||
sed -i -e 's|g++-4.5|g++|g' -e "s|-O3|$SLKCFLAGS|" cc-${PHOENIX}.sh
|
||||
./cc-${PHOENIX}.sh
|
||||
install -m 0755 snespurify-$PHOENIX $PKG/usr/bin
|
||||
sed -e 's|link := -s|link := -s -lX11|' -i 'Makefile'
|
||||
|
||||
make \
|
||||
compiler=gcc \
|
||||
platform=x \
|
||||
phoenix="$PHOENIX"
|
||||
|
||||
mkdir -p $PKG/usr/bin
|
||||
install -m 0755 purify $PKG/usr/bin/$PRGNAM-purify
|
||||
cd ..
|
||||
|
||||
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
|
||||
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
||||
|
||||
mkdir -p $PKG/usr/share/$PRGNAM/profile
|
||||
cp -R bsnes/profile/* $PKG/usr/share/$PRGNAM/profile
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
PRGNAM="bsnes"
|
||||
VERSION="0.082"
|
||||
VERSION="091"
|
||||
HOMEPAGE="http://byuu.org/bsnes/"
|
||||
DOWNLOAD="http://bsnes.googlecode.com/files/bsnes_v082-source.tar.bz2"
|
||||
MD5SUM="c7deead3fb28bcf1aa7bcef44f236f59"
|
||||
DOWNLOAD="http://bsnes.googlecode.com/files/bsnes_v091-source.tar.xz"
|
||||
MD5SUM="ba53212c56990e83d7770393c4e2d173"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES="OpenAL"
|
||||
|
|
Loading…
Reference in a new issue