games/ppsspp: Added (fast and portable PSP emulator).

Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
This commit is contained in:
Hunter Sezen 2016-08-02 22:21:27 +01:00 committed by David Spencer
parent 53956504b1
commit f4020cea36
6 changed files with 194 additions and 0 deletions

13
games/ppsspp/README Normal file
View file

@ -0,0 +1,13 @@
PPSSPP can run your PSP games on your PC in full HD resolution. It can
even upscale textures that would otherwise be too blurry as they were
made for the small screen of the original PSP.
* Play in HD resolutions and more
* Play on a tablet for big-screen mobile gaming
* Customize on-screen touch controls or use an external controller or
keyboard
* Save and restore game state anywhere, anytime
* Crank up the anisotropic filtering and texture scaling
* Continue where you left off by transferring saves from your real PSP
snappy is an optional dependency.

9
games/ppsspp/doinst.sh Normal file
View file

@ -0,0 +1,9 @@
if [ -x /usr/bin/update-desktop-database ]; then
/usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
fi
if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
if [ -x /usr/bin/gtk-update-icon-cache ]; then
/usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
fi
fi

View file

@ -0,0 +1,24 @@
diff -u -r ppsspp-2016.07.25_fa3f219-orig/CMakeLists.txt ppsspp-2016.07.25_fa3f219/CMakeLists.txt
--- ppsspp-2016.07.25_fa3f219-orig/CMakeLists.txt 2016-08-02 05:10:55.000000000 +0100
+++ ppsspp-2016.07.25_fa3f219/CMakeLists.txt 2016-08-02 21:56:56.983679009 +0100
@@ -33,20 +33,6 @@
endif()
endif()
-# Using ccache greatly improves the speed of our CI builds, let's enable for all.
-# Without this, our CI can't use ccache for clang, for some reason.
-find_program(CCACHE_FOUND ccache)
-if(CCACHE_FOUND)
- set_property(GLOBAL PROPERTY RULE_LAUNCH_COMPILE ccache)
- set_property(GLOBAL PROPERTY RULE_LAUNCH_LINK ccache)
-
- # ccache uses -I when compiling without preprocessor, which makes clang complain.
- if("${CMAKE_CXX_COMPILER_ID}" STREQUAL "Clang")
- set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Qunused-arguments -fcolor-diagnostics")
- set (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Qunused-arguments -fcolor-diagnostics")
- endif()
-endif(CCACHE_FOUND)
-
# Remove soon?
set(USE_FFMPEG ON)

View file

@ -0,0 +1,119 @@
#!/bin/sh
# Slackware build script for ppsspp
# Copyright 2016 Hunter Sezen California, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=ppsspp
SRCNAM=$(echo $PRGNAM | tr [a-z] [A-Z])
VERSION=${VERSION:-2016.07.25_fa3f219}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
fi
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i586" ]; then
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
fi
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.xz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Upstream apparently utterly clueless about how to invoke ccache
patch -p1 < $CWD/ppsspp-no-ccache.patch
mkdir -p build
cd build
cmake \
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_SKIP_RPATH=TRUE \
-DUSE_SYSTEM_FFMPEG=ON \
-Wno-dev \
-DCMAKE_BUILD_TYPE=Release ..
make
# No install target
mkdir -p $PKG/usr/share/{applications,icons/hicolor,$PRGNAM}
install -Dm0755 ${SRCNAM}SDL $PKG/usr/games/$PRGNAM
install -Dm0644 ../assets/unix-icons/icon-512.svg $PKG/usr/share/pixmaps/$PRGNAM.svg
cp -a assets $PKG/usr/share/$PRGNAM
cd ..
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
cp -a assets/unix-icons/hicolor/* $PKG/usr/share/icons/hicolor/
# Write a desktop file
cat > $PKG/usr/share/applications/$PRGNAM.desktop <<EOF
[Desktop Entry]
Name=$SRCNAM
Exec=$PRGNAM
Icon=$PRGNAM
Type=Application
Comment=$SRCNAM (fast and portable PSP emulator)
Categories=Game
EOF
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a LICENSE.TXT README.md korean.txt chinese.txt $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-${VERSION}-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}

10
games/ppsspp/ppsspp.info Normal file
View file

@ -0,0 +1,10 @@
PRGNAM="ppsspp"
VERSION="2016.07.25_fa3f219"
HOMEPAGE="http://www.ppsspp.org/"
DOWNLOAD="http://ks392457.kimsufi.com/orbea/stuff/slackbuilds/src/ppsspp-2016.07.25_fa3f219.tar.xz"
MD5SUM="d17140afc3ec3e60cae000263332ef5d"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="SDL2"
MAINTAINER="Hunter Sezen"
EMAIL="ovariegata@yahoo.com"

19
games/ppsspp/slack-desc Normal file
View file

@ -0,0 +1,19 @@
# HOW TO EDIT THIS FILE:
# The "handy ruler" below makes it easier to edit a package description.
# Line up the first '|' above the ':' following the base package name, and
# the '|' on the right side marks the last column you can put a character in.
# You must make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':' except on otherwise blank lines.
|-----handy-ruler------------------------------------------------------|
ppsspp: ppsspp (fast and portable PSP emulator)
ppsspp:
ppsspp: PPSSPP can run your PSP games on your PC in full HD resolution. It
ppsspp: can even upscale textures that would otherwise be too blurry as they
ppsspp: were made for the small screen of the original PSP.
ppsspp:
ppsspp: Homepage: http://www.ppsspp.org/
ppsspp:
ppsspp:
ppsspp:
ppsspp: