mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-18 22:06:04 +01:00
libraries/libvirt: Updated for version 3.8.0.
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
This commit is contained in:
parent
145c39c6dc
commit
f379b44d66
3 changed files with 34 additions and 4 deletions
|
@ -0,0 +1,27 @@
|
|||
From 65a983eca1f44eaf2a209ae232f72aa659184945 Mon Sep 17 00:00:00 2001
|
||||
From: Kothapally Madhu Pavan <kmp@linux.vnet.ibm.com>
|
||||
Date: Wed, 4 Oct 2017 14:08:45 +0530
|
||||
Subject: [PATCH] util: Free a pointer in virPolkitCheckAuth
|
||||
|
||||
Free DBusMessage pointer in virPolkitCheckAuth
|
||||
|
||||
Signed-off-by: Kothapally Madhu Pavan <kmp@linux.vnet.ibm.com>
|
||||
---
|
||||
src/util/virpolkit.c | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/src/util/virpolkit.c b/src/util/virpolkit.c
|
||||
index c735ca9b1..4559431ba 100644
|
||||
--- a/src/util/virpolkit.c
|
||||
+++ b/src/util/virpolkit.c
|
||||
@@ -138,6 +138,7 @@ int virPolkitCheckAuth(const char *actionid,
|
||||
|
||||
cleanup:
|
||||
virStringListFreeCount(retdetails, nretdetails);
|
||||
+ virDBusMessageUnref(reply);
|
||||
return ret;
|
||||
}
|
||||
|
||||
--
|
||||
2.14.1
|
||||
|
|
@ -5,7 +5,7 @@
|
|||
# Maintained by Robby Workman <rworkman@slackbuilds.org>
|
||||
|
||||
PRGNAM=libvirt
|
||||
VERSION=${VERSION:-3.7.0}
|
||||
VERSION=${VERSION:-3.8.0}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
|
@ -56,6 +56,9 @@ sed -i "s|(prefix)/lib/sysctl|(sysconfdir)/sysctl|" daemon/Makefile.in
|
|||
patch -p1 < $CWD/use-virtgroup-in-polkit-rules.diff
|
||||
sed -i -e "s,@VIRTGROUP@,$VIRTGROUP,g" daemon/libvirt.rules
|
||||
|
||||
# Include an upstream patch from git that we (may) need on SBo server
|
||||
patch -p1 < $CWD/0001-util-Free-a-pointer-in-virPolkitCheckAuth.patch
|
||||
|
||||
CFLAGS="$SLKCFLAGS" \
|
||||
./configure \
|
||||
--prefix=/usr \
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
PRGNAM="libvirt"
|
||||
VERSION="3.7.0"
|
||||
VERSION="3.8.0"
|
||||
HOMEPAGE="http://libvirt.org"
|
||||
DOWNLOAD="ftp://libvirt.org/libvirt/libvirt-3.7.0.tar.xz"
|
||||
MD5SUM="ba87ac97771883280164987d20bcaba0"
|
||||
DOWNLOAD="ftp://libvirt.org/libvirt/libvirt-3.8.0.tar.xz"
|
||||
MD5SUM="cc6bfd0a1dd9557eb81bc971d6a3e02e"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES="yajl urlgrabber"
|
||||
|
|
Loading…
Reference in a new issue