graphics/tuxpaint: Updated for version 0.9.22.

Fixes build failure with libpng16 on -current.

Signed-off-by: David Spencer <baildon.research@googlemail.com>

Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
David Spencer 2015-08-04 14:45:37 +01:00 committed by Willy Sudiarto Raharjo
parent 4cb2dba1c3
commit f21ae97584
4 changed files with 27 additions and 37 deletions

View file

@ -17,10 +17,6 @@ if [ -x /usr/bin/update-desktop-database ]; then
/usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
fi
if [ -x /usr/bin/update-mime-database ]; then
/usr/bin/update-mime-database usr/share/mime >/dev/null 2>&1
fi
if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
if [ -x /usr/bin/gtk-update-icon-cache ]; then
/usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1

View file

@ -1,11 +1,11 @@
diff -ur tuxpaint-0.9.21.org/Makefile tuxpaint-0.9.21/Makefile
--- tuxpaint-0.9.21.org/Makefile 2009-04-29 02:18:57.000000000 -0300
+++ tuxpaint-0.9.21/Makefile 2009-10-31 20:56:18.000000000 -0300
@@ -120,14 +120,14 @@
diff -u -r tuxpaint-0.9.22/Makefile tuxpaint-0.9.22-patched/Makefile
--- tuxpaint-0.9.22/Makefile 2014-08-19 08:28:33.000000000 +0100
+++ tuxpaint-0.9.22-patched/Makefile 2015-08-04 14:35:11.258065084 +0100
@@ -138,14 +138,14 @@
# Magic Tool plug-ins
INCLUDE_PREFIX:=$(DESTDIR)$(PREFIX)/include
-MAGIC_PREFIX:=$(DESTDIR)$(PREFIX)/lib/tuxpaint/plugins
-MAGIC_PREFIX:=$(DESTDIR)$(LIBDIR)/lib/tuxpaint/plugins
+MAGIC_PREFIX:=$(DESTDIR)$(PREFIX)/lib$(LIBDIRSUFFIX)/tuxpaint/plugins
@ -19,9 +19,9 @@ diff -ur tuxpaint-0.9.21.org/Makefile tuxpaint-0.9.21/Makefile
+MAN_PREFIX:=$(DESTDIR)$(PREFIX)/man
+DEVMAN_PREFIX:=$(DESTDIR)$(PREFIX)/man
# 'System-wide' Config file:
@@ -139,10 +139,10 @@
# BASH tab-completion file:
COMPLETIONDIR:=$(DESTDIR)/etc/bash_completion.d
@@ -163,10 +163,10 @@
# Icons and launchers:
ICON_PREFIX:=$(DESTDIR)$(PREFIX)/share/pixmaps
@ -35,16 +35,16 @@ diff -ur tuxpaint-0.9.21.org/Makefile tuxpaint-0.9.21/Makefile
# Maemo flag
MAEMOFLAG:=
@@ -393,7 +393,7 @@
@@ -435,7 +435,7 @@
windows_ARCH_INSTALL:=
osx_ARCH_INSTALL:=
beos_ARCH_INSTALL:=
beos_ARCH_INSTALL:=install-haiku
-linux_ARCH_INSTALL:=install-gnome install-kde install-kde-icons
+linux_ARCH_INSTALL:=install-kde install-kde-icons
ARCH_INSTALL:=$($(OS)_ARCH_INSTALL)
# "make install" installs all of the various parts
@@ -449,7 +449,8 @@
@@ -494,7 +494,8 @@
@cp src/tp_magic_api.h $(INCLUDE_PREFIX)/tuxpaint
@chmod a+r,g-w,o-w $(INCLUDE_PREFIX)/tuxpaint/tp_magic_api.h
@install -d $(DEVDOC_PREFIX)
@ -54,7 +54,7 @@ diff -ur tuxpaint-0.9.21.org/Makefile tuxpaint-0.9.21/Makefile
@chmod a=rX,g=rX,u=rwX $(DEVDOC_PREFIX)
# Installs the various parts for the MinGW/MSYS development/testing environment.
@@ -521,7 +522,7 @@
@@ -573,7 +574,7 @@
rm /usr/share/pixmaps/tuxpaint.png; \
fi
-if [ "x$(KDE_PREFIX)" != "x" ]; then \
@ -63,7 +63,7 @@ diff -ur tuxpaint-0.9.21.org/Makefile tuxpaint-0.9.21/Makefile
fi
-rm $(ICON_PREFIX)/tuxpaint.png
-rm $(X11_ICON_PREFIX)/tuxpaint.xpm
@@ -628,9 +629,9 @@
@@ -761,9 +762,9 @@
@echo
@echo "...Installing launcher icon into KDE..."
@if [ "x$(KDE_PREFIX)" != "x" ]; then \
@ -76,7 +76,7 @@ diff -ur tuxpaint-0.9.21.org/Makefile tuxpaint-0.9.21/Makefile
fi
.PHONY: install-kde-icons
@@ -791,8 +792,7 @@
@@ -944,8 +945,7 @@
@echo
@echo "...Installing documentation..."
@install -d $(DOC_PREFIX)
@ -86,7 +86,7 @@ diff -ur tuxpaint-0.9.21.org/Makefile tuxpaint-0.9.21/Makefile
@chmod -R a=rX,g=rX,u=rwX $(DOC_PREFIX)
@@ -806,21 +806,21 @@
@@ -959,21 +959,21 @@
@# tuxpaint.1
@cp src/manpage/tuxpaint.1 $(MAN_PREFIX)/man1
@gzip -f $(MAN_PREFIX)/man1/tuxpaint.1

View file

@ -6,8 +6,8 @@
# Modified by Willy Sudiarto Raharjo <willysr@slackware-id.org>
PRGNAM=tuxpaint
VERSION=${VERSION:-0.9.21}
BUILD=${BUILD:-2}
VERSION=${VERSION:-0.9.22}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@ -47,25 +47,19 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Create a more util Makefile
# Create a more useful Makefile
patch -p1 < $CWD/patch.diff
# Explicitly link libpng
sed -i 's/$(ARCH_LINKS)/$(ARCH_LINKS) -lpng/' Makefile
make PREFIX=/usr LIBDIRSUFFIX=$LIBDIRSUFFIX OPTFLAGS="$SLKCFLAGS"
make PREFIX=/usr LIBDIRSUFFIX=$LIBDIRSUFFIX DESTDIR=$PKG install
mv $PKG/etc/tuxpaint/tuxpaint.conf $PKG/etc/tuxpaint/tuxpaint.conf.new
# Puzzle plugin is broken
rm -f $PKG/usr/lib64/tuxpaint/plugins/puzzle.so
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

View file

@ -1,10 +1,10 @@
PRGNAM="tuxpaint"
VERSION="0.9.21"
VERSION="0.9.22"
HOMEPAGE="http://www.tuxpaint.org"
DOWNLOAD="http://downloads.sourceforge.net/tuxpaint/tuxpaint-0.9.21.tar.gz"
MD5SUM="a88401d1860648098eeed819cff038fa"
DOWNLOAD="http://downloads.sourceforge.net/tuxpaint/tuxpaint-0.9.22.tar.gz"
MD5SUM="bb9d7e4460ed8084be23b5dfcbf49ef3"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="libpaper"
REQUIRES="libpaper SDL_Pango"
MAINTAINER="Pablo Santamaria"
EMAIL="pablosantamaria@gmail.com"