mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-21 19:42:24 +01:00
network/transmission: Updated for version 1.06
This commit is contained in:
parent
14afbce1ab
commit
f1496db6a4
5 changed files with 51 additions and 67 deletions
|
@ -1,30 +0,0 @@
|
|||
diff -urN Transmission-0.6.1/mk/common.mk Transmission-0.6.1-patched/mk/common.mk
|
||||
--- Transmission-0.6.1/mk/common.mk 2006-06-26 00:34:31.000000000 +0300
|
||||
+++ Transmission-0.6.1-patched/mk/common.mk 2007-03-30 16:00:50.000000000 +0300
|
||||
@@ -62,20 +62,20 @@
|
||||
|
||||
define INSTALL_BIN_RULE
|
||||
@echo "Install $<"
|
||||
- @$(MKDIR) $(PREFIX)/bin
|
||||
- @$(CP) $< $(PREFIX)/bin/
|
||||
+ @$(MKDIR) $(DESTDIR)$(PREFIX)/bin
|
||||
+ @$(CP) $< $(DESTDIR)$(PREFIX)/bin/
|
||||
endef
|
||||
|
||||
define INSTALL_LOCALE_RULE
|
||||
@echo "Install $<"
|
||||
- @$(MKDIR) $(LOCALEDIR)/$*/LC_MESSAGES
|
||||
- @$(CP) $< $(LOCALEDIR)/$*/LC_MESSAGES/transmission-gtk.mo
|
||||
+ @$(MKDIR) $(DESTDIR)$(LOCALEDIR)/$*/LC_MESSAGES
|
||||
+ @$(CP) $< $(DESTDIR)$(LOCALEDIR)/$*/LC_MESSAGES/transmission-gtk.mo
|
||||
endef
|
||||
|
||||
define INSTALL_MAN_RULE
|
||||
@echo "Install $<"
|
||||
- @$(MKDIR) $(PREFIX)/man/man1
|
||||
- @$(CP) $< $(PREFIX)/man/man1/
|
||||
+ @$(MKDIR) $(DESTDIR)$(PREFIX)/man/man1
|
||||
+ @$(CP) $< $(DESTDIR)$(PREFIX)/man/man1/
|
||||
endef
|
||||
|
||||
RM = rm -Rf
|
|
@ -1,5 +1,7 @@
|
|||
Transmission is a lightweight BitTorrent client. It features a simple,
|
||||
intuitive interface on top on an efficient, cross-platform back-end.
|
||||
Transmission runs on Mac OS X with a Cocoa interface,
|
||||
Linux/NetBSD/FreeBSD/OpenBSD with a GTK+ interface, and BeOS with a native
|
||||
interface.
|
||||
Transmission is a lightweight open source BitTorrent client,
|
||||
providing useful functionality without feature bloat. It consists
|
||||
of a daemon, a GTK+ and a CLI client.
|
||||
|
||||
Dependencies: libevent (available at SlackBuilds.org) is required,
|
||||
but transmission will use a built-in libevent if you don't have
|
||||
it installed already.
|
||||
|
|
|
@ -1,11 +1,19 @@
|
|||
transmission: transmission (A lightweight BitTorrent client)
|
||||
transmission:
|
||||
transmission: Transmission is a lightweight BitTorrent client. It features a
|
||||
transmission: simple, intuitive interface on top on an efficient,
|
||||
transmission: cross-platform back-end. Transmission runs on Mac OS X with a
|
||||
transmission: Cocoa interface, Linux/NetBSD/FreeBSD/OpenBSD with a GTK+
|
||||
transmission: interface, and BeOS with a native interface.
|
||||
# HOW TO EDIT THIS FILE:
|
||||
# The "handy ruler" below makes it easier to edit a package description. Line
|
||||
# up the first '|' above the ':' following the base package name, and the '|'
|
||||
# on the right side marks the last column you can put a character in. You must
|
||||
# make exactly 11 lines for the formatting to be correct. It's also
|
||||
# customary to leave one space after the ':'.
|
||||
|
||||
|-----handy-ruler------------------------------------------------------|
|
||||
transmission: Transmission (bittorrent client)
|
||||
transmission:
|
||||
transmission: Transmission is a lightweight open source BitTorrent client,
|
||||
transmission: providing useful functionality without feature bloat.
|
||||
transmission: It consists of a daemon, a GTK+ and a CLI client.
|
||||
transmission:
|
||||
transmission: http://transmission.m0k.org/
|
||||
transmission:
|
||||
transmission:
|
||||
transmission: Homepage: http://transmission.m0k.org/
|
||||
transmission:
|
||||
transmission:
|
||||
|
|
|
@ -1,22 +1,22 @@
|
|||
#!/bin/sh
|
||||
|
||||
# Slackware build script for transmission
|
||||
# Written by Vasilis Papavasileiou <el03020 at mail dot ntua dot gr>
|
||||
# Modified by the SlackBuilds.org project
|
||||
# (assumed to be in public domain per our submission policy)
|
||||
# Written by Iskar Enev <iskar.enev[@]gmail.com>
|
||||
|
||||
# Update by Andrew Brouwers, abrouwers at gmail dot com
|
||||
|
||||
PRGNAM=transmission
|
||||
ORIG_PRGNAM=Transmission
|
||||
VERSION=0.6.1
|
||||
VERSION=1.06
|
||||
ARCH=${ARCH:-i486}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
CWD=$(pwd)
|
||||
TMP=${TMP:-/tmp/SBo}
|
||||
PKG=$TMP/package-$PRGNAM
|
||||
OUTPUT=${OUTPUT:-/tmp}
|
||||
|
||||
DOCS="AUTHORS LICENSE NEWS README"
|
||||
DOCUMENTATION="AUTHORS COPYING INSTALL LICENSE NEWS README"
|
||||
|
||||
if [ "$ARCH" = "i486" ]; then
|
||||
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
|
||||
|
@ -24,26 +24,30 @@ elif [ "$ARCH" = "i686" ]; then
|
|||
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
|
||||
fi
|
||||
|
||||
set -e
|
||||
|
||||
rm -rf $PKG
|
||||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP || exit 1
|
||||
rm -rf $ORIG_PRGNAM-$VERSION
|
||||
tar -xzvf $CWD/$ORIG_PRGNAM-$VERSION.tar.gz || exit 1
|
||||
cd $ORIG_PRGNAM-$VERSION || exit 1
|
||||
cd $TMP
|
||||
rm -rf $PRGNAM-$VERSION
|
||||
mkdir -p $PRGNAM-$VERSION
|
||||
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
|
||||
cd $PRGNAM-$VERSION
|
||||
chown -R root:root .
|
||||
chmod -R u+w,go+r-w,a-s .
|
||||
|
||||
# Patch mk/common.mk so that we can install cleanly (with DESTDIR)
|
||||
patch -p1 <$CWD/Makefile.patch
|
||||
|
||||
CFLAGS="$SLKCFLAGS" \
|
||||
CXXFLAGS="$SLKCFLAGS" \
|
||||
./configure \
|
||||
--prefix=/usr \
|
||||
|| exit 1
|
||||
--sysconfdir=/etc \
|
||||
--localstatedir=/var \
|
||||
--mandir=/usr/man \
|
||||
--disable-static \
|
||||
--verbose
|
||||
|
||||
make || exit 1
|
||||
make install DESTDIR=$PKG || exit 1
|
||||
make
|
||||
make install DESTDIR=$PKG
|
||||
|
||||
( cd $PKG
|
||||
find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
|
||||
|
@ -52,11 +56,11 @@ make install DESTDIR=$PKG || exit 1
|
|||
|
||||
( cd $PKG/usr/man
|
||||
find . -type f -exec gzip -9 {} \;
|
||||
for i in $(find . -type l) ; do ln -s $(readlink $i).gz $i.gz ; rm $i ; done
|
||||
for i in $(find . -type l) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
|
||||
)
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a $DOCUMENTATION $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
|
||||
mkdir -p $PKG/install
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
PRGNAM="transmission"
|
||||
VERSION="0.6.1"
|
||||
HOMEPAGE="http://transmission.m0k.org/"
|
||||
DOWNLOAD="http://download.m0k.org/transmission/files/Transmission-0.6.1.tar.gz"
|
||||
MD5SUM="1156a88c77ab71782b9261881ea13811"
|
||||
MAINTAINER="Vasilis Papavasileiou"
|
||||
EMAIL="el03020@mail.ntua.gr"
|
||||
VERSION="1.06"
|
||||
HOMEPAGE="http://www.transmissionbt.com/"
|
||||
DOWNLOAD="http://download.m0k.org/transmission/files/transmission-1.06.tar.bz2"
|
||||
MD5SUM="471e4bd40e1464067a3e266ecf3cb724"
|
||||
MAINTAINER="Iskar Enev"
|
||||
EMAIL="iskar.enev[@]gmail.com"
|
||||
APPROVED="rworkman"
|
||||
|
|
Loading…
Reference in a new issue