system/pommed: Removed (Build failure)

undefined reference to `pci_alloc' ...
This commit is contained in:
dsomero 2010-05-21 18:26:17 -04:00 committed by David Somero
parent 7eb4a84a82
commit f14108ab64
9 changed files with 0 additions and 312 deletions

View file

@ -1,8 +0,0 @@
pommed enables the use of the brightness and volume keys on Apple
laptops including the MacBook and MacBook Pro (the only Apple laptops
that Slackware currently runs on) and is likely of little or not use to
others.
This requires libsmbios and confuse.
See README.SLACKWARE for configuration information.

View file

@ -1,20 +0,0 @@
README.SLACKWARE for pommed
This package installs an rc.pommed script that should be called from
rc.local (and optionally rc.local_shutdown) like so:
In rc.local:
# Start pommed
if [ -x /etc/rc.d/rc.pommed ]; then
/etc/rc.d/rc.pommed start
fi
In rc.local_shutdown:
# Stop pommed
if [ -x /etc/rc.d/rc.pommed ]; then
/etc/rc.d/rc.pommed stop
fi
It is also necessary to reload the messagebus service:
/etc/rc.d/rc.messagebus reload

View file

@ -1,33 +0,0 @@
config() {
NEW="$1"
OLD="$(dirname $NEW)/$(basename $NEW .new)"
# If there's no config file by that name, mv it over:
if [ ! -r $OLD ]; then
mv $NEW $OLD
elif [ "$(cat $OLD | md5sum)" = "$(cat $NEW | md5sum)" ]; then # toss the redundant copy
rm $NEW
fi
# Otherwise, we leave the .new copy for the admin to consider...
}
# Keep same perms on rc.pommed.new:
if [ -e etc/rc.d/rc.pommed ]; then
cp -a etc/rc.d/rc.pommed etc/rc.d/rc.pommed.new.incoming
cat etc/rc.d/rc.pommed.new > etc/rc.d/rc.pommed.new.incoming
mv etc/rc.d/rc.pommed.new.incoming etc/rc.d/rc.pommed.new
fi
config etc/rc.d/rc.pommed.new
config etc/dbus-1/system.d/pommed.conf.new
config etc/pommed.conf.new
if [ -x /usr/bin/update-desktop-database ]; then
/usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
fi
if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
if [ -x /usr/bin/gtk-update-icon-cache ]; then
/usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
fi
fi

View file

@ -1,12 +0,0 @@
diff -Nur pommed-1.26.orig/pommed/Makefile pommed-1.26/pommed/Makefile
--- pommed-1.26.orig/pommed/Makefile 2009-03-14 08:13:17.000000000 -0500
+++ pommed-1.26/pommed/Makefile 2009-07-29 11:12:08.162491222 -0500
@@ -53,7 +53,7 @@
CFLAGS += $(LIBPCI_CFLAGS)
LDFLAGS += $(LIBPCI_LIBS)
else
- LIBS = /usr/lib/libpci.a
+ LIBS = /usr/lib64/libpci.a
LDFLAGS += -lz
endif

View file

@ -1,55 +0,0 @@
diff -Nur pommed-1.26.orig/gpomme/Makefile pommed-1.26/gpomme/Makefile
--- pommed-1.26.orig/gpomme/Makefile 2009-03-14 08:13:17.000000000 -0500
+++ pommed-1.26/gpomme/Makefile 2009-07-29 11:13:21.054859107 -0500
@@ -1,4 +1,5 @@
CC = gcc
+OPT ?= -O2
GTK_CFLAGS = $(shell pkg-config --cflags gtk+-2.0)
GTK_LIBS = $(shell pkg-config --libs gtk+-2.0)
@@ -17,7 +18,7 @@
INOTIFY_CFLAGS = $(shell test -e /usr/include/sys/inotify.h || echo -DNO_SYS_INOTIFY_H)
-CFLAGS = -g -O2 -Wall $(DBUS_CFLAGS) $(DBUSGLIB_CFLAGS) $(GTK_CFLAGS) $(CONFUSE_CFLAGS) $(GLADE_CFLAGS) $(INOTIFY_CFLAGS)
+CFLAGS = -g $(OPT) -Wall $(DBUS_CFLAGS) $(DBUSGLIB_CFLAGS) $(GTK_CFLAGS) $(CONFUSE_CFLAGS) $(GLADE_CFLAGS) $(INOTIFY_CFLAGS)
LDFLAGS = -lpthread $(DBUS_LIBS) $(DBUSGLIB_LIBS) $(GTK_LIBS) $(CONFUSE_LIBS) $(GLADE_LIBS)
SOURCES = gpomme.c theme.c conffile.c \
diff -Nur pommed-1.26.orig/pommed/Makefile pommed-1.26/pommed/Makefile
--- pommed-1.26.orig/pommed/Makefile 2009-03-14 08:13:17.000000000 -0500
+++ pommed-1.26/pommed/Makefile 2009-07-29 11:13:34.453703569 -0500
@@ -1,6 +1,7 @@
ARCH ?= $(shell uname -m)
CC = gcc
+OPT ?= -O2
DBUS_CFLAGS = $(shell pkg-config dbus-1 --cflags) -DDBUS_API_SUBJECT_TO_CHANGE
DBUS_LIBS = $(shell pkg-config dbus-1 --libs)
@@ -18,7 +19,7 @@
TIMERFD_CFLAGS = $(shell test -e /usr/include/sys/timerfd.h || echo -DNO_SYS_TIMERFD_H)
-CFLAGS = -g -O2 -Wall $(DBUS_CFLAGS) $(ALSA_CFLAGS) $(AUDIOFILE_CFLAGS) $(CONFUSE_CFLAGS) $(INOTIFY_CFLAGS) $(TIMERFD_CFLAGS)
+CFLAGS = -g $(OPT) -Wall $(DBUS_CFLAGS) $(ALSA_CFLAGS) $(AUDIOFILE_CFLAGS) $(CONFUSE_CFLAGS) $(INOTIFY_CFLAGS) $(TIMERFD_CFLAGS)
LDFLAGS = -pthread -lrt $(DBUS_LIBS) $(ALSA_LIBS) $(AUDIOFILE_LIBS) $(CONFUSE_LIBS)
diff -Nur pommed-1.26.orig/wmpomme/Makefile pommed-1.26/wmpomme/Makefile
--- pommed-1.26.orig/wmpomme/Makefile 2009-03-14 08:13:17.000000000 -0500
+++ pommed-1.26/wmpomme/Makefile 2009-07-29 11:13:46.671562196 -0500
@@ -1,11 +1,12 @@
CC = gcc
+OPT ?= -O2
DBUS_CFLAGS = $(shell pkg-config dbus-1 --cflags) -DDBUS_API_SUBJECT_TO_CHANGE
DBUS_LIBS = $(shell pkg-config dbus-1 --libs)
TIMERFD_CFLAGS = $(shell test -e /usr/include/sys/timerfd.h || echo -DNO_SYS_TIMERFD_H)
-CFLAGS = -g -O2 -Wall $(DBUS_CFLAGS) $(TIMERFD_CFLAGS)
+CFLAGS = -g $(OPT) -Wall $(DBUS_CFLAGS) $(TIMERFD_CFLAGS)
LDFLAGS = -lrt -lXpm -lXext -lX11 $(DBUS_LIBS)
SOURCES = wmgeneral.c wmpomme.c \

View file

@ -1,122 +0,0 @@
#!/bin/sh
# Slackware build script for pommed
# Copyright 2007 Alan Hicks (alan@lizella.net)
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=pommed
VERSION=1.26
ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=${TMP}/package-${PRGNAM}
OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
fi
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
chmod -R u+w,go+r-w,a-s .
# Fix a bad assumption in the pommed Makefile
# If pciutils is rebuilt to include the pkgconfig file, this can be omitted,
# but at the time of this edit (20090729), it's not present in 13.0rc1
sed "s%@LIBDIR@%/usr/lib${LIBDIRSUFFIX}%" \
$CWD/patches/pommed-1.26-link_libpci_a.diff | patch -p1
# Use our CFLAGS instead of assuming -O2 only
patch -p1 < $CWD/patches/pommed-1.26-use_custom_cflags.diff
make OPT="$SLKCFLAGS"
# The Makefile doesn't have an "install" target, so we'll do it manually
# Install pommed (system daemon)
mkdir -p $PKG/usr/sbin $PKG/usr/share/pommed $PKG/etc
cp -a pommed/pommed $PKG/usr/sbin
cp -a pommed/data/* $PKG/usr/share/pommed
cat pommed.conf.mactel > $PKG/etc/pommed.conf.new
# Install gpomme (gtk client)
mkdir -p $PKG/usr/bin $PKG/usr/share/gpomme/themes $PKG/usr/share/applications
cp -a gpomme/gpomme $PKG/usr/bin
cp -a gpomme/themes/* $PKG/usr/share/gpomme/themes
cat gpomme/gpomme.desktop > $PKG/usr/share/applications/gpomme.desktop
mkdir -p $PKG/usr/share/icons/hicolor/scalable/apps
cp -a icons/gpomme.svg $PKG/usr/share/icons/hicolor/scalable/apps
for i in 16 22 24 32 36 48 64 72 96 128 192 ; do
mkdir -p $PKG/usr/share/icons/hicolor/${i}x${i}/apps
cp -a icons/gpomme_${i}x${i}.png \
$PKG/usr/share/icons/hicolor/${i}x${i}/apps/gpomme.png
done
# Install wmpomme (windowmaker client)
mkdir -p $PKG/usr/bin
cp -a wmpomme/wmpomme $PKG/usr/bin
mkdir -p $PKG/usr/share/pixmaps
cat icons/gpomme_192x192.xpm > $PKG/usr/share/pixmaps/gpomme.xpm
# Install dbus config file
mkdir -p $PKG/etc/dbus-1/system.d
cat dbus-policy.conf > $PKG/etc/dbus-1/system.d/pommed.conf.new
# Install init script
mkdir -p $PKG/etc/rc.d
cat $CWD/rc.pommed > $PKG/etc/rc.d/rc.pommed.new
chmod 0755 $PKG/etc/rc.d/rc.pommed.new
# Install manpages
mkdir -p $PKG/usr/man/man1
cat pommed.1 > $PKG/usr/man/man1/pommed.1
gzip -9 $PKG/usr/man/man1/pommed.1
# Install docs
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a AUTHORS COPYING ChangeLog INSTALL README TODO \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/README.SLACKWARE > $PKG/usr/doc/$PRGNAM-$VERSION/README.SLACKWARE
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}

View file

@ -1,10 +0,0 @@
PRGNAM="pommed"
VERSION="1.26"
HOMEPAGE="http://alioth.debian.org/projects/pommed/"
DOWNLOAD="https://alioth.debian.org/frs/download.php/2975/pommed-1.26.tar.gz"
MD5SUM="481d58a99fc0eeefad156e5d329e0a82"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="Alan Hicks"
EMAIL="alan@lizella.net"
APPROVED="rworkman"

View file

@ -1,33 +0,0 @@
#!/bin/sh
# Start/stop/restart the pommed service:
pommed_start() {
/usr/sbin/pommed
}
pommed_stop() {
kill $(cat /var/run/pommed.pid) || killall pommed
rm -f /var/run/pommed.pid
}
pommed_restart() {
pommed_stop
sleep 1
pommed_start
}
case "$1" in
'start')
pommed_start
;;
'stop')
pommed_stop
;;
'restart')
pommed_restart
;;
*)
echo "usage $0 start|stop|restart"
esac

View file

@ -1,19 +0,0 @@
# HOW TO EDIT THIS FILE:
# The "handy ruler" below makes it easier to edit a package description. Line
# up the first '|' above the ':' following the base package name, and the '|'
# on the right side marks the last column you can put a character in. You must
# make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':'.
|-----handy-ruler------------------------------------------------------|
pommed: pommed (handles the hotkeys found on some Apple laptops)
pommed:
pommed: pommed handles the hotkeys found on the Apple MacBook Pro, MacBook,
pommed: and PowerBook laptops and adjusts the LCD backlight, sound volume,
pommed: keyboard backlight, or ejects the CD-ROM drive accordingly.
pommed: pommed also monitors the ambient light sensors to automatically light
pommed: up the keyboard backlight on the MacBook Pro and the latest PowerBook.
pommed:
pommed: Optional support for the Apple Remote control is available.
pommed:
pommed: