system/xtrs: Added to 13.0 repository

This commit is contained in:
Niels Horn 2010-05-13 01:01:19 +02:00 committed by Robby Workman
parent 7603037553
commit efebcd3389
8 changed files with 161 additions and 0 deletions

17
system/xtrs/README Normal file
View file

@ -0,0 +1,17 @@
xtrs: TRS-80 Model I/III/4/4P Emulator for Unix
xtrs is a Radio Shack TRS-80 Model I/III/4/4P emulator for Unix and the X
Window system. It includes lower case, the real time clock, hi-res graphics,
serial port, parallel printer, mouse, cassette, sound and music output
(requires OSS), 5" and 8" floppy disk drives in single and double density,
and even hard disk drives.
To run xtrs, you will need a 'romfile' with the contents of the original ROM
of the model you want to emulate. Since these are copyrighted, they are not
included in this package. However, do not dispair! The xtrs page explains
how to obtain a legal copy of the MODELA/III file that can be used. These
or other ROM images should be copied to the /usr/share/xtrs directory.
A simple xtrs.desktop file is included that will start xtrs with
the default options. Read the included 'xtrs' man-page after installation
for more information and command-line options.

View file

@ -0,0 +1,16 @@
diff -Nur xtrs-4.9d.orig/Makefile.local xtrs-4.9d/Makefile.local
--- xtrs-4.9d.orig/Makefile.local 2009-06-15 18:32:57.000000000 -0500
+++ xtrs-4.9d/Makefile.local 2009-09-26 16:29:19.371490363 -0500
@@ -36,9 +36,9 @@
# time, use these lines (with the appropriate file names). The default file
# name is ignored and can be omitted if the ROM for that model is built in.
-DEFAULT_ROM = -DDEFAULT_ROM='"/usr/local/lib/xtrs/level2rom.hex"' \
- -DDEFAULT_ROM3='"/usr/local/lib/xtrs/romimage.m3"' \
- -DDEFAULT_ROM4P='"/usr/local/lib/xtrs/romimage.m4p"'
+DEFAULT_ROM = -DDEFAULT_ROM='"/usr/share/xtrs/level2rom.hex"' \
+ -DDEFAULT_ROM3='"/usr/share/xtrs/romimage.m3"' \
+ -DDEFAULT_ROM4P='"/usr/share/xtrs/romimage.m4p"'
# If you would like to change where xtrs looks for disk?-? files, edit
# this line. "." of course means the current working directory.

4
system/xtrs/doinst.sh Normal file
View file

@ -0,0 +1,4 @@
if [ -x /usr/bin/update-desktop-database ]; then
/usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
fi

19
system/xtrs/slack-desc Normal file
View file

@ -0,0 +1,19 @@
# HOW TO EDIT THIS FILE:
# The "handy ruler" below makes it easier to edit a package description. Line
# up the first '|' above the ':' following the base package name, and the '|' on
# the right side marks the last column you can put a character in. You must make
# exactly 11 lines for the formatting to be correct. It's also customary to
# leave one space after the ':'.
|-----handy-ruler------------------------------------------------------|
xtrs: xtrs: TRS-80 Model I/III/4/4P Emulator for Unix
xtrs:
xtrs: xtrs is a Radio Shack TRS-80 Model I/III/4/4P emulator for Unix and
xtrs: the X Window system. It includes lower case, the real time clock, hi-
xtrs: res graphics, serial port, parallel printer, mouse, cassette, sound
xtrs: and music output (requires OSS), 5" and 8" floppy disk drives in
xtrs: single and double density, and even hard disk drives.
xtrs:
xtrs: http://www.tim-mann.org/xtrs.html
xtrs:
xtrs:

BIN
system/xtrs/xtrs-ico.png Normal file

Binary file not shown.

After

Width:  |  Height:  |  Size: 362 B

View file

@ -0,0 +1,85 @@
#!/bin/sh
# Slackware build script for xtrs - the X Windows TRS-80 emulator
# Written by Niels Horn - niels.horn@gmail.com
# revision date 2009/09/05
PRGNAM=xtrs
VERSION=4.9d
ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
fi
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
rm -rf $TMP/$PRGNAM-$VERSION
cd $TMP
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
chmod -R u+w,go+r-w,a-s .
# Make /usr/share/xtrs the default rom directory
patch -p1 < $CWD/default_rom_dir.patch
# xtrs does not have a ./configure
make \
DEBUG="$SLKCFLAGS" \
PREFIX=/usr \
MANDIR=/usr/man \
APPDEFAULTS='-DAPPDEFAULTS=\"/etc/X11/app-defaults\"'
mkdir -p $PKG/usr/bin $PKG/usr/man/man1
make BINDIR=$PKG/usr/bin MANDIR=$PKG/usr/man install || exit
# Make a directory for the ROMs (not included), include fakerom.hex & xtrsrom4p.hex
mkdir -p $PKG/usr/share/xtrs
cp -a fakerom.hex xtrsrom4p.hex $PKG/usr/share/xtrs
# Copy icon & desktop file to package
mkdir -p $PKG/usr/share/{applications,pixmaps}
cat $CWD/xtrs.desktop > $PKG/usr/share/applications/xtrs.desktop
cp -a $CWD/xtrs-ico.png $PKG/usr/share/pixmaps
( cd $PKG
find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
xargs strip --strip-unneeded 2> /dev/null || true
find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
xargs strip --strip-unneeded 2> /dev/null
)
( cd $PKG/usr/man
find . -type f -exec gzip -9 {} \;
for i in $(find . -type l) ; do ln -s $(readlink $i).gz $i.gz ; rm $i ; done
)
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a ChangeLog README xtrsrom4p.README $PKG/usr/doc/$PRGNAM-$VERSION
find $PKG/usr/doc/$PRGNAM-$VERSION -type f -exec chmod 644 {} \;
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
/sbin/makepkg -l y -c n $TMP/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}

10
system/xtrs/xtrs.desktop Normal file
View file

@ -0,0 +1,10 @@
[Desktop Entry]
Version=1.0
Type=Application
Name=xtrs
Comment=Emulator for TRS-80
Categories=System;
Exec=xtrs
Icon=xtrs-ico
Terminal=false
StartupNotify=false

10
system/xtrs/xtrs.info Normal file
View file

@ -0,0 +1,10 @@
PRGNAM="xtrs"
VERSION="4.9d"
HOMEPAGE="http://www.tim-mann.org/xtrs.html"
DOWNLOAD="http://www.tim-mann.org/trs80/xtrs-4.9d.tar.gz"
MD5SUM="8bb7cf88a3bc1da890f1f29398120bf3"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="Niels Horn"
EMAIL="niels.horn@gmail.com"
APPROVED="rworkman"