mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-04 20:29:09 +01:00
games/pcsx-df: Removed (Build failure)
This commit is contained in:
parent
3411cde11c
commit
efcd74311c
6 changed files with 0 additions and 177 deletions
|
@ -1,9 +0,0 @@
|
|||
PCSX-df is a forked version of the dead PCSX emulator, with a nicer
|
||||
interface and several improvements to stability and functionality.
|
||||
PCSX-df has a very capable Internal HLE BIOS that can run many games
|
||||
without problems. It is recommended that you use it. However, if you
|
||||
own a real Playstation, you may be able to use your own BIOS image
|
||||
placed under '~/.pcsx/bios'.
|
||||
|
||||
This package conflicts with pcsxr. Both cannot be installed at the same time!
|
||||
|
|
@ -1,3 +0,0 @@
|
|||
if [ -x usr/bin/update-desktop-database ]; then
|
||||
usr/bin/update-desktop-database -q usr/share/applications
|
||||
fi
|
|
@ -1,98 +0,0 @@
|
|||
#!/bin/sh
|
||||
|
||||
# Slackware build script for pcsx-df
|
||||
|
||||
# Copyright 2008 Heinz Wiesinger <pprkut@liwjatan.at>
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use of this script, with or without modification, is
|
||||
# permitted provided that the following conditions are met:
|
||||
#
|
||||
# 1. Redistributions of this script must retain the above copyright
|
||||
# notice, this list of conditions and the following disclaimer.
|
||||
#
|
||||
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
|
||||
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
||||
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
||||
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
||||
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
||||
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
||||
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
||||
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
||||
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
||||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
PRGNAM=pcsx-df
|
||||
VERSION=1.9
|
||||
ARCH=${ARCH:-i486}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
CWD=$(pwd)
|
||||
TMP=${TMP:-/tmp/SBo}
|
||||
PKG=$TMP/package-$PRGNAM
|
||||
OUTPUT=${OUTPUT:-/tmp}
|
||||
|
||||
if [ "$ARCH" = "i486" ]; then
|
||||
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "i686" ]; then
|
||||
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "x86_64" ]; then
|
||||
SLKCFLAGS="-O2 -fPIC"
|
||||
LIBDIRSUFFIX="64"
|
||||
fi
|
||||
|
||||
set -e
|
||||
|
||||
rm -rf $PKG
|
||||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
rm -rf $PRGNAM-$VERSION
|
||||
tar xvzf $CWD/$PRGNAM-$VERSION.tar.gz
|
||||
cd $PRGNAM-$VERSION
|
||||
chown -R root:root .
|
||||
chmod -R u+w,go+r-w,a-s .
|
||||
|
||||
patch -p1 -i $CWD/pcsx.pthread.patch
|
||||
|
||||
for i in dfbinimage dfcdrom dfinput dfiso dfOpenGL dfsound dfxvideo; do
|
||||
sed -i "s|\$(prefix)/lib/|\$(prefix)/lib$LIBDIRSUFFIX/|g" \
|
||||
plugins/$i/Makefile.am
|
||||
done
|
||||
|
||||
chmod +x ./autogen.sh
|
||||
|
||||
./autogen.sh
|
||||
|
||||
CFLAGS="$SLKCFLAGS" \
|
||||
CXXFLAGS="$SLKCFLAGS" \
|
||||
./configure \
|
||||
--prefix=/usr \
|
||||
--libdir=/usr/lib$LIBDIRSUFFIX \
|
||||
--sysconfdir=/etc \
|
||||
--localstatedir=/var \
|
||||
--mandir=/usr/man \
|
||||
--disable-static \
|
||||
--disable-nautilusburn \
|
||||
--build=$ARCH-slackware-linux
|
||||
|
||||
make
|
||||
make install-strip DESTDIR=$PKG
|
||||
|
||||
( cd $PKG/usr/man
|
||||
find . -type f -exec gzip -9 {} \;
|
||||
for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
|
||||
)
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a ABOUT-NLS AUTHORS ChangeLog COPYING INSTALL NEWS README \
|
||||
$PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
|
||||
mkdir -p $PKG/install
|
||||
cat $CWD/slack-desc > $PKG/install/slack-desc
|
||||
|
||||
cd $PKG
|
||||
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
|
|
@ -1,10 +0,0 @@
|
|||
PRGNAM="pcsx-df"
|
||||
VERSION="1.9"
|
||||
HOMEPAGE="http://pcsx-df.sourceforge.net"
|
||||
DOWNLOAD="http://downloads.sourceforge.net/pcsx-df/pcsx-df-1.9.tar.gz"
|
||||
MD5SUM="a7a52b38c3b425c0c7e7949102ab09d1"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
MAINTAINER="ppr:kut"
|
||||
EMAIL="pprkut@liwjatan.at"
|
||||
APPROVED="David Somero"
|
|
@ -1,38 +0,0 @@
|
|||
diff -rup pcsx-df-1.9/configure.ac pcsx-df-1.9.new.clean/configure.ac
|
||||
--- pcsx-df-1.9/configure.ac 2008-01-17 13:11:07.000000000 +0100
|
||||
+++ pcsx-df-1.9.new.clean/configure.ac 2008-07-25 15:55:38.857104605 +0200
|
||||
@@ -23,6 +23,11 @@ AC_DEFINE_UNQUOTED([GETTEXT_PACKAGE], ["
|
||||
PKG_CHECK_MODULES(GLIB2, glib-2.0, [], AC_MSG_ERROR([*** glib2 not found!]))
|
||||
PKG_CHECK_MODULES(GTK2, gtk+-2.0, [], AC_MSG_ERROR([*** libgtk2 not found!]))
|
||||
PKG_CHECK_MODULES(GLADE2, libglade-2.0, [], AC_MSG_ERROR([*** libglade2 not found!]))
|
||||
+
|
||||
+PKG_CHECK_MODULES(GTHREAD, gthread-2.0, [], AC_MSG_ERROR([*** gthread-2.0 not found!]))
|
||||
+AC_SUBST(GTREAD_CFLAGS)
|
||||
+AC_SUBST(GTREAD_LIBS)
|
||||
+
|
||||
AC_ARG_ENABLE(nautilusburn, [ --enable-nautilusburn build dfiso with libnautilusburn (default yes)],
|
||||
[ NAUTILUS_BURN="$enableval" ],[ NAUTILUS_BURN="yes" ])
|
||||
AM_CONDITIONAL(ENABLE_NAUTILUSBURN,test "x$NAUTILUS_BURN" = xyes)
|
||||
diff -rup pcsx-df-1.9/gui/Makefile.am pcsx-df-1.9.new.clean/gui/Makefile.am
|
||||
--- pcsx-df-1.9/gui/Makefile.am 2008-01-12 16:13:30.000000000 +0100
|
||||
+++ pcsx-df-1.9.new.clean/gui/Makefile.am 2008-07-25 15:55:38.917113978 +0200
|
||||
@@ -5,6 +5,8 @@ INCLUDES = -DPACKAGE_DATA_DIR=\"${datadi
|
||||
$(GTK2_CFLAGS) $(GLADE2_CFLAGS) \
|
||||
-I$(top_srcdir)/libpcsxcore -I$(top_srcdir)/include
|
||||
|
||||
+AM_CFLAGS= $(GTRHEAD_CFLAGS) $(GLIB2_CFLAGS) $(GTK2_CFLAGS) $(GLADE2_CFLAGS)
|
||||
+
|
||||
bin_PROGRAMS = pcsx
|
||||
|
||||
pcsx_SOURCES = \
|
||||
@@ -14,6 +16,6 @@ pcsx_SOURCES = \
|
||||
Config.c \
|
||||
Gtk2Gui.c \
|
||||
hdebug.c
|
||||
-
|
||||
-pcsx_LDADD = \
|
||||
- $(GTK2_LIBS) $(GLADE2_LIBS) ../libpcsxcore/libpcsxcore.la
|
||||
+
|
||||
+pcsx_LDADD = $(GTHREAD_LIBS) $(GLIB2_LIBS) $(GTK2_LIBS) \
|
||||
+ $(GLADE2_LIBS) ../libpcsxcore/libpcsxcore.la
|
||||
\ Pas de fin de ligne à la fin du fichier.
|
|
@ -1,19 +0,0 @@
|
|||
# HOW TO EDIT THIS FILE:
|
||||
# The "handy ruler" below makes it easier to edit a package description. Line
|
||||
# up the first '|' above the ':' following the base package name, and the '|'
|
||||
# on the right side marks the last column you can put a character in. You must
|
||||
# make exactly 11 lines for the formatting to be correct. It's also
|
||||
# customary to leave one space after the ':'.
|
||||
|
||||
|-----handy-ruler------------------------------------------------------|
|
||||
pcsx-df: pcsx-df (Playstation Emulator)
|
||||
pcsx-df:
|
||||
pcsx-df: PCSX-df is a forked version of the dead PCSX emulator, with a nicer
|
||||
pcsx-df: interface and several improvements to stability and functionality.
|
||||
pcsx-df: PCSX-df has a very capable Internal HLE BIOS that can run many games
|
||||
pcsx-df: without problems. It is recommended that you use it. However, if you
|
||||
pcsx-df: own a real Playstation, you may be able to use your own BIOS image
|
||||
pcsx-df: placed under '~/.pcsx/bios'.
|
||||
pcsx-df:
|
||||
pcsx-df: Homepage: http://pcsx-df.sourceforge.net
|
||||
pcsx-df:
|
Loading…
Reference in a new issue