mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-21 19:42:24 +01:00
office/zathura: Updated for version 0.3.3.
This commit is contained in:
parent
a969a5388b
commit
ef70875e1f
4 changed files with 30 additions and 16 deletions
|
@ -13,4 +13,5 @@ zathura-cb - Comic book archives (cbz/cbr/cb7/cbt)
|
|||
zathura-djvu - DjVu
|
||||
|
||||
When upgrading zathura, you must rebuild all its plugins
|
||||
against the new version of zathura
|
||||
against the new version of zathura, even if the version numbers
|
||||
are the same.
|
||||
|
|
|
@ -1,15 +1,15 @@
|
|||
diff -Naur zathura-0.2.7/zathura.c zathura-0.2.7.patched/zathura.c
|
||||
--- zathura-0.2.7/zathura.c 2014-02-17 11:16:57.000000000 -0500
|
||||
+++ zathura-0.2.7.patched/zathura.c 2014-08-22 02:39:14.000000000 -0400
|
||||
diff -Naur zathura-0.3.3/zathura/zathura.c zathura-0.3.3.patched/zathura/zathura.c
|
||||
--- zathura-0.3.3/zathura/zathura.c 2015-04-13 16:54:30.000000000 -0400
|
||||
+++ zathura-0.3.3.patched/zathura/zathura.c 2015-05-11 14:45:31.000000000 -0400
|
||||
@@ -3,6 +3,7 @@
|
||||
#define _BSD_SOURCE
|
||||
#define _DEFAULT_SOURCE
|
||||
#define _XOPEN_SOURCE 700
|
||||
|
||||
+#include <dlfcn.h>
|
||||
#include <errno.h>
|
||||
#include <stdlib.h>
|
||||
#include <unistd.h>
|
||||
@@ -101,6 +102,7 @@
|
||||
@@ -116,6 +117,7 @@
|
||||
}
|
||||
|
||||
/* load plugins */
|
||||
|
|
|
@ -22,6 +22,15 @@
|
|||
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
||||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
# 20150511 bkw:
|
||||
# - Version bump 0.3.3. The poppler plugin is still on 0.2.5.
|
||||
# - Make the poppler plugin's pdf.so a symlink. Will do the same
|
||||
# for zathura-pdf-mupdf, to allow switching between the two without
|
||||
# reinstalling packages. This wouldn't have worked with older versions,
|
||||
# due to changes in glib's g_file_test() between glib 1.x and 2.x.
|
||||
# - Upstream started using -fdiagnostics-color=always, which is only
|
||||
# supported in newer gcc versions. Get rid of it.
|
||||
|
||||
# Updated 20130617 by B. Watson <yalhcru@gmail.com>:
|
||||
# - Updated for v0.2.3
|
||||
|
||||
|
@ -37,7 +46,7 @@
|
|||
# - fix homepage URL
|
||||
|
||||
PRGNAM=zathura
|
||||
VERSION=${VERSION:-0.2.7}
|
||||
VERSION=${VERSION:-0.3.3}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
|
@ -74,8 +83,7 @@ set -eu
|
|||
# plugins. This build includes the default PDF plugin, without which zathura
|
||||
# is completely useless.
|
||||
PLUGIN=$PRGNAM-pdf-poppler
|
||||
#PLUGINVER=${PLUGINVER:-$VERSION}
|
||||
PLUGINVER=${PLUGINVER-0.2.5}
|
||||
PLUGINVER=${PLUGINVER:-0.2.5}
|
||||
|
||||
rm -rf $PKG
|
||||
mkdir -p $TMP $PKG $OUTPUT
|
||||
|
@ -119,6 +127,7 @@ find -L . \
|
|||
patch -p1 < $CWD/dlopen_hack.diff
|
||||
|
||||
sed -i "s/-pedantic/$SLKCFLAGS/" config.mk
|
||||
sed -i '/-fdiagnostics-color/d' colors.mk
|
||||
|
||||
make LIBDIR=/usr/lib$LIBDIRSUFFIX
|
||||
make install LIBDIR=/usr/lib$LIBDIRSUFFIX MANPREFIX=/usr/man DESTDIR=$PKG RSTTOMAN=""
|
||||
|
@ -132,7 +141,7 @@ cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
|||
cd $TMP
|
||||
|
||||
# Hack, lets #include <zathura/document.h> in pdf.h work with an uninstalled
|
||||
# copy of zathura by saying "-I.."
|
||||
# copy of zathura by saying "-I../zathura"
|
||||
rm -f $PRGNAM
|
||||
ln -s $PRGNAM-$VERSION $PRGNAM
|
||||
|
||||
|
@ -148,14 +157,18 @@ find -L . \
|
|||
|
||||
# ZATHURA_VERSION_CHECK=0 is required because zathura.pc isn't installed.
|
||||
|
||||
PLUGDIR=/usr/lib$LIBDIRSUFFIX/$PRGNAM
|
||||
sed -i "s/-fPIC/$SLKCFLAGS/" config.mk
|
||||
make install \
|
||||
ZATHURA_INC=-I.. \
|
||||
PLUGINDIR=/usr/lib$LIBDIRSUFFIX/$PRGNAM \
|
||||
VERBOSE=1 \
|
||||
ZATHURA_INC=-I../zathura \
|
||||
PLUGINDIR=$PLUGDIR/pdf-poppler \
|
||||
DESTDIR=$PKG \
|
||||
ZATHURA_GTK_VERSION=3 \
|
||||
ZATHURA_VERSION_CHECK=0
|
||||
strip $PKG/usr/lib$LIBDIRSUFFIX/$PRGNAM/*.so
|
||||
strip $PKG/$PLUGDIR/pdf-poppler/*.so
|
||||
|
||||
ln -s pdf-poppler/pdf.so $PKG/$PLUGDIR/pdf.so
|
||||
|
||||
# icon converted from https://pwmt.org/img/fav.ico
|
||||
mkdir -p $PKG/usr/share/pixmaps
|
||||
|
|
|
@ -1,10 +1,10 @@
|
|||
PRGNAM="zathura"
|
||||
VERSION="0.2.7"
|
||||
VERSION="0.3.3"
|
||||
HOMEPAGE="http://www.pwmt.org/projects/zathura"
|
||||
DOWNLOAD="http://www.pwmt.org/projects/zathura/download/zathura-0.2.7.tar.gz \
|
||||
DOWNLOAD="http://www.pwmt.org/projects/zathura/download/zathura-0.3.3.tar.gz \
|
||||
http://www.pwmt.org/projects/zathura-pdf-poppler/download/zathura-pdf-poppler-0.2.5.tar.gz"
|
||||
MD5SUM="53124af80e974283a6678319a62e6666 \
|
||||
e314b8b136e71aa4925a864141f12d15"
|
||||
d360252210ce51a29e8d341b1b72a7cc"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES="girara"
|
||||
|
|
Loading…
Reference in a new issue