mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-21 19:42:24 +01:00
office/LibreOffice: Updated for version 24.2.1.2
Signed-off-by: Christoph Willing <chris.willing@linux.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
ba2116183b
commit
ee23de2492
3 changed files with 41 additions and 11 deletions
|
@ -4,7 +4,7 @@
|
|||
|
||||
# Slackware build script for LibreOffice
|
||||
|
||||
# Copyright 2015-2023 Christoph Willing Brisbane, Australia
|
||||
# Copyright 2015-2024 Christoph Willing Sydney, Australia
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use of this script, with or without modification, is
|
||||
|
@ -28,9 +28,9 @@ cd $(dirname $0) ; CWD=$(pwd)
|
|||
|
||||
PRGNAM=LibreOffice
|
||||
SRCNAM=libreoffice
|
||||
VERSION=${VERSION:-7.6.4.1}
|
||||
VERSION=${VERSION:-24.2.1.2}
|
||||
SHORT_VERSION=${VERSION%.*.*}
|
||||
BUILD=${BUILD:-2}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
PKGTYPE=${PKGTYPE:-tgz}
|
||||
|
||||
|
@ -69,6 +69,18 @@ else
|
|||
LIBDIRSUFFIX=""
|
||||
fi
|
||||
|
||||
if [ -x /usr/bin/gcc-11.* ];
|
||||
then
|
||||
echo Slackware-15.0
|
||||
export CC=/usr/bin/clang
|
||||
export CXX=/usr/bin/clang++
|
||||
CXXCLANGFLAGS="-Wno-c++11-narrowing"
|
||||
else
|
||||
echo Slackware-15.0++
|
||||
export CC=/usr/bin/gcc
|
||||
export CXX=/usr/bin/g++
|
||||
fi
|
||||
|
||||
set -e
|
||||
|
||||
rm -rf $PKG
|
||||
|
@ -203,7 +215,8 @@ fi
|
|||
|
||||
./configure \
|
||||
CFLAGS="$SLKCFLAGS" \
|
||||
CXXFLAGS="$SLKCFLAGS" \
|
||||
CXXFLAGS="$SLKCFLAGS $CXXCLANGFLAGS" \
|
||||
LDFLAGS="-lz" \
|
||||
NSS_CFLAGS="$(pkg-config --cflags-only-I mozilla-nss)"\
|
||||
--prefix=/usr \
|
||||
--mandir=/usr/man \
|
||||
|
@ -243,7 +256,6 @@ fi
|
|||
--with-system-epoxy \
|
||||
--with-system-expat \
|
||||
--with-system-hunspell \
|
||||
--with-system-icu \
|
||||
--with-system-jpeg \
|
||||
--with-system-lcms2 \
|
||||
--with-system-libodfgen \
|
||||
|
@ -306,6 +318,7 @@ if [ "$HAVE_SRCS_TARBALL" = "0" ]; then
|
|||
fi
|
||||
|
||||
patch -p0 < $CWD/no-check-if-root.diff
|
||||
patch -p0 < $CWD/narrowing_0f5dfae.diff
|
||||
|
||||
# GCC10 requirements (Tx alienBOB)
|
||||
sed -i external/libebook/ExternalProject_libebook.mk \
|
||||
|
|
|
@ -1,12 +1,12 @@
|
|||
PRGNAM="LibreOffice"
|
||||
VERSION="7.6.4.1"
|
||||
VERSION="24.2.1.2"
|
||||
HOMEPAGE="https://www.libreoffice.org"
|
||||
DOWNLOAD="https://download.documentfoundation.org/libreoffice/src/7.6.4/libreoffice-7.6.4.1.tar.xz \
|
||||
https://sourceforge.net/projects/slackbuildsdirectlinks/files/LibreOffice/libreoffice-7.6.4.1-srcs.tar.xz"
|
||||
MD5SUM="51cb8339342bf6d95b07c72b6106cb00 \
|
||||
94ac9be99bfb45e04fc689533f9f5b23"
|
||||
DOWNLOAD="https://download.documentfoundation.org/libreoffice/src/24.2.1/libreoffice-24.2.1.2.tar.xz \
|
||||
https://sourceforge.net/projects/slackbuildsdirectlinks/files/LibreOffice/libreoffice-24.2.1.2-srcs.tar.xz"
|
||||
MD5SUM="acaa6d8c1b7a11bafd8415961763e342 \
|
||||
132fad4355fa02abbf7dfe56756ab05a"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES="zulu-openjdk11 apache-ant perl-Archive-Zip liblangtag"
|
||||
REQUIRES="zulu-openjdk17 apache-ant perl-Archive-Zip libcdr libfreehand liblangtag libmspub libzmf"
|
||||
MAINTAINER="Christoph Willing"
|
||||
EMAIL="chris.willing@linux.com"
|
||||
|
|
17
office/LibreOffice/narrowing_0f5dfae.diff
Normal file
17
office/LibreOffice/narrowing_0f5dfae.diff
Normal file
|
@ -0,0 +1,17 @@
|
|||
--- sal/osl/unx/file.cxx.orig 2024-02-26 01:15:17.000000000 +1000
|
||||
+++ sal/osl/unx/file.cxx 2024-03-08 21:40:36.345000000 +1000
|
||||
@@ -64,6 +64,14 @@
|
||||
#include <vector>
|
||||
#endif
|
||||
|
||||
+#ifdef LINUX
|
||||
+#include <sys/vfs.h>
|
||||
+// As documented by the kernel
|
||||
+#define SMB_SUPER_MAGIC static_cast<__fsword_t>(0x517B)
|
||||
+#define CIFS_SUPER_MAGIC static_cast<__fsword_t>(0xFF534D42)
|
||||
+#define SMB2_SUPER_MAGIC static_cast<__fsword_t>(0xFE534D42)
|
||||
+#endif
|
||||
+
|
||||
namespace {
|
||||
|
||||
enum class State
|
Loading…
Reference in a new issue