mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-20 19:41:34 +01:00
libraries/openjpeg: Added patch from upstream.
Signed-off-by: Niels Horn <niels.horn@slackbuilds.org>
This commit is contained in:
parent
a8362d26b2
commit
ed6ac81f7e
4 changed files with 21 additions and 4 deletions
|
@ -24,7 +24,7 @@
|
|||
|
||||
PRGNAM=openjpeg
|
||||
VERSION=1.4
|
||||
BUILD=${BUILD:-2}
|
||||
BUILD=${BUILD:-3}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
|
@ -70,6 +70,9 @@ chmod -R u+w,go+r-w,a-s .
|
|||
# Fix header symlink paths (like upstream svn revision 725)
|
||||
patch -p1 -i $CWD/openjpeg_fix_header_symlinks.patch
|
||||
|
||||
# Fix unresolved symbols to libm (like upstream svn revision 729)
|
||||
patch -p0 -d libopenjpeg -i $CWD/openjpeg_link_libm.patch
|
||||
|
||||
mkdir -p build
|
||||
cd build
|
||||
cmake \
|
||||
|
@ -85,7 +88,7 @@ cd build
|
|||
-DBUILD_MJ2:BOOL=ON \
|
||||
-DBUILD_INDEXER_JPIP:BOOL=ON \
|
||||
..
|
||||
make
|
||||
make VERBOSE=1
|
||||
make install DESTDIR=$PKG
|
||||
cd -
|
||||
|
||||
|
|
|
@ -7,4 +7,4 @@ DOWNLOAD_x86_64=""
|
|||
MD5SUM_x86_64=""
|
||||
MAINTAINER="Heinz Wiesinger"
|
||||
EMAIL="pprkut@liwjatan.at"
|
||||
APPROVED="Michiel,rworkman"
|
||||
APPROVED="Niels Horn"
|
||||
|
|
14
libraries/openjpeg/openjpeg_link_libm.patch
Normal file
14
libraries/openjpeg/openjpeg_link_libm.patch
Normal file
|
@ -0,0 +1,14 @@
|
|||
Index: CMakeLists.txt
|
||||
===================================================================
|
||||
--- CMakeLists.txt (revision 728)
|
||||
+++ CMakeLists.txt (revision 729)
|
||||
@@ -30,6 +30,9 @@
|
||||
ENDIF(BUILD_SHARED_LIBS)
|
||||
ENDIF(WIN32)
|
||||
ADD_LIBRARY(${OPENJPEG_LIBRARY_NAME} ${OPENJPEG_SRCS})
|
||||
+IF(UNIX)
|
||||
+ TARGET_LINK_LIBRARIES(${OPENJPEG_LIBRARY_NAME} m)
|
||||
+ENDIF(UNIX)
|
||||
SET_TARGET_PROPERTIES(${OPENJPEG_LIBRARY_NAME} PROPERTIES ${OPENJPEG_LIBRARY_PROPERTIES})
|
||||
|
||||
# Install library
|
|
@ -5,7 +5,7 @@
|
|||
# make exactly 11 lines for the formatting to be correct. It's also
|
||||
# customary to leave one space after the ':'.
|
||||
|
||||
|-----handy-ruler------------------------------------------------|
|
||||
|-----handy-ruler------------------------------------------------------|
|
||||
openjpeg: openjpeg (JPEG2000 Codec)
|
||||
openjpeg:
|
||||
openjpeg: The OpenJPEG library is an open-source JPEG 2000 codec.
|
||||
|
|
Loading…
Reference in a new issue