mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-20 19:41:34 +01:00
libraries/lablgtk: Patched to allow building with gtksourceview.
This commit is contained in:
parent
5ffcce15a6
commit
ece0c60acb
2 changed files with 67 additions and 0 deletions
64
libraries/lablgtk/lablgtk-2.14.0-sourceview2.patch
Normal file
64
libraries/lablgtk/lablgtk-2.14.0-sourceview2.patch
Normal file
|
@ -0,0 +1,64 @@
|
|||
--- src/gSourceView2.mli (wersja 1491)
|
||||
+++ src/gSourceView2.mli (wersja 1494)
|
||||
@@ -251,7 +251,7 @@
|
||||
|
||||
val iter_forward_search :
|
||||
GText.iter ->
|
||||
- SourceViewEnums.source_search_flag list ->
|
||||
+ SourceView2Enums.source_search_flag list ->
|
||||
start:< as_iter : Gtk.text_iter; .. > ->
|
||||
stop:< as_iter : Gtk.text_iter; .. > ->
|
||||
?limit:< as_iter : Gtk.text_iter; .. > ->
|
||||
@@ -259,8 +259,8 @@
|
||||
|
||||
val iter_backward_search :
|
||||
GText.iter ->
|
||||
- SourceViewEnums.source_search_flag list ->
|
||||
+ SourceView2Enums.source_search_flag list ->
|
||||
start:< as_iter : Gtk.text_iter; .. > ->
|
||||
stop:< as_iter : Gtk.text_iter; .. > ->
|
||||
?limit:< as_iter : Gtk.text_iter; .. > ->
|
||||
- string -> (GText.iter * GText.iter) option
|
||||
\ No newline at end of file
|
||||
+ string -> (GText.iter * GText.iter) option
|
||||
--- src/Makefile (wersja 1491)
|
||||
+++ src/Makefile (wersja 1494)
|
||||
@@ -337,7 +337,7 @@
|
||||
cd "$(INSTALLDIR)" && $(RANLIB) $(CLIBS)
|
||||
cp varcc$(XE) propcc$(XE) "$(INSTALLDIR)"
|
||||
if test $(THREADS_LIB) != no; \
|
||||
- then cp $(ALLTHOBJS:.cmo=.cmi) $(INSTALLDIR); \
|
||||
+ then cp $(ALLTHOBJS:.cmo=.cmi) "$(INSTALLDIR)"; \
|
||||
fi
|
||||
if test $(THREADS_LIB) = vm || test $(HAS_DLL_SUPPORT) != yes; \
|
||||
then cp lablgtktop$(XE) "$(INSTALLDIR)"; \
|
||||
--- src/ml_gtktree.c (wersja 1491)
|
||||
+++ src/ml_gtktree.c (wersja 1494)
|
||||
@@ -684,6 +684,7 @@
|
||||
ML_2 (gtk_tree_view_set_tooltip_column, GtkTreeView_val, Int_val, Unit)
|
||||
#else
|
||||
Unsupported_212 (gtk_tree_view_set_tooltip_cell)
|
||||
+Unsupported_212 (gtk_tree_view_set_tooltip_cell_bc)
|
||||
Unsupported_212 (gtk_tree_view_set_tooltip_row)
|
||||
Unsupported_212 (gtk_tree_view_get_tooltip_context)
|
||||
Unsupported_212 (gtk_tree_view_get_tooltip_column)
|
||||
--- src/gtkSourceView2.ml (wersja 1491)
|
||||
+++ src/gtkSourceView2.ml (wersja 1494)
|
||||
@@ -189,13 +189,13 @@
|
||||
module SourceViewMisc =
|
||||
struct
|
||||
external iter_backward_search:
|
||||
- Gtk.text_iter -> string -> SourceViewEnums.source_search_flag list ->
|
||||
+ Gtk.text_iter -> string -> SourceView2Enums.source_search_flag list ->
|
||||
start: Gtk.text_iter -> stop: Gtk.text_iter -> Gtk.text_iter option ->
|
||||
(Gtk.text_iter * Gtk.text_iter) option =
|
||||
"ml_gtk_source_iter_backward_search_bc" "ml_gtk_source_iter_backward_search"
|
||||
external iter_forward_search:
|
||||
- Gtk.text_iter -> string -> SourceViewEnums.source_search_flag list ->
|
||||
+ Gtk.text_iter -> string -> SourceView2Enums.source_search_flag list ->
|
||||
start: Gtk.text_iter -> stop: Gtk.text_iter -> Gtk.text_iter option ->
|
||||
(Gtk.text_iter * Gtk.text_iter) option =
|
||||
"ml_gtk_source_iter_forward_search_bc" "ml_gtk_source_iter_forward_search"
|
||||
-end
|
||||
\ No newline at end of file
|
||||
+end
|
|
@ -67,6 +67,9 @@ cd $PRGNAM-$VERSION
|
|||
chown -R root:root .
|
||||
chmod -R u+w,go+r-w,a-s .
|
||||
|
||||
# Patch to allow building with gtksourceview.
|
||||
patch -p0 < $CWD/lablgtk-2.14.0-sourceview2.patch
|
||||
|
||||
./configure \
|
||||
--prefix=/usr \
|
||||
--libdir=/usr/lib${LIBDIRSUFFIX} \
|
||||
|
|
Loading…
Reference in a new issue