mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-16 19:50:19 +01:00
libraries/libixion: Fix build with gcc in 14.2 and current.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
0cabe4fcf7
commit
ecb0795b93
2 changed files with 33 additions and 1 deletions
24
libraries/libixion/fmt.patch
Normal file
24
libraries/libixion/fmt.patch
Normal file
|
@ -0,0 +1,24 @@
|
|||
From 0891528c3ebbf59b0634d01b57499183bac1974b Mon Sep 17 00:00:00 2001
|
||||
From: orbea <orbea@riseup.net>
|
||||
Date: Mon, 23 Sep 2019 12:09:37 -0700
|
||||
Subject: [PATCH] Fix build with gcc and an external fmt.
|
||||
|
||||
---
|
||||
src/libixion/Makefile.am | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/src/libixion/Makefile.am b/src/libixion/Makefile.am
|
||||
index 1121e5f0..bb310b3f 100644
|
||||
--- a/src/libixion/Makefile.am
|
||||
+++ b/src/libixion/Makefile.am
|
||||
@@ -3,6 +3,7 @@ AM_CPPFLAGS = \
|
||||
-I$(top_srcdir)/include \
|
||||
-I$(top_srcdir)/src/include \
|
||||
-DIXION_BUILD \
|
||||
+ -DFMT_HEADER_ONLY \
|
||||
$(MDDS_CFLAGS) \
|
||||
$(SPDLOG_CFLAGS) \
|
||||
$(BOOST_CPPFLAGS)
|
||||
--
|
||||
2.22.0
|
||||
|
|
@ -24,7 +24,7 @@
|
|||
|
||||
PRGNAM=libixion
|
||||
VERSION=${VERSION:-0.15.0}
|
||||
BUILD=${BUILD:-1}
|
||||
BUILD=${BUILD:-2}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
|
@ -71,8 +71,16 @@ find -L . \
|
|||
|
||||
# Fix build with clang.
|
||||
# https://gitlab.com/ixion/ixion/merge_requests/9
|
||||
# https://gitlab.com/ixion/ixion/commit/a8fe2c542b16ee30723ab3d7f3b643ee479e9723
|
||||
sed -i 's/nullptr_t/std::nullptr_t/' include/ixion/model_context.hpp
|
||||
|
||||
# Fix build with gcc and an external fmt.
|
||||
# https://gitlab.com/ixion/ixion/merge_requests/10
|
||||
# https://gitlab.com/ixion/ixion/commit/0891528c3ebbf59b0634d01b57499183bac1974b
|
||||
patch -p1 < $CWD/fmt.patch
|
||||
|
||||
autoreconf -fi
|
||||
|
||||
CFLAGS="$SLKCFLAGS" \
|
||||
CXXFLAGS="$SLKCFLAGS" \
|
||||
./configure \
|
||||
|
|
Loading…
Reference in a new issue