system/isomaster: Updated for version 1.3.7

This commit is contained in:
Erik Hanson 2010-05-13 00:40:42 +02:00 committed by Michiel van Wessem
parent 595d80cd44
commit eb7d11a860
3 changed files with 43 additions and 29 deletions

View file

@ -1,18 +0,0 @@
--- Makefile 2007-03-18 12:41:13.000000000 -0500
+++ Makefile.new 2007-03-25 23:06:35.000000000 -0500
@@ -1,5 +1,5 @@
# Other paths are relative to this.
-PREFIX ?= /usr/local
+PREFIX ?= /usr
# Where to install the executable.
BINPATH ?= $(PREFIX)/bin
@@ -14,7 +14,7 @@
export LOCALEDIR ?= $(PREFIX)/share/locale
# Where to install the man page.
-MYMANPATH ?= $(PREFIX)/share/man/man1
+MYMANPATH ?= $(PREFIX)/man/man1
# Where to install the .desktop file
DESKTOPPATH ?= $(PREFIX)/share/applications

View file

@ -1,10 +1,29 @@
#!/bin/sh
#
# Slackware build script for ISO Master
# Written by Erik Hanson erik@slackbuilds.org
#
# Copyright 2009 Erik W. Hanson, Minneapolis, MN, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=isomaster
VERSION=1.3.5
VERSION=1.3.7
ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@ -18,6 +37,8 @@ if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
fi
set -eu
@ -32,9 +53,18 @@ chown -R root:root .
chmod -R u+w,go+r-w,a-s .
# No autotools, do manually.
patch -p0 < $CWD/Makefile.patch
CFLAGS="$SLKCFLAGS" make
make install DESTDIR=$PKG
CFLAGS="$SLKCFLAGS"
make \
PREFIX=/usr \
MYMANPATH=/usr/man/man1 \
MYDOCPATH=/usr/doc/$PRGNAM-$VERSION/bkisofs
make install \
PREFIX=/usr \
MYMANPATH=/usr/man/man1 \
MYDOCPATH=/usr/doc/$PRGNAM-$VERSION/bkisofs \
DESTDIR=$PKG
strip --strip-unneeded $PKG/usr/bin/*
gzip -9 $PKG/usr/man/man?/*
@ -49,4 +79,4 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}

View file

@ -1,8 +1,10 @@
PRGNAM="isomaster"
VERSION="1.3.5"
VERSION="1.3.7"
HOMEPAGE="http://littlesvr.ca/isomaster/index.php"
DOWNLOAD="http://littlesvr.ca/isomaster/releases/isomaster-1.3.5.tar.bz2"
MD5SUM="ceec3c0034d443f4d514558256038dcd"
DOWNLOAD="http://littlesvr.ca/isomaster/releases/isomaster-1.3.7.tar.bz2"
MD5SUM="663f2d1a72e2e5f9fdaa30ad585e10f0"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="Erik Hanson"
EMAIL="erik@slackbuilds.org"
APPROVED="dsomero"
APPROVED="michiel"