development/gaphor: Updated for version 0.17.2.

Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
Mikko Värri 2014-03-06 06:58:55 +07:00 committed by Willy Sudiarto Raharjo
parent 417775d944
commit e8fc12db7e
3 changed files with 5 additions and 27 deletions

View file

@ -1,19 +0,0 @@
--- gaphor/services/componentregistry.py.orig 2012-08-08 13:57:32.000000000 +0300
+++ gaphor/services/componentregistry.py 2012-08-08 13:57:57.000000000 +0300
@@ -7,6 +7,7 @@
"""
from zope import interface, component
+from zope.component import registry
from gaphor.core import inject
from gaphor.interfaces import IService, IEventFilter
@@ -27,7 +28,7 @@
pass
def init(self, app):
- self._components = component.registry.Components(
+ self._components = registry.Components(
name='component_registry',
bases=(component.getGlobalSiteManager(),))

View file

@ -2,7 +2,7 @@
# Slackware build script for gaphor
# Copyright 2012 Mikko Värri, Finland
# Copyright 2014 Mikko Värri, Finland
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=gaphor
VERSION=${VERSION:-0.17.1}
VERSION=${VERSION:-0.17.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@ -55,9 +55,6 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
# A patch from upstream git
patch -p0 <$CWD/fix_zope_component_registry.patch
python setup.py install --root=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION

View file

@ -1,8 +1,8 @@
PRGNAM="gaphor"
VERSION="0.17.1"
VERSION="0.17.2"
HOMEPAGE="http://pypi.python.org/pypi/gaphor"
DOWNLOAD="http://pypi.python.org/packages/source/g/gaphor/gaphor-0.17.1.tar.gz"
MD5SUM="cf7b6e1f752913f19a69c7addcfe00d5"
DOWNLOAD="http://pypi.python.org/packages/source/g/gaphor/gaphor-0.17.2.tar.gz"
MD5SUM="f42e27a082a0890baf626dd70e17ca95"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="etk.docking zope.component gaphas"