mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-21 19:42:24 +01:00
system/kvm: Removed (deprecated by upstream - use qemu-kvm)
http://www.linux-kvm.org/page/Downloads states: qemu-kvm is the stable branch of kvm, it's based off of qemu's point releases with the kvm extras on top; kvm-NN releases were previously known as the development releases, but are deprecated today and should not be used. Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
This commit is contained in:
parent
5cb5fb54da
commit
e8dd6a9494
8 changed files with 0 additions and 281 deletions
|
@ -1,12 +0,0 @@
|
|||
diff -Nur kvm-88.orig/kvm/kernel/external-module-compat-comm.h kvm-88/kvm/kernel/external-module-compat-comm.h
|
||||
--- kvm-88.orig/kvm/kernel/external-module-compat-comm.h 2009-07-17 20:47:08.000000000 -0300
|
||||
+++ kvm-88/kvm/kernel/external-module-compat-comm.h 2009-07-17 20:55:21.000000000 -0300
|
||||
@@ -845,7 +845,7 @@
|
||||
|
||||
#include <linux/tracepoint.h>
|
||||
|
||||
-#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,30)
|
||||
+#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,31)
|
||||
|
||||
struct tracepoint;
|
||||
|
|
@ -1,24 +0,0 @@
|
|||
KVM (Kernel-based Virtual Machine) is a full virtualization solution
|
||||
for Linux on x86 hardware containing virtualization extensions (Intel VT
|
||||
or AMD-V). It consists of a loadable kernel module, kvm.ko, that provides
|
||||
the core virtualization infrastructure and a processor specific module,
|
||||
kvm-intel.ko or kvm-amd.ko. KVM also requires a modified QEMU although
|
||||
work is underway to get the required changes upstream.
|
||||
|
||||
Using KVM, one can run multiple virtual machines running unmodified Linux
|
||||
or Windows images. Each virtual machine has private virtualized hardware:
|
||||
a network card, disk, graphics adapter, etc.
|
||||
|
||||
If you'd like to build this for a kernel other than the one you're currently
|
||||
running, you can do something like this:
|
||||
KERNELVERSION=2.6.27.15 ./kvm.SlackBuild
|
||||
|
||||
This script requires a 'kvm' group to exist before running. The recommended
|
||||
GID is 221. You can create it like this: groupadd -g 221 kvm
|
||||
|
||||
After installation, add user to kvm group and re-login. Don't forget to load
|
||||
kernel module kvm-intel (or kvm-amd if you use AMD processors).
|
||||
|
||||
NOTE: if 2.6.30.* or 2.6.31.* kernels are used uncomment appropriate string
|
||||
in slackbild.
|
||||
|
|
@ -1,4 +0,0 @@
|
|||
# Re-generate modules.dep and map files.
|
||||
if [ -x sbin/depmod ]; then
|
||||
chroot . /sbin/depmod -a @KERNEL@ 1> /dev/null 2> /dev/null
|
||||
fi
|
|
@ -1,15 +0,0 @@
|
|||
diff -Nur kvm-88.orig/kvm/kernel/Makefile kvm-88/kvm/kernel/Makefile
|
||||
--- kvm-88.orig/kvm/kernel/Makefile 2009-07-12 08:19:45.000000000 -0500
|
||||
+++ kvm-88/kvm/kernel/Makefile 2009-10-05 16:11:50.668418494 -0500
|
||||
@@ -49,11 +49,6 @@
|
||||
install:
|
||||
mkdir -p $(DESTDIR)/$(INSTALLDIR)
|
||||
cp $(ARCH_DIR)/*.ko $(DESTDIR)/$(INSTALLDIR)
|
||||
- for i in $(ORIGMODDIR)/drivers/kvm/*.ko \
|
||||
- $(ORIGMODDIR)/arch/$(ARCH_DIR)/kvm/*.ko; do \
|
||||
- if [ -f "$$i" ]; then mv "$$i" "$$i.orig"; fi; \
|
||||
- done
|
||||
- /sbin/depmod -a $(DEPMOD_VERSION)
|
||||
|
||||
tmpspec = .tmp.kvm-kmod.spec
|
||||
|
|
@ -1,152 +0,0 @@
|
|||
#!/bin/sh
|
||||
|
||||
# Slackware build script for KVM
|
||||
|
||||
# Copyright 2008-2009 Murat D. Kadirov <banderols@gmail.com>
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use of this script, with or without modification, is
|
||||
# permitted provided that the following conditions are met:
|
||||
#
|
||||
# 1. Redistributions of this script must retain the above copyright
|
||||
# notice, this list of conditions and the following disclaimer.
|
||||
#
|
||||
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
|
||||
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
||||
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
||||
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
||||
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
||||
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
||||
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
||||
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
||||
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
||||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
PRGNAM=kvm
|
||||
VERSION=${VERSION:-88}
|
||||
BUILD=${BUILD:-2}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
# Automatically determine the architecture we're building on:
|
||||
if [ -z "$ARCH" ]; then
|
||||
case "$( uname -m )" in
|
||||
i?86) ARCH=i486 ;;
|
||||
arm*) ARCH=arm ;;
|
||||
# Unless $ARCH is already set, use uname -m for all other archs:
|
||||
*) ARCH=$( uname -m ) ;;
|
||||
esac
|
||||
fi
|
||||
|
||||
CWD=$(pwd)
|
||||
TMP=${TMP:-/tmp/SBo}
|
||||
PKG=$TMP/package-$PRGNAM
|
||||
OUTPUT=${OUTPUT:-/tmp}
|
||||
|
||||
KERNEL=${KERNEL:-$(uname -r)}
|
||||
PKG_VERS=${VERSION}_$(echo $KERNEL | tr - _)
|
||||
|
||||
# The script is set to build all possible target CPU emulators by default.
|
||||
# Modify the BUILD ARCH line below if you DO NOT need to emulate specific
|
||||
# target CPUs. BUILD_ARCH="x86_64" should work fine for most 32-bit or 64-bit
|
||||
# emulation on PCs (Linux guests, BSD guests, Windows guests)
|
||||
BUILD_ARCH="i386 x86_64 arm cris m68k microblaze mips mipsel mips64el ppc ppcemb ppc64 sh4 sh4eb sparc sparc64"
|
||||
|
||||
export PATH=$PATH:/usr/share/texmf/bin
|
||||
|
||||
if [ "$ARCH" = "i486" ]; then
|
||||
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
|
||||
elif [ "$ARCH" = "i686" ]; then
|
||||
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
|
||||
elif [ "$ARCH" = "x86_64" ]; then
|
||||
SLKCFLAGS="-O2 -fPIC"
|
||||
fi
|
||||
|
||||
# Bail if group isn't valid on your system
|
||||
# gid=221 is suggested to avoid conflicts with other SBo packages,
|
||||
# but it's your call: http://slackbuilds.org/uid_gid.txt
|
||||
if ! grep -q "^kvm:" /etc/group; then
|
||||
printf "\n\tYou must have a kvm group to run this script.\n"
|
||||
printf "\tSomething like this should suffice for most systems:\n"
|
||||
printf "\t# groupadd -g 221 kvm\n\n"
|
||||
exit 1
|
||||
fi
|
||||
|
||||
set -e
|
||||
|
||||
rm -rf $PKG
|
||||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
rm -rf $PRGNAM-$VERSION
|
||||
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
|
||||
cd $PRGNAM-$VERSION
|
||||
chown -R root:root .
|
||||
find . \
|
||||
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
||||
-exec chmod 755 {} \; -o \
|
||||
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
||||
-exec chmod 644 {} \;
|
||||
|
||||
patch -p1 < $CWD/qemu-fix-build-for-esd-audio.patch
|
||||
|
||||
# Uncomment if 2.6.30.* kernel is used.
|
||||
#patch -p1 < $CWD/2.6.30.patch
|
||||
|
||||
# Uncomment if 2.6.31.* kernel is used.
|
||||
#rm kvm/kernel/configure
|
||||
|
||||
# Don't run depmod or try to rename existing modules on "make install"
|
||||
patch -p1 < $CWD/kvm-88-no_trickery_on_install.patch
|
||||
|
||||
# This translates the possible targets into the correct format for configure
|
||||
TARGETS="$(for i in $BUILD_ARCH ; do printf "$i-softmmu " ; done)"
|
||||
|
||||
CFLAGS="$SLKCFLAGS" \
|
||||
CXXFLAGS="$SLKCFLAGS" \
|
||||
./configure \
|
||||
--prefix=/usr \
|
||||
--audio-drv-list="oss alsa sdl esd" \
|
||||
--audio-card-list="ac97 es1370 sb16 cs4231a adlib gus" \
|
||||
--enable-mixemu \
|
||||
--target-list="$TARGETS"
|
||||
|
||||
make \
|
||||
mandir=/usr/man \
|
||||
docdir=/usr/doc/$PRGNAM-$VERSION
|
||||
make install \
|
||||
mandir=/usr/man \
|
||||
docdir=/usr/doc/$PRGNAM-$VERSION \
|
||||
DESTDIR=$PKG
|
||||
|
||||
cp -a kvm/kvm_stat $PKG/usr/bin
|
||||
|
||||
mkdir -p $PKG/lib/udev/rules.d/
|
||||
cat kvm/scripts/65-kvm.rules > $PKG/lib/udev/rules.d/65-kvm.rules
|
||||
|
||||
# Make modprobe prefer the new modules in ${moduledir}/extra/
|
||||
# We don't want to install this with a .new suffix, because we want it
|
||||
# removed with the package.
|
||||
mkdir -p $PKG/etc/depmod.d
|
||||
cat << EOF > $PKG/etc/depmod.d/kvm-${KERNEL}.conf
|
||||
override kvm ${KERNEL} extra
|
||||
override kvm-amd ${KERNEL} extra
|
||||
override kvm-intel ${KERNEL} extra
|
||||
EOF
|
||||
|
||||
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
|
||||
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
||||
|
||||
( cd $PKG/usr/man
|
||||
find . -type f -exec gzip -9 {} \;
|
||||
for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
|
||||
)
|
||||
|
||||
cp -a kvm/scripts CODING_STYLE COPYING COPYING.LIB Changelog KVM_VERSION \
|
||||
LICENSE MAINTAINERS README TODO VERSION $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
|
||||
mkdir -p $PKG/install
|
||||
cat $CWD/slack-desc > $PKG/install/slack-desc
|
||||
sed "s%@KERNEL@%$KERNEL%" $CWD/doinst.sh > $PKG/install/doinst.sh
|
||||
|
||||
cd $PKG
|
||||
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$PKG_VERS-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
|
|
@ -1,10 +0,0 @@
|
|||
PRGNAM="kvm"
|
||||
VERSION="88"
|
||||
HOMEPAGE="http://www.linux-kvm.org"
|
||||
DOWNLOAD="http://downloads.sourceforge.net/kvm/kvm-88.tar.gz"
|
||||
MD5SUM="02371948fcee1fa2a77e7a457384d71c"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
MAINTAINER="Murat D. Kadirov"
|
||||
EMAIL="banderols@gmail.com"
|
||||
APPROVED="rworkman"
|
|
@ -1,44 +0,0 @@
|
|||
From b37fb38b6043e319768fa92d5541fe20afb4741b Mon Sep 17 00:00:00 2001
|
||||
From: Anthony Liguori <aliguori@us.ibm.com>
|
||||
Date: Wed, 1 Jul 2009 10:07:16 -0500
|
||||
Subject: [PATCH 4/4] Fix build for ESD audio
|
||||
|
||||
(cherry picked from commit c6a5a71a3a1886afad5eeb214eb6e8785f4e0319)
|
||||
|
||||
Signed-off-by: Anthony Liguori <aliguori@us.ibm.com>
|
||||
Signed-off-by: Mark McLoughlin <markmc@redhat.com>
|
||||
---
|
||||
Makefile | 10 +++++-----
|
||||
1 files changed, 5 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index fc40431..f5deae9 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -139,18 +139,18 @@ obj-y += migration-exec.o
|
||||
endif
|
||||
|
||||
ifdef CONFIG_COREAUDIO
|
||||
-AUDIO_PT = yes
|
||||
+AUDIO_PT = y
|
||||
endif
|
||||
ifdef CONFIG_FMOD
|
||||
audio/audio.o audio/fmodaudio.o: CPPFLAGS := -I$(CONFIG_FMOD_INC) $(CPPFLAGS)
|
||||
endif
|
||||
ifdef CONFIG_ESD
|
||||
-AUDIO_PT = yes
|
||||
-AUDIO_PT_INT = yes
|
||||
+AUDIO_PT = y
|
||||
+AUDIO_PT_INT = y
|
||||
endif
|
||||
ifdef CONFIG_PA
|
||||
-AUDIO_PT = yes
|
||||
-AUDIO_PT_INT = yes
|
||||
+AUDIO_PT = y
|
||||
+AUDIO_PT_INT = y
|
||||
endif
|
||||
ifdef AUDIO_PT
|
||||
LDFLAGS += -pthread
|
||||
--
|
||||
1.6.3.3
|
||||
|
|
@ -1,20 +0,0 @@
|
|||
# HOW TO EDIT THIS FILE:
|
||||
# The "handy ruler" below makes it easier to edit a package description. Line
|
||||
# up the first '|' above the ':' following the base package name, and the '|' on
|
||||
# the right side marks the last column you can put a character in. You must make
|
||||
# exactly 11 lines for the formatting to be correct. It's also customary to
|
||||
# leave one space after the ':'.
|
||||
|
||||
|-----handy-ruler--------------------------------------------------------|
|
||||
kvm: kvm (kernel-based virtual machine)
|
||||
kvm:
|
||||
kvm: KVM is a full virtualization solution for Linux on x86 hardware
|
||||
kvm: containing virtualization extensions (Intel VT or AMD-V).
|
||||
kvm:
|
||||
kvm: Homepage: http://www.linux-kvm.org/page/Main_Page
|
||||
kvm:
|
||||
kvm:
|
||||
kvm:
|
||||
kvm:
|
||||
kvm:
|
||||
|
Loading…
Reference in a new issue