mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-22 19:44:21 +01:00
games/defendguin: Added to 12.2 repository
This commit is contained in:
parent
66110dd26e
commit
e8259575a4
9 changed files with 172 additions and 0 deletions
3
games/defendguin/README
Normal file
3
games/defendguin/README
Normal file
|
@ -0,0 +1,3 @@
|
|||
Defendguin is a clone of the arcade game "Defender," but with a Linux
|
||||
theme. Your mission is to defend little penguinoids from being captured
|
||||
and mutated.
|
64
games/defendguin/defendguin.SlackBuild
Normal file
64
games/defendguin/defendguin.SlackBuild
Normal file
|
@ -0,0 +1,64 @@
|
|||
#!/bin/sh
|
||||
|
||||
# Slackware build script for defendguin
|
||||
|
||||
# Written by B. Watson (yalhcru@gmail.com)
|
||||
|
||||
PRGNAM=defendguin
|
||||
VERSION=${VERSION:-0.0.11}
|
||||
ARCH=${ARCH:-i486}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
CWD=$(pwd)
|
||||
TMP=${TMP:-/tmp/SBo}
|
||||
PKG=$TMP/package-$PRGNAM
|
||||
OUTPUT=${OUTPUT:-/tmp}
|
||||
|
||||
if [ "$ARCH" = "i486" ]; then
|
||||
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
|
||||
elif [ "$ARCH" = "i686" ]; then
|
||||
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
|
||||
elif [ "$ARCH" = "x86_64" ]; then
|
||||
SLKCFLAGS="-O2 -fPIC"
|
||||
fi
|
||||
|
||||
set -e
|
||||
|
||||
rm -rf $PKG
|
||||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
rm -rf $PRGNAM-$VERSION
|
||||
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
|
||||
cd $PRGNAM-$VERSION
|
||||
chown -R root:root .
|
||||
chmod 755 .
|
||||
chmod -R a-s,u+w,go+r-w .
|
||||
|
||||
patch -p1 < $CWD/install_paths.diff
|
||||
patch -p1 < $CWD/man.diff
|
||||
|
||||
make COPT="$SLKCFLAGS"
|
||||
make install DESTDIR=$PKG
|
||||
|
||||
# Cruft removal:
|
||||
rm -f \
|
||||
$PKG/usr/share/$PRGNAM/images/l2r.sh \
|
||||
$PKG/usr/share/$PRGNAM/images/loader/loading-orig.bmp.gz
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp docs/* $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
|
||||
mkdir -p $PKG/usr/share/applications
|
||||
cat $CWD/$PRGNAM.desktop > $PKG/usr/share/applications/$PRGNAM.desktop
|
||||
|
||||
mkdir -p $PKG/usr/share/pixmaps
|
||||
cat $CWD/$PRGNAM.png > $PKG/usr/share/pixmaps/$PRGNAM.png
|
||||
|
||||
mkdir -p $PKG/install
|
||||
cat $CWD/slack-desc > $PKG/install/slack-desc
|
||||
cat $CWD/doinst.sh > $PKG/install/doinst.sh
|
||||
|
||||
cd $PKG
|
||||
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
|
6
games/defendguin/defendguin.desktop
Normal file
6
games/defendguin/defendguin.desktop
Normal file
|
@ -0,0 +1,6 @@
|
|||
[Desktop Entry]
|
||||
Name=Defendguin
|
||||
Exec=defendguin
|
||||
Type=Application
|
||||
Icon=defendguin
|
||||
Categories=Game;
|
8
games/defendguin/defendguin.info
Normal file
8
games/defendguin/defendguin.info
Normal file
|
@ -0,0 +1,8 @@
|
|||
PRGNAM="defendguin"
|
||||
VERSION="0.0.11"
|
||||
HOMEPAGE="http://www.newbreedsoftware.com/defendguin/"
|
||||
DOWNLOAD="ftp://ftp.tuxpaint.org/unix/x/defendguin/src/defendguin-0.0.11.tar.gz"
|
||||
MD5SUM="c8040e39f199c5338625066025ec2395"
|
||||
MAINTAINER="B. Watson"
|
||||
EMAIL="yalhcru@gmail.com"
|
||||
APPROVED="dsomero"
|
BIN
games/defendguin/defendguin.png
Normal file
BIN
games/defendguin/defendguin.png
Normal file
Binary file not shown.
After Width: | Height: | Size: 2.6 KiB |
5
games/defendguin/doinst.sh
Normal file
5
games/defendguin/doinst.sh
Normal file
|
@ -0,0 +1,5 @@
|
|||
|
||||
if [ -x /usr/bin/update-desktop-database ]; then
|
||||
/usr/bin/update-desktop-database usr/share/applications >/dev/null 2>&1
|
||||
fi
|
||||
|
53
games/defendguin/install_paths.diff
Normal file
53
games/defendguin/install_paths.diff
Normal file
|
@ -0,0 +1,53 @@
|
|||
diff -Naur defendguin-0.0.11/Makefile defendguin-0.0.11.patched/Makefile
|
||||
--- defendguin-0.0.11/Makefile 2006-01-29 04:23:31.000000000 -0500
|
||||
+++ defendguin-0.0.11.patched/Makefile 2009-04-16 03:18:04.000000000 -0400
|
||||
@@ -9,11 +9,12 @@
|
||||
|
||||
# User-definable stuff:
|
||||
|
||||
-CFLAGS=-Wall -O2
|
||||
+DESTDIR=
|
||||
+COPT=
|
||||
#DATA_PREFIX=$(PWD)/data/
|
||||
-PREFIX=/usr/local
|
||||
+PREFIX=/usr
|
||||
MAN_PREFIX=$(PREFIX)
|
||||
-BIN_PREFIX=$(PREFIX)/bin
|
||||
+BIN_PREFIX=$(PREFIX)/games
|
||||
DATA_PREFIX=$(PREFIX)/share/defendguin/
|
||||
JOY=YES
|
||||
|
||||
@@ -24,7 +25,7 @@
|
||||
SDL_LDFLAGS := $(shell sdl-config --libs) -L/usr/X11R6/lib
|
||||
MIXER=-lSDL_mixer
|
||||
NOSOUNDFLAG=__SOUND
|
||||
-CFLAGS=-Wall $(SDL_CFLAGS) -DDATA_PREFIX=\"$(DATA_PREFIX)\" -D$(NOSOUNDFLAG) \
|
||||
+CFLAGS=-Wall $(COPT) $(SDL_CFLAGS) -DDATA_PREFIX=\"$(DATA_PREFIX)\" -D$(NOSOUNDFLAG) \
|
||||
-DJOY_$(JOY)
|
||||
SDL_LIB=$(SDL_LDFLAGS) $(MIXER)
|
||||
|
||||
@@ -37,13 +38,17 @@
|
||||
make defendguin MIXER= NOSOUNDFLAG=NOSOUND
|
||||
|
||||
install: defendguin
|
||||
- install -d $(DATA_PREFIX)
|
||||
- cp -R data/* $(DATA_PREFIX)
|
||||
- chmod -R a+rX,g-w,o-w $(DATA_PREFIX)
|
||||
- cp defendguin $(BIN_PREFIX)/
|
||||
- chmod a+rx,g-w,o-w $(BIN_PREFIX)/defendguin
|
||||
- cp src/defendguin.6 $(MAN_PREFIX)/man/man6/
|
||||
- chmod a+rx,g-w,o-w $(MAN_PREFIX)/man/man6/defendguin.6
|
||||
+ install -d $(DESTDIR)$(DATA_PREFIX)
|
||||
+ install -d $(DESTDIR)$(MAN_PREFIX)/man/man6/
|
||||
+ install -d $(DESTDIR)$(BIN_PREFIX)
|
||||
+ cp -R data/* $(DESTDIR)$(DATA_PREFIX)
|
||||
+ chmod -R a+rX,g-w,o-w $(DESTDIR)$(DATA_PREFIX)
|
||||
+ strip defendguin
|
||||
+ cp defendguin $(DESTDIR)$(BIN_PREFIX)/
|
||||
+ chmod a+rx,g-w,o-w $(DESTDIR)$(BIN_PREFIX)/defendguin
|
||||
+ cp src/defendguin.6 $(DESTDIR)$(MAN_PREFIX)/man/man6/
|
||||
+ chmod a+rx,g-w,o-w $(DESTDIR)$(MAN_PREFIX)/man/man6/defendguin.6
|
||||
+ gzip -9 $(DESTDIR)$(MAN_PREFIX)/man/man6/defendguin.6
|
||||
|
||||
uninstall:
|
||||
-rm -r $(DATA_PREFIX)
|
14
games/defendguin/man.diff
Normal file
14
games/defendguin/man.diff
Normal file
|
@ -0,0 +1,14 @@
|
|||
diff -Naur defendguin-0.0.11/src/defendguin.6 defendguin-0.0.11.patched/src/defendguin.6
|
||||
--- defendguin-0.0.11/src/defendguin.6 2006-01-29 05:16:58.000000000 -0500
|
||||
+++ defendguin-0.0.11.patched/src/defendguin.6 2009-04-16 03:27:29.000000000 -0400
|
||||
@@ -29,7 +29,9 @@
|
||||
\fB\-\-usage\fR
|
||||
Displays acceptable command\-line options.
|
||||
.SH "FILES"
|
||||
-\fI/usr/local/share/defendguin/\fP \- Sound, music and graphics data.
|
||||
+\fI/usr/share/defendguin/\fP \- Sound, music and graphics data.
|
||||
+.LP
|
||||
+\fI~/.defendguinrc\fP \- Per\-user settings
|
||||
.LP
|
||||
.SH "AUTHORS"
|
||||
.LP
|
19
games/defendguin/slack-desc
Normal file
19
games/defendguin/slack-desc
Normal file
|
@ -0,0 +1,19 @@
|
|||
# HOW TO EDIT THIS FILE:
|
||||
# The "handy ruler" below makes it easier to edit a package description. Line
|
||||
# up the first '|' above the ':' following the base package name, and the '|'
|
||||
# on the right side marks the last column you can put a character in. You must
|
||||
# make exactly 11 lines for the formatting to be correct. It's also
|
||||
# customary to leave one space after the ':'.
|
||||
|
||||
|-----handy-ruler------------------------------------------------------|
|
||||
defendguin: defendguin (clone of the arcade game Defender)
|
||||
defendguin:
|
||||
defendguin: Defendguin is a clone of the arcade game "Defender," but with a
|
||||
defendguin: Linux theme. Your mission is to defend little penguinoids from
|
||||
defendguin: being captured and mutated.
|
||||
defendguin:
|
||||
defendguin:
|
||||
defendguin:
|
||||
defendguin:
|
||||
defendguin:
|
||||
defendguin:
|
Loading…
Reference in a new issue