mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-04 20:29:09 +01:00
graphics/fbida: Updated for version 2.09.
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
This commit is contained in:
parent
73b2640c6e
commit
e74fcb2cf6
4 changed files with 12 additions and 33 deletions
|
@ -1,6 +1,6 @@
|
|||
#!/bin/sh
|
||||
|
||||
# Slackware build script for fbida
|
||||
|
||||
# Slackware build script for fbida
|
||||
# Modified by Luis Henrique <lmello.009@gmail.com>
|
||||
|
||||
# (C) 2007 Michael Wagner <lapinours@web.de>
|
||||
|
@ -24,16 +24,14 @@
|
|||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
PRGNAM=fbida
|
||||
VERSION=2.07
|
||||
VERSION=2.09
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
# Automatically determine the architecture we're building on:
|
||||
if [ -z "$ARCH" ]; then
|
||||
case "$( uname -m )" in
|
||||
i?86) ARCH=i486 ;;
|
||||
arm*) ARCH=arm ;;
|
||||
# Unless $ARCH is already set, use uname -m for all other archs:
|
||||
*) ARCH=$( uname -m ) ;;
|
||||
esac
|
||||
fi
|
||||
|
@ -74,14 +72,6 @@ find . \
|
|||
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
||||
-exec chmod 644 {} \;
|
||||
|
||||
# "Patch" GNUmakefile and mk/Autoconf.mk
|
||||
for i in GNUmakefile mk/Autoconf.mk; do
|
||||
sed -i s,/X11R6,, $i || exit 1
|
||||
done
|
||||
|
||||
# Fix rd/read-png.c (obsolete libpng declaration)
|
||||
patch -p0 < $CWD/read-png.c.patch
|
||||
|
||||
CFLAGS="$SLKCFLAGS" make HAVE_MOTIF=no
|
||||
prefix=/usr make install DESTDIR=$PKG HAVE_MOTIF=no
|
||||
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
PRGNAM="fbida"
|
||||
VERSION="2.07"
|
||||
VERSION="2.09"
|
||||
HOMEPAGE="http://linux.bytesex.org/fbida/"
|
||||
DOWNLOAD="http://dl.bytesex.org/releases/fbida/fbida-2.07.tar.gz"
|
||||
MD5SUM="3e05910fb7c1d9b2bd3e272d96db069c"
|
||||
DOWNLOAD="http://dl.bytesex.org/releases/fbida/fbida-2.09.tar.gz"
|
||||
MD5SUM="62415c7cb28d995f9d317868de0f2830"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES=""
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- rd/read-png.c.orig 2010-05-27 17:30:21.883639928 -0300
|
||||
+++ rd/read-png.c 2010-05-27 17:33:27.385641448 -0300
|
||||
@@ -69,7 +69,7 @@
|
||||
if (h->color_type == PNG_COLOR_TYPE_PALETTE)
|
||||
png_set_palette_to_rgb(h->png);
|
||||
if (h->color_type == PNG_COLOR_TYPE_GRAY && bit_depth < 8)
|
||||
- png_set_gray_1_2_4_to_8(h->png);
|
||||
+ png_set_expand_gray_1_2_4_to_8(h->png);
|
||||
|
||||
if (png_get_bKGD(h->png, h->info, &file_bg)) {
|
||||
png_set_background(h->png,file_bg,PNG_BACKGROUND_GAMMA_FILE,1,1.0);
|
|
@ -1,14 +1,14 @@
|
|||
# HOW TO EDIT THIS FILE:
|
||||
# The "handy ruler" below makes it easier to edit a package description. Line
|
||||
# up the first '|' above the ':' following the base package name, and the '|'
|
||||
# on the right side marks the last column you can put a character in. You must
|
||||
# make exactly 11 lines for the formatting to be correct. It's also
|
||||
# customary to leave one space after the ':'.
|
||||
# The "handy ruler" below makes it easier to edit a package description.
|
||||
# Line up the first '|' above the ':' following the base package name, and
|
||||
# the '|' on the right side marks the last column you can put a character in.
|
||||
# You must make exactly 11 lines for the formatting to be correct. It's also
|
||||
# customary to leave one space after the ':' except on otherwise blank lines.
|
||||
|
||||
|-----handy-ruler------------------------------------------------------|
|
||||
fbida: fbida (image viewer)
|
||||
fbida:
|
||||
fbida: The fbida project contains a few applications for viewing and
|
||||
fbida: The fbida project contains a few applications for viewing and
|
||||
fbida: editing images, with the main focus being photos.
|
||||
fbida:
|
||||
fbida: Homepage: http://linux.bytesex.org/fbida/
|
||||
|
|
Loading…
Reference in a new issue