mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-24 10:02:29 +01:00
development/jupyter-notebook: Update for 6.5.7
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
d2a11c4a0d
commit
e602f01065
3 changed files with 5 additions and 30 deletions
|
@ -1,21 +0,0 @@
|
|||
--- a/notebook/notebookapp.py 2023-12-20 18:04:52.352937385 -0800
|
||||
+++ b/notebook/notebookapp.py 2023-12-20 18:06:22.564933788 -0800
|
||||
@@ -1408,7 +1408,7 @@
|
||||
# and allow jupyter_server contents managers to pass
|
||||
# through. If jupyter_server is not installed, this class
|
||||
# will be ignored.
|
||||
- 'jupyter_server.contents.services.managers.ContentsManager'
|
||||
+ "jupyter_server.services.contents.managers.ContentsManager",
|
||||
],
|
||||
config=True,
|
||||
help=_('The notebook manager class to use.')
|
||||
--- a/notebook/traittypes.py 2023-12-20 18:08:44.904928112 -0800
|
||||
+++ b/notebook/traittypes.py 2023-12-20 18:09:04.503927331 -0800
|
||||
@@ -1,5 +1,6 @@
|
||||
import inspect
|
||||
-from traitlets import ClassBasedTraitType, Undefined, warn
|
||||
+from warnings import warn
|
||||
+from traitlets import ClassBasedTraitType, Undefined
|
||||
|
||||
# Traitlet's 5.x includes a set of utilities for building
|
||||
# description strings for objects. Traitlets 5.x does not
|
|
@ -26,8 +26,8 @@
|
|||
cd $(dirname $0) ; CWD=$(pwd)
|
||||
|
||||
PRGNAM=jupyter-notebook
|
||||
VERSION=${VERSION:-6.5.4}
|
||||
BUILD=${BUILD:-3}
|
||||
VERSION=${VERSION:-6.5.7}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
PKGTYPE=${PKGTYPE:-tgz}
|
||||
|
||||
|
@ -65,10 +65,6 @@ find -L . \
|
|||
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||
|
||||
# Fix traitlets warning and error:
|
||||
# https://github.com/jupyter/notebook/pull/7051
|
||||
patch -p1 < $CWD/fix-traitlets-error.patch
|
||||
|
||||
python3 setup.py install --root=$PKG
|
||||
|
||||
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
PRGNAM="jupyter-notebook"
|
||||
VERSION="6.5.4"
|
||||
VERSION="6.5.7"
|
||||
HOMEPAGE="https://jupyter.org/"
|
||||
DOWNLOAD="https://files.pythonhosted.org/packages/source/n/notebook/notebook-6.5.4.tar.gz"
|
||||
MD5SUM="6a2f44954dfa39c55bba2f576dd59e4a"
|
||||
DOWNLOAD="https://files.pythonhosted.org/packages/source/n/notebook/notebook-6.5.7.tar.gz"
|
||||
MD5SUM="4026bb5c1f7d517affa1e45ad6c576a2"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES="jupyter-ipykernel jupyter-nbclassic python3-ipython_genutils"
|
||||
|
|
Loading…
Reference in a new issue