mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-16 19:50:19 +01:00
development/easyedit: Added to 12.0 repository
This commit is contained in:
parent
75bcf7a332
commit
e5e53d4c75
5 changed files with 132 additions and 0 deletions
13
development/easyedit/Makefile.diff
Normal file
13
development/easyedit/Makefile.diff
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- Makefile.old 2007-07-10 13:39:00.000000000 +0100
|
||||
+++ Makefile 2007-07-11 19:11:23.000000000 +0100
|
||||
@@ -21,8 +21,8 @@
|
||||
@./create.make
|
||||
|
||||
install :
|
||||
- cp ee /usr/local/bin/ee
|
||||
- cp ee.1 /usr/local/man/man1/ee.1
|
||||
+ cp ee $(DESTDIR)/usr/bin/ee
|
||||
+ cp ee.1 $(DESTDIR)/usr/man/man1/ee.1
|
||||
|
||||
clean :
|
||||
rm -f ee.o new_curse.o ee
|
8
development/easyedit/README
Normal file
8
development/easyedit/README
Normal file
|
@ -0,0 +1,8 @@
|
|||
The editor 'ee' (easy editor) is intended to be a simple, easy to use
|
||||
terminal-based screen oriented editor that requires no instruction to use.
|
||||
It's primary use would be for people who are new to computers, or who use
|
||||
computers only for things like email.
|
||||
|
||||
WARNING: Easy edit conflicts with Electric Eyes (an image viewer). If you
|
||||
have installed Electric Eyes, it must be uninstalled before installing
|
||||
easyedit. Electric Eyes is not part of a standard Slackware installation.
|
84
development/easyedit/easyedit.SlackBuild
Normal file
84
development/easyedit/easyedit.SlackBuild
Normal file
|
@ -0,0 +1,84 @@
|
|||
#!/bin/sh
|
||||
# Easyedit.SlackBuild v2.0 2007/10/29
|
||||
# Copyright (c) 2007 Simon Coxall simoncoxall@yahoo.co.uk
|
||||
# All rights reserved.
|
||||
#
|
||||
# Permission to use, copy, modify, and distribute this software for
|
||||
# any purpose with or without fee is hereby granted, provided that
|
||||
# the above copyright notice and this permission notice appear in copies.
|
||||
#
|
||||
# THIS SOFTWARE IS PROVIDED ``AS IS'' AND ANY EXPRESSED OR IMPLIED
|
||||
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
||||
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.
|
||||
# IN NO EVENT SHALL THE AUTHORS AND COPYRIGHT HOLDERS AND THEIR
|
||||
# CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
||||
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
|
||||
# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF
|
||||
# USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
|
||||
# ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
|
||||
# OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT
|
||||
# OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
|
||||
# SUCH DAMAGE.
|
||||
#
|
||||
# ---------------------------------------------------------------------
|
||||
#
|
||||
# Auther: Simon Coxall simoncoxall@yahoo.co.uk
|
||||
# SlackBuild for easyedit (ee)
|
||||
# Source URL: http://mahon.cwx.net/sources/ee-1.4.6.src.tgz
|
||||
#
|
||||
# Version history:
|
||||
# v1. 2007/07/10 Initial build
|
||||
# v2. 2007/10/29 Revised to use system ncurses
|
||||
# ---------------------------------------------------------------------
|
||||
|
||||
PRGNAM=easyedit
|
||||
VERSION=1.4.6
|
||||
ARCH=${ARCH:-i486}
|
||||
BUILD=${BUILD:-2}
|
||||
TAG=${TAG:-_SBo}
|
||||
CWD=$(pwd)
|
||||
TMP=${TMP:-/tmp/SBo}
|
||||
PKG=$TMP/package-$PRGNAM
|
||||
OUTPUT=${OUTPUT:-/tmp}
|
||||
|
||||
DOCS="Artistic Changes README.ee ee.i18n.guide ee.msg"
|
||||
|
||||
set -e # Exit on most errors
|
||||
|
||||
rm -rf $PKG
|
||||
mkdir -p $TMP $PKG/usr/{bin,doc,man/man1} $OUTPUT
|
||||
cd $TMP
|
||||
rm -rf $PRGNAM-$VERSION
|
||||
|
||||
tar xvf $CWD/ee-$VERSION.src.tgz
|
||||
cd $PRGNAM-$VERSION
|
||||
chown -R root:root .
|
||||
chmod -R a-s,u+rw,go+r-w .
|
||||
|
||||
# Patch the Makefile so it's installed to /usr instead of /usr/local
|
||||
# and also honours the DESTDIR=$PKG
|
||||
patch -p0 < $CWD/Makefile.diff
|
||||
|
||||
# No ./configure required, just run make. However, we'll use the system ncurses
|
||||
# instead of the builtin version, as it doesn't seem to work properly.
|
||||
make curses -f make.default
|
||||
make install DESTDIR=$PKG
|
||||
|
||||
( cd $PKG
|
||||
find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
|
||||
find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
|
||||
)
|
||||
|
||||
( cd $PKG/usr/man/man1
|
||||
gzip -9 ee.1
|
||||
)
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
|
||||
mkdir -p $PKG/install
|
||||
cat $CWD/slack-desc > $PKG/install/slack-desc
|
||||
|
||||
cd $PKG
|
||||
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
|
8
development/easyedit/easyedit.info
Normal file
8
development/easyedit/easyedit.info
Normal file
|
@ -0,0 +1,8 @@
|
|||
PRGNAM="easyedit"
|
||||
VERSION="1.4.6"
|
||||
HOMEPAGE="http://mahon.cwx.net"
|
||||
DOWNLOAD="http://mahon.cwx.net/sources/ee-1.4.6.src.tgz"
|
||||
MD5SUM="447c48341fc355dacc7e5d338dd1677a"
|
||||
MAINTAINER="Simon Coxall"
|
||||
EMAIL="simoncoxall@yahoo.co.uk"
|
||||
APPROVED="rworkman"
|
19
development/easyedit/slack-desc
Normal file
19
development/easyedit/slack-desc
Normal file
|
@ -0,0 +1,19 @@
|
|||
# HOW TO EDIT THIS FILE:
|
||||
# The "handy ruler" below makes it easier to edit a package description. Line
|
||||
# up the first '|' above the ':' following the base package name, and the '|'
|
||||
# on the right side marks the last column you can put a character in. You must
|
||||
# make exactly 11 lines for the formatting to be correct. It's also
|
||||
# customary to leave one space after the ':'.
|
||||
|
||||
|-----handy-ruler------------------------------------------------------|
|
||||
easyedit: easyedit (an easy to use text editor)
|
||||
easyedit:
|
||||
easyedit: The editor 'ee' (easy editor) is intended to be a simple, easy
|
||||
easyedit: to use, terminal-based screen oriented editor that requires no
|
||||
easyedit: instruction to use. It's primary use would be for people who
|
||||
easyedit: are new to computers, or who use computers only for things
|
||||
easyedit: like email.
|
||||
easyedit:
|
||||
easyedit:
|
||||
easyedit:
|
||||
easyedit:
|
Loading…
Reference in a new issue