games/nSnake: Added (snake game on the console).

Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
Dimitris Zlatanidis 2014-04-20 22:14:51 +07:00 committed by Willy Sudiarto Raharjo
parent 72fd212d6e
commit e5aac2a1fc
6 changed files with 161 additions and 0 deletions

View file

@ -0,0 +1,37 @@
--- nSnake-2.0.0/Makefile.original 2014-04-20 10:32:07.056427339 +0300
+++ nSnake-2.0.0/Makefile 2014-04-20 17:48:36.912009088 +0300
@@ -48,15 +48,15 @@
PREFIX = $(DESTDIR)/usr
EXEC_PREFIX = $(PREFIX)
-DATAROOTDIR = $(PREFIX)/share
-MANROOT = $(DATAROOTDIR)/man
+DATAROOTDIR = $(PREFIX)/share/games
+MANROOT = $(PREFIX)/man
MANNUMBER = 6
-BINDIR = $(EXEC_PREFIX)/games
+BINDIR = $(EXEC_PREFIX)/bin
MANDIR = $(MANROOT)/man$(MANNUMBER)
-MANFILE = $(PACKAGE).$(MANNUMBER)
+# MANFILE = $(PACKAGE).$(MANNUMBER)
MANPAGE = doc/man/$(MANFILE)
# Build info
@@ -121,10 +121,10 @@
# Installing...
$(MUTE)install -d -m 755 $(BINDIR)
$(MUTE)install -m 755 bin/$(EXE) $(BINDIR)
- -$(MUTE)cat $(MANPAGE) | sed -e "s|DATE|$(DATE)|g" -e "s|VERSION|$(VERSION)|g" >$(MANFILE)
- $(MUTE)install -d $(MANDIR)
- $(MUTE)install $(MANFILE) $(MANDIR)
- $(MUTE)rm -f $(MANFILE)
+ # -$(MUTE)cat $(MANPAGE) | sed -e "s|DATE|$(DATE)|g" -e "s|VERSION|$(VERSION)|g" > $(MANFILE)
+ # $(MUTE)install -d $(MANDIR)
+ # $(MUTE)install $(MANFILE) $(MANDIR)
+ # $(MUTE)rm -f $(MANFILE)
# $(PACKAGE) successfuly installed!
uninstall:

3
games/nSnake/README Normal file
View file

@ -0,0 +1,3 @@
nSnake is a clone of the classic snake game that we all used to play
on our cellphones. You play this game on the terminal, with textual
interface.

3
games/nSnake/doinst.sh Normal file
View file

@ -0,0 +1,3 @@
if [ -x /usr/bin/update-desktop-database ]; then
/usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
fi

View file

@ -0,0 +1,89 @@
#!/bin/sh
# Slackware build script for nSnake
# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=nSnake
VERSION=${VERSION:-2.0.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
fi
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
fi
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz || tar xvf $CWD/v$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
patch -p1 < $CWD/Makefile.patch
make
make install PREFIX=$PKG/usr
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a AUTHORS BUGS COPYING ChangeLog NEWS README.md TODO $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}

10
games/nSnake/nSnake.info Normal file
View file

@ -0,0 +1,10 @@
PRGNAM="nSnake"
VERSION="2.0.0"
HOMEPAGE="http://alexdantas.net/projects/nsnake"
DOWNLOAD="https://github.com/alexdantas/nSnake/archive/v2.0.0.tar.gz"
MD5SUM="f3fd657ce4532d16fd82906356d35831"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
MAINTAINER="Dimitris Zlatanidis"
EMAIL="d.zlatanidis@gmail.com"

19
games/nSnake/slack-desc Normal file
View file

@ -0,0 +1,19 @@
# HOW TO EDIT THIS FILE:
# The "handy ruler" below makes it easier to edit a package description.
# Line up the first '|' above the ':' following the base package name, and
# the '|' on the right side marks the last column you can put a character in.
# You must make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':' except on otherwise blank lines.
|-----handy-ruler------------------------------------------------------|
nSnake: nSnake (snake game on the console)
nSnake:
nSnake: nsnake is a clone of the classic snake game that we all used to play
nSnake: on our cellphones. You play this game on the terminal, with textual
nSnake: interface.
nSnake:
nSnake: Homepage: http://alexdantas.net/projects/nsnake
nSnake:
nSnake:
nSnake:
nSnake: