graphics/OpenCASCADE: Updated for version 6.6.0.

Dropped the dep ftgl (following upstream hints)

Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
This commit is contained in:
Matteo Bernardini 2013-11-17 11:38:26 +01:00 committed by Heinz Wiesinger
parent 34e09a4b06
commit e494d0daa9
4 changed files with 19 additions and 157 deletions

View file

@ -1,123 +0,0 @@
--- OpenCASCADE-6.5.2/ros/configure.ac 2011-09-30 13:32:47.000000000 -0300
+++ OpenCASCADE-6.5.2_patched/ros/configure.ac 2012-01-02 13:35:24.000000000 -0200
@@ -422,7 +422,7 @@
HAVE_FTGL=yes
HAVE_FTGL_INC=yes
CPPFLAGS="-I$ftgl/include $CPPFLAGS";
- AC_CHECK_HEADER( [FTGL/FTGL.h], [], [HAVE_FTGL_INC=no] )
+ AC_CHECK_HEADER( [FTGL/ftgl.h], [], [HAVE_FTGL_INC=no] )
if test "x$HAVE_FTGL_INC" = "xyes"; then
CSF_FTGL_INCLUDES="-I$ftgl/include/FTGL"
HAVE_FTGL_LIB=yes
@@ -431,9 +431,9 @@
LIBS_sv=$LIBS
LIBS="-lftgl $CSF_OpenGlLibs_LIB $LIBS"
#we have problem with unresolved symbols on 64 stations
- CSF_FTGL_LIB="-L$ftgl/lib -lftgl"
+ CSF_FTGL_LIB="-L$ftgl/lib -lftgl -lfreetype"
AC_TRY_LINK([
-#include <FTGL/FTGL.h>
+#include <FTGL/ftgl.h>
#include <FTGL/FTGLTextureFont.h>
], [
FTGLTextureFont font("");], [
--- OpenCASCADE-6.5.2/ros/inc/OpenGl_FontMgr.hxx 2011-09-02 12:43:25.000000000 -0300
+++ OpenCASCADE-6.5.2_patched/ros/inc/OpenGl_FontMgr.hxx 2012-01-02 13:32:57.000000000 -0200
@@ -6,7 +6,7 @@
# include <stdlib.h>
#endif
-#include <FTFont.h>
+#include <FTGL/FTFont.h>
#include <InterfaceGraphic.hxx>
#include <TCollection_HAsciiString.hxx>
--- OpenCASCADE-6.5.2/ros/inc/OpenGl_TextRender.hxx 2011-09-02 12:43:25.000000000 -0300
+++ OpenCASCADE-6.5.2_patched/ros/inc/OpenGl_TextRender.hxx 2012-01-02 13:32:57.000000000 -0200
@@ -5,7 +5,7 @@
#include <NCollection_DataMap.hxx>
#include <TCollection_AsciiString.hxx>
#include <TCollection_HAsciiString.hxx>
-#include <FTFont.h>
+#include <FTGL/FTFont.h>
#define NUM_FONT_SIZES 40
#define NUM_CHAR_FONT 1024
--- OpenCASCADE-6.5.2/ros/src/OpenGl/OpenGl_FontMgr.cxx 2011-09-02 12:43:25.000000000 -0300
+++ OpenCASCADE-6.5.2_patched/ros/src/OpenGl/OpenGl_FontMgr.cxx 2012-01-02 13:32:57.000000000 -0200
@@ -1,8 +1,6 @@
#include <OpenGl_FontMgr.hxx>
-#include <FTGLTextureFont.h>
-#include <FTLibrary.h>
-#include <FTFace.h>
+#include <FTGL/ftgl.h>
#include <Standard_Stream.hxx>
#undef TRACE
@@ -60,6 +58,8 @@
void OpenGl_FontMgr::_initializeFontDB()
{
Handle(OSD_FontMgr) fntMgr = OSD_FontMgr::GetInstance();
+ FT_Library library;
+ int error = FT_Init_FreeType( &library );
if ( !fntMgr.IsNull() ) {
OSD_NListOfSystemFont fontList = fntMgr->GetAvalableFonts();
@@ -68,13 +68,14 @@
OSD_NListOfSystemFont::Iterator it(fontList);
for ( ; it.More(); it.Next() ) {
OGLFont_SysInfo* info = new OGLFont_SysInfo();
- if ( it.Value()->FontAspect() == OSD_FA_Regular ) {
+ if ( it.Value()->FontAspect() == OSD_FA_Regular && !error ) {
//this workaround for fonts with names dependent on system locale.
//for example: "Times New Roman Fett Kursive" or "Times New Roman Gras Italiqui"
- FTFace face(it.Value()->FontPath()->ToCString());
-
- if ( face.Error() == FT_Err_Ok ) {
- if ( (*face.Face())->style_flags == 0 ) {
+ FT_Face ftFace;
+ error = FT_New_Face(library,
+ it.Value()->FontPath()->ToCString(), 0, &ftFace);
+ if ( !error ) {
+ if ( ftFace->style_flags == 0 ) {
info->SysFont = it.Value();
}
else {
@@ -82,27 +83,30 @@
#ifdef TRACE
cout << "TKOpenGl::initializeFontDB() detected new font!\n"
<< "\tFont Previous Name: " << it.Value()->FontName()->ToCString() << endl
- << "\tFont New Name: " << (*face.Face())->family_name << endl
- << "\tFont Aspect: " << (*face.Face())->style_flags << endl;
+ << "\tFont New Name: " << ftFace->family_name << endl
+ << "\tFont Aspect: " << ftFace->style_flags << endl;
#endif
OSD_FontAspect aspect = OSD_FA_Regular;
- if ( (*face.Face())->style_flags == (FT_STYLE_FLAG_ITALIC | FT_STYLE_FLAG_BOLD) )
+ if ( ftFace->style_flags == (FT_STYLE_FLAG_ITALIC | FT_STYLE_FLAG_BOLD) )
aspect = OSD_FA_BoldItalic;
- else if ( (*face.Face())->style_flags == FT_STYLE_FLAG_ITALIC )
+ else if ( ftFace->style_flags == FT_STYLE_FLAG_ITALIC )
aspect = OSD_FA_Italic;
- else if ( (*face.Face())->style_flags == FT_STYLE_FLAG_BOLD )
+ else if ( ftFace->style_flags == FT_STYLE_FLAG_BOLD )
aspect = OSD_FA_Bold;
#ifdef TRACE
cout << "\tOSD_FontAspect: " << aspect << endl;
#endif
Handle(TCollection_HAsciiString) aFontName =
- new TCollection_HAsciiString( (*face.Face())->family_name );
+ new TCollection_HAsciiString( ftFace->family_name );
info->SysFont = new OSD_SystemFont( aFontName, aspect, it.Value()->FontPath() );
}
}
else
+ {
+ error = 0;
continue;
+ }
} else {
info->SysFont = it.Value();
}

View file

@ -23,11 +23,11 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
# revision date: 2012/01/03
# revision date: 2013/11/17
PRGNAM=OpenCASCADE
VERSION=${VERSION:-6.5.2}
BUILD=${BUILD:-2}
VERSION=${VERSION:-6.6.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
SRCVERSION=$( echo $VERSION | sed "s/\.//g" )
@ -68,25 +68,20 @@ rm -rf $PRGNAM-$VERSION
# Source untars in current directory...
mkdir $PRGNAM-$VERSION
cd $PRGNAM-$VERSION
tar xvf $CWD/${PRGNAM}${SRCVERSION}.tar.gz
tar xvf $CWD/${PRGNAM}${SRCVERSION}.tgz
chown -R root:root .
chmod -R u+w,go+r-w,a-s .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Patch source for newer gcc versions
# (avoids "not declared in this scope" errors)
patch -p1 < $CWD/newgcc.patch
# Fix for newer fgtl versions
# (based on earlier patch from openSUSE)
patch -p1 < $CWD/OpenCASCADE-6.5.2_ftgl.patch
# Change to the directory where we'll build from
cd ros
autoreconf -f -i
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS -fpermissive" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \
@ -125,25 +120,25 @@ mkdir -p $PKG/usr/src/$PRGNAM
) || exit 1
# Remove unnecessary (and confusing) files
rm -r $PKG/usr/{lin,Linux,env_DRAW.sh}
rm -r $PKG/usr/Linux $PKG/usr/*.sh
mkdir -p $PKG/usr/share/$PRGNAM
cp -a data samples $PKG/usr/share/$PRGNAM
cp -a ros/data ros/samples $PKG/usr/share/$PRGNAM
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
README LICENSE ros/README.txt \
ros/LICENSE ros/README \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
# If you want *all* documentation in the package, use INSTALL_FULL_DOCS=yes
# but be warned: we're talking about ~ 600MB of documentation...
# but be warned: we're talking about ~ 520MB of documentation...
if [ "${INSTALL_FULL_DOCS:-no}" = "yes" ]; then
cp -a \
doc/* \
ros/doc/* \
$PKG/usr/doc/$PRGNAM-$VERSION
fi

View file

@ -1,10 +1,10 @@
PRGNAM="OpenCASCADE"
VERSION="6.5.2"
VERSION="6.6.0"
HOMEPAGE="http://www.opencascade.org/"
DOWNLOAD="http://files.opencascade.com/OCCT/OCC_6.5.2_release/OpenCASCADE652.tar.gz"
MD5SUM="bfc4c8974e1ae56230b0cc81ec836898"
DOWNLOAD="http://files.opencascade.com/OCCT/OCC_6.6.0_release/OpenCASCADE660.tgz"
MD5SUM="ad698d9b1e370c14999e7ec130575c92"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="ftgl"
REQUIRES=""
MAINTAINER="Niels Horn"
EMAIL="niels.horn@gmail.com"

View file

@ -1,10 +0,0 @@
--- OpenCASCADE-6.5.1/ros/src/OSD/OSD_MAllocHook.cxx 2011-05-19 08:24:52.000000000 -0300
+++ OpenCASCADE-6.5.1_patched/ros/src/OSD/OSD_MAllocHook.cxx 2011-08-10 12:39:39.000000000 -0300
@@ -10,6 +10,7 @@
#define __STDC_LIMIT_MACROS
#endif
#include <stdint.h>
+#include <stdlib.h>
#endif
#include <set>