mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-04 20:29:09 +01:00
system/hardinfo: Patched for newer GCC.
Thanks to _gin in LQ. Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
230c7d9ebb
commit
e40b090918
2 changed files with 17 additions and 6 deletions
|
@ -23,7 +23,7 @@
|
||||||
|
|
||||||
PRGNAM=hardinfo
|
PRGNAM=hardinfo
|
||||||
VERSION=${VERSION:-0.5.1}
|
VERSION=${VERSION:-0.5.1}
|
||||||
BUILD=${BUILD:-2}
|
BUILD=${BUILD:-3}
|
||||||
TAG=${TAG:-_SBo}
|
TAG=${TAG:-_SBo}
|
||||||
|
|
||||||
if [ -z "$ARCH" ]; then
|
if [ -z "$ARCH" ]; then
|
||||||
|
@ -63,14 +63,15 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
|
||||||
cd $PRGNAM-$VERSION
|
cd $PRGNAM-$VERSION
|
||||||
chown -R root:root .
|
chown -R root:root .
|
||||||
find -L . \
|
find -L . \
|
||||||
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
|
||||||
-exec chmod 755 {} \; -o \
|
-o -perm 511 \) -exec chmod 755 {} \; -o \
|
||||||
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||||
-exec chmod 644 {} \;
|
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||||
|
|
||||||
# Fix mandir
|
# Fix mandir
|
||||||
sed -i "s|share/man|man|" configure
|
sed -i "s|share/man|man|" configure
|
||||||
|
|
||||||
|
patch -p1 < $CWD/makefile.patch
|
||||||
CFLAGS="$SLKCFLAGS" \
|
CFLAGS="$SLKCFLAGS" \
|
||||||
CXXFLAGS="$SLKCFLAGS" \
|
CXXFLAGS="$SLKCFLAGS" \
|
||||||
./configure \
|
./configure \
|
||||||
|
@ -86,7 +87,7 @@ make install DESTDIR=$PKG
|
||||||
|
|
||||||
rm -rf $PKG/usr/local
|
rm -rf $PKG/usr/local
|
||||||
|
|
||||||
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
|
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
|
||||||
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
||||||
|
|
||||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||||
|
|
10
system/hardinfo/makefile.patch
Normal file
10
system/hardinfo/makefile.patch
Normal file
|
@ -0,0 +1,10 @@
|
||||||
|
--- hardinfo-0.5.1/Makefile.in.old 2015-12-19 09:39:19.955074713 +0700
|
||||||
|
+++ hardinfo-0.5.1/Makefile.in 2015-12-19 09:39:40.254827496 +0700
|
||||||
|
@@ -1,6 +1,6 @@
|
||||||
|
|
||||||
|
CCFLAGS = -fPIC -pipe -Wall -g
|
||||||
|
-CFLAGS = $(GTK_CFLAGS) $(SOUP_CFLAGS) -I.
|
||||||
|
+CFLAGS = $(GTK_CFLAGS) $(SOUP_CFLAGS) -I. -std=gnu89
|
||||||
|
CC = gcc $(ARCHOPTS) -g
|
||||||
|
CCSLOW = gcc -O0 -g
|
||||||
|
|
Loading…
Reference in a new issue